X
Tap here to go to the mobile version of the site.

Support Forum

So how do I REALLY get the toolbar buttons to just show icons (and not text)?

Posted

On my Bookmarks toolbar, my bookmarks "buttons" show icon AND text. I just want to show icon, not text. When I go right-click.....customize, the window "customize toolbars" opens. Down in the bottom left corner the "show" option dropdown is already set to "icons" (and only icons). But it's just not so. The toolbar buttons show icons AND text. If I cycle through that dropdown just for kicks, it doesn't change; I can choose "icons (only)" all day long, but the toolbar buttons still show text.

On my Bookmarks toolbar, my bookmarks "buttons" show icon AND text. I just want to show icon, not text. When I go right-click.....customize, the window "customize toolbars" opens. Down in the bottom left corner the "show" option dropdown is already set to "icons" (and only icons). But it's just not so. The toolbar buttons show icons AND text. If I cycle through that dropdown just for kicks, it doesn't change; I can choose "icons (only)" all day long, but the toolbar buttons still show text.

Modified by dotdot

Chosen solution

Hello dotdot, try the next, right-click on a bookmark and select Properties, then clear the name of the bookmark and save it.


thank you

Read this answer in context 3

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Next Generation Java Plug-in 10.11.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape "9.5.3"
  • iTunes Detector Plug-in
  • Google Update
  • 5.1.10411.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.4.634
  • DivX Plus Web Player version 2.2.0.52
  • GEPlugin
  • DivX VOD Helper Plug-in
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • MetaStream 3 Plugin r4

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

ideato
  • Top 25 Contributor
694 solutions 5063 answers

Chosen Solution

Hello dotdot, try the next, right-click on a bookmark and select Properties, then clear the name of the bookmark and save it.


thank you

Hello dotdot, try the next, right-click on a bookmark and select Properties, then clear the name of the bookmark and save it. thank you
the-edmeister
  • Top 10 Contributor
  • Moderator
3882 solutions 29363 answers

Icons [only] doesn't apply to bookmarks, the Bookmarks Toolbar Items part of the Bookmarks Toolbar doesn't work the same as the rest of the Bookmarks Toolbar or the same as the other Toolbars, You need to do the work-around that ideato mentioned.

'''Icons''' ''[only]'' doesn't apply to bookmarks, the '''''Bookmarks Toolbar Items''''' part of the Bookmarks Toolbar doesn't work the same as the rest of the Bookmarks Toolbar or the same as the other Toolbars, You need to do the work-around that '''''ideato''''' mentioned.
TheOldFox 86 solutions 620 answers

Helpful Reply

Either of the following Add-ons allow you to show icons only and/or to have multiple rows on the Bookmarks Toolbar. Set the options on either after installation.




Other - Check your Plugins and update as needed.

  1. Check your Plugins - https://www.mozilla.org/en-US/plugincheck/
  2. Adobe Shockwave for Director Netscape plug-in, version 11.6.4.634 (this old version has security issues)
Either of the following Add-ons allow you to show icons only and/or to have multiple rows on the Bookmarks Toolbar. Set the options on either after installation. *Multirow Bookmarks Toolbar Plus - https://addons.mozilla.org/en-US/firefox/addon/multirow-bookmarks-toolbarplus/ *Roomy Bookmarks Toolbar - https://addons.mozilla.org/en-US/firefox/addon/roomy-bookmarks-toolbar/ ---------------------------------- Other - Check your Plugins and update as needed. #Check your Plugins - https://www.mozilla.org/en-US/plugincheck/ #'''''Adobe Shockwave for Director Netscape plug-in, version 11.6.4.634''''' (this old version has security issues) #*http://kb.mozillazine.org/Shockwave #*Download, save, close all browsers, run the installer you downloaded - http://get.adobe.com/shockwave/thankyou/

Question owner

I like the multirow, OldFox, thanks for the tip. I'd already deleted the text from most of my "buttons" when your solution came in. Too bad for me. Had I known about multirow first, I'd not have deleted some of the text/names. The autohide of multirow is really nice, and better - I think - than simply adding more toolbars per Firefox' standard "add new toolbar" routine. Thanks.

I like the multirow, OldFox, thanks for the tip. I'd already deleted the text from most of my "buttons" when your solution came in. Too bad for me. Had I known about multirow first, I'd not have deleted some of the text/names. The autohide of multirow is really nice, and better - I think - than simply adding more toolbars per Firefox' standard "add new toolbar" routine. Thanks.

Question owner

Thanks Ideato. I already knew how to do this "delete-one-button-at-a-time" routine. I had hoped there was a more streamlined way such as the one offered by that other popular browser by that other software company. Especially since one opens up that customize window and there's a setting there that leads one to believe that it should work.

Thanks Ideato. I already knew how to do this "delete-one-button-at-a-time" routine. I had hoped there was a more streamlined way such as the one offered by that other popular browser by that other software company. Especially since one opens up that customize window and there's a setting there that leads one to believe that it should work.

Modified by dotdot

cor-el
  • Top 10 Contributor
  • Moderator
12018 solutions 111660 answers

Helpful Reply

You can also do this with code in the userChrome.css file below the default @namespace line.

The customization files userChrome.css (interface) and userContent.css (websites) are located in the chrome folder in the user profile folder.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

#personal-bookmarks .bookmark-item > .toolbarbutton-text { display:none !important; }
You can also do this with code in the userChrome.css file below the default @namespace line. *http://kb.mozillazine.org/userChrome.css The customization files userChrome.css (interface) and userContent.css (websites) are located in the chrome folder in the user profile folder. *http://kb.mozillazine.org/Editing_configuration ----- <pre><nowiki>@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */ #personal-bookmarks .bookmark-item > .toolbarbutton-text { display:none !important; } </nowiki></pre>
Ch4rd 0 solutions 1 answers

In addition to cor-el's solution, if you do not have the userChrome.css file, you can create it yourself.

Open a new text file in notepad or similar program, paste the code in cor-el's post, and save the file as userChrome.css in a folder called "chrome" in your profile folder.

In addition to cor-el's solution, if you do not have the userChrome.css file, you can create it yourself. Open a new text file in notepad or similar program, paste the code in cor-el's post, and save the file as userChrome.css in a folder called "chrome" in your profile folder.
cor-el
  • Top 10 Contributor
  • Moderator
12018 solutions 111660 answers

Make sure that you select "All files" when saving the file in Notepad.
If you save the file as a Text file then a (possibly hidden) .txt file extension can be added.

Make sure that you select "All files" when saving the file in Notepad.<br /> If you save the file as a Text file then a (possibly hidden) .txt file extension can be added.