Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

when I visit this site https://eopf.usps.gov/eOPF/jsp/essLogin.jsp it will ask me to update safari browser. I am using the current version of FF on a macbook.


using ff 18.0.1 on a mac book pro. When visiting this site https://eopf.usps.gov/eOPF/jsp/essLogin.jsp it tells me to use Safari 2.0.4 or higher.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.8
  • Displays Java applet content, or a placeholder if Java is not installed.


  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

finitarry 157 solutions 2178 answers

They are out of date. Safari versions have gone past that version long ago. What happens if you use Safari from Mac OS?

What happens if you use a fake Safari user-agent thru the extension User Agent Switcher?

Modified by finitarry

Question owner

"What happens if you use a fake Safari user-agent thru the extension User Agent Switcher? " not sure where that is in FF.

With Safari site works fine.

Ok found the user agent switcher add on. Tried it using IE but it now says I need javascript enabled.

Modified by bosbruins11

finitarry 157 solutions 2178 answers

Why not download and import a list of user agents available for User Agent Switcher and use a fake Safari user-agent? That way, you will not be asked for Active X. There is a large list of such user-agents available from a link in the extension's Edit User Agents window. Download the list and import it.

Question owner

OK so downloaded and imported the list but no luck. Doesnt work using the Opera browser either. I am trying to use FF for everything but not going to be able to I suppose.

  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Helpful Reply

Try to create this String pref to override the user agent (no extension required) and see if the site works.




.*#Mozilla 5.0 (Macintosh; U; Intel Mac OS X 10_8; en-us) AppleWebKit/531.21.8 (KHTML, like Gecko) Version/4.0.4 Safari/531.21.10

Close and restart Firefox

I had that Safari user agent (probably outdated) in my docs, but I do get the login form on Linux.

You can open the Web Console (Web Developer > Web Console;Cmd+Shift+K) with the page on display and enter this debug code on the command line and press enter:


If you have the general.useragent.override pref set then reset this pref to the default value to remove it.

Modified by cor-el

Question owner

cor-el it worked!!! Thank You.

But after several visits I now get a missing plug ins window.

Modified by bosbruins11