Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How to prevent a site from ever reappearing in address bar drop-down list?


There are a couple sites I don't ever want to appear in the drop down list. Every time I notice one of them I delete it (by pointing with mouse and hitting delete), but it will just reappear another day (most likely after visiting the site). I want to permanently prevent it from ever reappearing again later, how do I do that?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.5
  • IE Tab 2 Plug-in for Mozilla/Firefox
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Google Update
  • 4.1.10329.0
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • ActiveTouch General Plugin Container Version 105
  • Logitech Harmony Remote Plugin
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin


  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:17.0) Gecko/20100101 Firefox/17.0

More Information

finitarry 157 solutions 2177 answers

You could delete the page from your history (and never visit it again).

Helpful Reply

Sorry, but that won't work. I do want to visit the site, I just want to prevent it from reappearing in the address bar drop down list.

finitarry 157 solutions 2177 answers

I do not think there is any way to do that unless you set the location bar setting to show nothing (from Options > Privacy), or visit that site in Private Browsing mode.

  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers


Question owner

Thanks for suggesting private browsing. Although it does more than I want (for example it won't cache or keep cookies) it might have been okay for me... other than the fact it closed all my other tabs. I even opened another instance (window) of firefox and when I put that one into private, it closed my other one.

I think I'm just out of luck. Actually while typing this response and trying another window, I thought of a workaround.. I could just use another browser (chrome or whatever) for visiting sites I don't want firefox to remember.

  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

Future Firefox versions will have a PB mode per window.

See also:

Question owner

Much thanks! Historyblock is my solution. The only thing better would be if it still kept cache/cookies, but I'll live w/o those.