X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

firefox is unable to load Mega?

Posted

ok, this is my problem. i want to load some files to the Mega filesystem (mega.co.nz) but the page doesn't load (Timeout error), sometimes it loads but when i want to upload files, a pop-up appears telling me that my web browser is outdated, and i should try using chrome, ok, i have installed chrome, and the upload works perfectly, but i dislike chrome because some of it functions, there is any way to load files to Mega using firefox?

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.10.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.5 r502
  • Unity Player 3.5.6f4
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.6.636
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • Battlefield Play4Free Updater
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • np-mswmp

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

ideato
  • Top 25 Contributor
616 solutions 4260 answers

Hello UMadMan, try https://mega.co.nz/


thank you

chiaroscuro 0 solutions 5 answers

I have the same problem - Firefox 18.0.1 - Windows 7 pro. I try https://mega.co.nz/ , and it loads most of the page (I can see the source) but it never renders the page - just a white screen with a grey horizontal (progress?) bar. No error messages, I tried it in "safe" mode, cleared my cache, - nothing. At the bottom bar it says "transferring data from mega.co.nz ..."

Chrome loads the page fine, but I don't like chrome.

chiaroscuro 0 solutions 5 answers

Can you post it to a site that doesn't make me take a marketing survey to download the file? I'm not giving spammers my email address.


EDIT* Since it seems like I can't delete this post, it was in answer to some "top 10 contributor" who posted a link to a .pdf file on a site that wants you to take a survey and give your email address to download a file! He then deleted the post.

Modified by chiaroscuro

odradek2298 0 solutions 1 answers

The same problem. Use Firefox 18.0.1

https://mega.co.nz/#blog_1 Mozilla Firefox 18: Carefully avoids providing any API that would allow writing files from JavaScript.

wheng 0 solutions 3 answers

I have the same problem as chiaroscuro has (just a white screen with a grey horizontal (progress?) bar)

SaphirJD 0 solutions 22 answers

Do not know if that is the reason, but it is said Mega Site creators have made the site mostly compatible with google chrome...

There is a firefox mega plugin available, take a look :)

wheng 0 solutions 3 answers

Thx for the reply SaphirJD.

There idd is a problem it seems with uploading and downloading files from Mega with Firefox, but the problem stated here is that the site just won't open. I have the plugin but the plugin won't work if the site does not even open :)

SebastianA 0 solutions 1 answers

I'm getting a similar issue, but in the last day or two an error (of some sort) has started appearing when I try to access mega.co.nz.

"Your browser does not allow data to be written. Please make sure you use default browser settings."

Clicking OK on that comes up with a big "Download Chrome!" prompt so yeah no.

Firefox 18.0, tried disabling addons like greasemonkey and adblock, and enabled flash and java, no difference.

I do like to mess around in about:config but not without valid reasons, so I have no idea which (if any) of the things I've changed cause this. It's happening on my work laptop and home desktop so it's not something random, it's some intentional change it's not liking.

Is it possible that it's due to disabling or blocking flash supercookies?

edit: Just tried allowing sites to store data in Flash but no change.

Modified by SebastianA

chiaroscuro 0 solutions 5 answers

SebastianA, I just retried it, and got the same message as you described. Previously I got the blank screen (see above). Maybe Mega has added an error msg. for the problem I was having before? Can anyone here access the site with FF 18.0.2?

I'd switch to Chrome in a minute, if their handling of bookmarks wasn't so wonky.

chiaroscuro 0 solutions 5 answers

OK, I figured it out - at least on my system, which is Win7 Pro, Firefox 18.0.2.

I went in and initialized the config file by renaming 'prefs.js', which starts out like a first time install of FF. It did reload all my plugins though, which was nice. Lo and behold, Mega loaded just like in Chrome - I was able to sign in to my account, upload and download files. Then I went into the FF preferences and set everything the way I like it, and I broke it again. I tried again with prefs.js.

Getting to the point, I determined that the problem was that under the 'privacy' panel in 'tools/options' I had third party cookies set to 'ask me every time', which is how I have had it set for years. I set it to clear them when FF closes and it worked again.

This setting also made it impossible to play videos on vimeo.com.

Also if you are running the 'noscript' plugin, you should allow the whole site.

I hope this works for some of you others.

Modified by chiaroscuro

cor-el
  • Top 10 Contributor
  • Moderator
10740 solutions 96657 answers

Note that such cookie issues can be caused because Firefox created an allow exception for a sub domain (xxx.mega.co.nz) of the website instead of for the main domain (mega.co.nz).
The solution in such a case is to create an allow exception yourself for the main domain.

The mega.co.nz server also makes use of a 128 bit RC4 cipher to connect securely instead of a 256 bit connection and doesn't work with all 128 bit ciphers disabled, so the server software could benefit from an update.

qwerty123456 0 solutions 1 answers

Helpful Reply

The "Your browser does not allow data to be written. Please make sure you use default browser settings." error can be solved. Go to about:config and change dom.storage.enabled to true. https://mega.co.nz use supercookies.

Modified by qwerty123456