X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I don't use a proxy server to connect to the internet, but Firefox automatically configures itself to use the loopback address.

Posted

I have a direct connection to the internet and don't use a proxy server. Every few weeks, Firefox automatically resets itself to be configured to use a proxy server at the loopback address (127.0.0.1). Manually changing it back to "No proxy" works, but I have to do so each time I open the browser or even a new tab. The only fix I can find is to create a new profile which gives me a new, clean install of FF, but then I lose all my add-ons. This has happened repeatedly now and it's extremely frustrating. I have scanned for malware but have not found any problems.

Chosen solution

hello rjlasser, first of all please make sure that none of your extensions is causing the issue (some youtube censorship circumvention addons also make use of proxies for example).

otherwise please refer to How to fix preferences that won't save for some common solutions.

Read this answer in context 0

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.52 Safari/537.17

More Information

philipp
  • Top 10 Contributor
  • Moderator
2043 solutions 8891 answers

Chosen Solution

hello rjlasser, first of all please make sure that none of your extensions is causing the issue (some youtube censorship circumvention addons also make use of proxies for example).

otherwise please refer to How to fix preferences that won't save for some common solutions.

Question owner

Actually that did it. It was the FiddlerHook extension that enables me to use Firefox with Fiddler. Once I disabled this extension, problem solved!

Thank you very much!