X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox 18 US-english on SuSE Linux does not work

Posted

Hi,

running Firefox 17.0.1 on my SuSE Linux 11.2 works fine.

As I updated to Firefox 18.0 in Windows, I also downloaded the US-english version for Linux (firefox-18.0.tar.bz2) and unpacked it. The big disappointment: IT DOES NOT WORK!

XPCOMGlueLoad error for file /root/test/firefox/libxpcom.so: libxul.so: cannot open shared object file: No such file or directory Couldn't load XPCOM.

I removed the installation, restarted the system, installed again. No change. I tried the German package - the same problem.

What am I doing wrong? Is this a known issue? Any remedy?

Thanks, Tim Stoehr tstoehr@de.ibm.com

Chosen solution

Looking around in all the links sent to me from different people (thanks a lot!) I decided (had to!) to upgrade my system, maybe do a new install to what's current. Closing th issue.

Read this answer in context 1

Additional System Details

Application

  • User Agent: Mozilla/5.0 (X11; Linux i686; rv:17.0) Gecko/20100101 Firefox/17.0

More Information

XPCOMGlueLoad error for file /root/test/firefox/libxpcom.so:
libxul.so: cannot open shared object file: No such file or directory
Couldn't load XPCOM.

cor-el
  • Top 10 Contributor
  • Moderator
10780 solutions 97024 answers

Make sure that you meet the system requirements for the Firefox 18 version.

Question owner

Hi,

did the system requirements change since Firefox 17.0? I'm not sure how to check all these packages in my SuSE.

Tim

cor-el
  • Top 10 Contributor
  • Moderator
10780 solutions 97024 answers

Helpful Reply

The GLib requirement has changed to GLib 2.22 or higher.

Question owner

Thanks for the answer.

My SuSE 11 is using glib2 2.18.2 (glib is not installed).

I'm not sure which implications I'ld generate updating glib2 to 2.22.

So in summary, is it true that my installation is too old for Firefox 18?

Tim

James
  • Top 25 Contributor
  • Moderator
437 solutions 3164 answers

The openSUSE 11.2 should work fine if updated as I was using 11.2 for a long while on my old computer until a couple weeks ago as I did not really want to use the Gnome 3 that was in openSUSE 11.3 and newer as the 11.3 and newer Gnome LiveCDs were slow compared to 11.2 and older cds. Currently mainly use XFce on 12.2 as Gnome 3 and fallback sucks.

I was using more bleeding edge versions of Firefox then 18.0 on openSUSE 11.2

Problem is openSUSE 11.2. Is not really supported anymore also as many of my normal package sources stopped working.

jujube67 0 solutions 1 answers

Helpful Reply

@tstoehr:

Did you try the Firefox RPMs specifically built for openSUSE 11.2? You might have better luck with them.

Check this page out for some add'l package repos (including ones for Mozilla, including v18.0): http://en.opensuse.org/Additional_package_repositories

Now openSUSE 11.2 is a bit older, so the links on this page for openSUSE 11.2 for Mozilla don't appear, but they still exist and use the same structure (and appear to be maintained still, which is good :-):

http://download.opensuse.org/repositories/mozilla/openSUSE_11.2/

So, to add the repo on openSUSE 11.2, A). You can use YaST to add it --OR-- B). You can do it via the command line:

     1). open up a command window/terminal
     2). 'su' to root
     3). enter the following command:

zypper ar -f -n firefox http://download.opensuse.org/repositories/mozilla/openSUSE_11.2/

NOTE: If you're not familiar with adding a repo to openSUSE, you can find more info on that at opensuse.org or here's a link which may be helpful -- http://www.linux.com/learn/tutorials/225596-enhancing-opensuse-112-adding-repositories-and-packages-

Hope this helps...

-jjb

cor-el
  • Top 10 Contributor
  • Moderator
10780 solutions 97024 answers

See also http://en.opensuse.org/openSUSE:Evergreen

Question owner

Thanks a lot for the links (sorry to come back so late to you, I was on a class). I found the openSuSE_11.2 repository. Too bad my system is even older than I thought it is - it's openSuSE 11.1.

So I think this is the final hint to update the system.

Tim

Chosen Solution

Looking around in all the links sent to me from different people (thanks a lot!) I decided (had to!) to upgrade my system, maybe do a new install to what's current. Closing th issue.