X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Newest Firefox 18 has problems with applying proxy settings from system

Posted

After upgrade to Firefox 18 system proxy settings don't work correctly. At the same time, Firefox 17, IE and Opera work as expected. I guess, this is a newly introduced bug. Could you please check it?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Next Generation Java Plug-in 10.10.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.6.636
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • 5.1.10411.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:17.0) Gecko/17.0 Firefox/17.0

More Information

Cannot provide Troubleshooting info because downgraded Firefox 18 to 17. My OS is Windows XP SP3, x86

philipp
  • Top 10 Contributor
  • Moderator
2046 solutions 8901 answers

hello maxvor, there are some proxy related bugs in firefox 18 (but when i remember correctly most of them affected linux & osx systems) which will be addressed in a firefox 18.0.1 release soon, you might want to look out for that...

lcbj 0 solutions 1 answers

I noticed a lag in pages loading in FF 17.0.2 immediately after the most recent Windows update so I installed FF 18. As soon as it installed pages would not load at all and when I checked support it said that my antivirus program was probably blocking it and I should make the new FF an exception. I then discovered that my Norton Internet Security 2011 had been completely wiped out. I had to completely uninstall and reinstall Norton. Then I uninstalled FF 18 and went back to 17.0.2 and now everything is working fine.

DerlinStiles 0 solutions 1 answers

Helpful Reply

I am also having this issue- every FF install that has been updated to 18.0 stops working (XP machines). Never had this issue with FF before, or any other browser. When I remove the proxy settings (uncheck "use system proxy settings") on any of these machines, FF begins working immediately.

lucr 0 solutions 1 answers

It looks like the myIpAddress() function is missing, causing proxy.pac to fail.

Tyler Downer
  • Administrator
  • Moderator
1165 solutions 6642 answers

Firefox 18.0.1 is now live, and it fixes the proxy issues found in Firefox 18. Please update to that version.

tjdarth 0 solutions 7 answers

FF 18.0.1 still does not resolve the proxy issue. When I initially open FF I have to reset the proxy configuration to 'No Proxy' because FF 18 always selects the 'Manual Proxy Configuration' when the application is closed and reopened?! Can this be corrected . . .

Thanks in advance . . . Love my Functional FF

philipp
  • Top 10 Contributor
  • Moderator
2046 solutions 8901 answers

tjdarth, please see How to fix preferences that won't save

tjdarth 0 solutions 7 answers

Helpful Reply

My experience shows that Windows has the same problem as well. I have an 8gb machine Win 7 64Bit OS. It appears that this problem has been passed from 18.0 thru 18.0.1. I have normally chosen the 'No Proxy' option in prior versions. But since the introduction of 18.0, I briefly had the proxy problem but it was quickly resolved from the developers of this app. I allow FF to auto dl and install so when 18.0.1 was installed and this problem reappeared, I knew someone had to have picked up a prior module or something and reintroduced the same problem all over again.

Can anyone share a timeframe for resolving this issue?

Thanks in advance . . . TomJ

tjdarth 0 solutions 7 answers

Thanks madperson for this clue. I followed the info layed out from the link and when I examine the 'user.js" I don't find an entry that relates to the proxy. I am including the lines I find in ths file for your review. Please let me know if you see anything out of the ordinary that may be relevant:

user_pref("extentions.y2layers.installId", "84243a30-df8b-461b-8a35-e7272b89ebab"); user_pref("extentions.y2layers.defaultEnableAppsList", "DropDownDeals,buzzdock,YontooNewOffers");

user_pref("extensions.autoDisableScopes", 14); user_pref("extensions.BabylonToolbar.tlbrSrchUrl", "http://search.babylon.com/?babsrc=TB_def&mntrId=00ffbd6d000000000000446d57b2a6bd&q="); user_pref("extensions.BabylonToolbar.id", "00ffbd6d000000000000446d57b2a6bd"); user_pref("extensions.BabylonToolbar.appId", "{BDB69379-802F-4eaf-B541-F8DE92DD98DB}"); user_pref("extensions.BabylonToolbar.instlDay", "15633"); user_pref("extensions.BabylonToolbar.vrsn", "1.8.3.8"); user_pref("extensions.BabylonToolbar.vrsni", "1.8.3.8"); user_pref("extensions.BabylonToolbar_i.vrsnTs", "1.8.3.813:46:58"); user_pref("extensions.BabylonToolbar.prtnrId", "babylon"); user_pref("extensions.BabylonToolbar.prdct", "BabylonToolbar"); user_pref("extensions.BabylonToolbar.aflt", "babsst"); user_pref("extensions.BabylonToolbar_i.smplGrp", "none"); user_pref("extensions.BabylonToolbar.tlbrId", "base"); user_pref("extensions.BabylonToolbar.instlRef", "sst"); user_pref("extensions.BabylonToolbar.dfltLng", "en"); user_pref("extensions.BabylonToolbar.excTlbr", false); user_pref("extensions.BabylonToolbar.admin", false);

BTW: I am curious as to where the "BabylonToolbar" comes from because I have no toolbar by this name.

Thanks in advance . . .

TomJ

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

You should delete that user.js file.
It shouldn't be there and the presence of babylon lines indicate that you are infected by Babylon and that software has created this file.

tjdarth 0 solutions 7 answers

Thanks cor-el, the info you supplied helped me clear up my FF 18.0.1 problems, especially with "Proxies"

Thanks . . . TomJ