X
Tap here to go to the mobile version of the site.

Support Forum

firefox doesn't recognize mms:// even gecko-mediaplayer is correctly installed and "network.protocol-handler.app.mms" is correctly set.

Posted

Firefox reports below message when I try to open "mms://live.hitfm.cn/fm887.wsx".

=

Firefox doesn't know how to open this address, because the protocol (mms) isn't associated with any program.

=

I have mplayer correctly installed and it is functional as I can play it by running "mplayer mms://live.hitfm.cn/fm887.wsx" on command line.

I have gecko media player 1.0.7 installed and I set below two confs in about:config, but it doesn't fix the issue.

network.protocol-handler.app.mms --> /usr/bin/mplayer network.protocol-handler.external.mms --> true

Firefox reports below message when I try to open "mms://live.hitfm.cn/fm887.wsx". =========== Firefox doesn't know how to open this address, because the protocol (mms) isn't associated with any program. =========== I have mplayer correctly installed and it is functional as I can play it by running "mplayer mms://live.hitfm.cn/fm887.wsx" on command line. I have gecko media player 1.0.7 installed and I set below two confs in about:config, but it doesn't fix the issue. network.protocol-handler.app.mms --> /usr/bin/mplayer network.protocol-handler.external.mms --> true

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.2 r202
  • Gecko Media Player 1.0.7Video Player Plug-in for QuickTime, RealPlayer and Windows Media Player streams using MPlayer
  • The next generation Java plug-in for Mozilla browsers.

Application

  • User Agent: Mozilla/5.0 (X11; Linux i686; rv:17.0) Gecko/20100101 Firefox/17.0

More Information

Application Basics
Name
Firefox
Version
17.0.1
User Agent
Mozilla/5.0 (X11; Linux i686; rv:17.0) Gecko/20100101 Firefox/17.0
Profile Directory
Open Directory
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Crash Reports
about:crashes
Memory Use
about:memory
Extensions
Name
Version
Enabled
ID
Awesome screenshot: Capture and Annotate
2.3.8
true
jid0-GXjLLfbCoAx0LcltEdFrEkQdQPI@jetpack
Firebug
1.10.6
true
firebug@software.joehewitt.com
FoxyProxy Standard
4.1
true
foxyproxy@eric.h.jung
JSONView
0.7
true
jsonview@brh.numbera.com
User Agent Switcher
0.7.3
false
{e968fc70-8f95-4ab9-9e79-304de2a71ee1}
Important Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.cache.disk.capacity
358400
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size.use_old_max
false
browser.cache.disk.smart_size_cached_value
358400
browser.history_expire_days.mirror
180
browser.places.importBookmarksHTML
false
browser.places.smartBookmarksVersion
4
browser.privatebrowsing.dont_prompt_on_enter
true
browser.startup.homepage_override.buildID
20121201141630
browser.startup.homepage_override.mstone
17.0.1
browser.tabs.autoHide
true
extensions.lastAppVersion
17.0.1
network.cookie.prefsMigrated
true
network.dns.disablePrefetch
true
network.protocol-handler.app.mms
/usr/bin/mplayer
network.protocol-handler.app.picasa
/opt/picasa/bin/picasa
network.protocol-handler.external.mms
true
network.protocol-handler.external.picasa
true
places.database.lastMaintenance
1356662310
places.history.expiration.transient_current_max_pages
26353
places.last_vacuum
1325898162
plugin.soname.list
libXt.so:libXext.so
privacy.cpd.cookies
false
privacy.cpd.downloads
false
privacy.cpd.formdata
false
privacy.cpd.history
false
privacy.sanitize.migrateFx3Prefs
true
privacy.sanitize.timeSpan
0
security.OCSP.disable_button.managecrl
false
security.disable_button.openCertManager
false
security.disable_button.openDeviceManager
false
security.ssl3.ecdh_ecdsa_rc4_128_sha
false
security.ssl3.ecdh_rsa_rc4_128_sha
false
security.ssl3.ecdhe_ecdsa_rc4_128_sha
false
security.ssl3.ecdhe_rsa_rc4_128_sha
false
security.warn_viewing_mixed
false
Graphics
Adapter Description
X.Org R300 Project -- Gallium 0.4 on ATI RV370
Vendor ID
X.Org R300 Project
Device ID
Gallium 0.4 on ATI RV370
Driver Version
2.1 Mesa 9.0.1
WebGL Renderer
X.Org R300 Project -- Gallium 0.4 on ATI RV370 -- 2.1 Mesa 9.0.1
GPU Accelerated Windows
0
AzureCanvasBackend
none
AzureFallbackCanvasBackend
none
AzureContentBackend
none
JavaScript
Incremental GC
1
Accessibility
Activated
0
Prevent Accessibility
0
Library Versions
Expected minimum version
Version in use
NSPR
4.9.3
4.9.4
NSS
3.14.0.1 Basic ECC
3.14.1.0 Basic ECC
NSS Util
3.14.0.1
3.14.1.0
NSS SSL
3.14.0.1 Basic ECC
3.14.1.0 Basic ECC
NSS S/MIME
3.14.0.1 Basic ECC
3.14.1.0 Basic ECC

cor-el
  • Top 10 Contributor
  • Moderator
12306 solutions 113980 answers

You need to use this pref setting to make Firefox ask which application to use:

  • network.protocol-handler.expose.mms -> false
You need to use this pref setting to make Firefox ask which application to use: *network.protocol-handler.expose.mms -> false

Question owner

setting "network.protocol-handler.expose.mms -> false" doesn't help ...

setting "network.protocol-handler.expose.mms -> false" doesn't help ...
cor-el
  • Top 10 Contributor
  • Moderator
12306 solutions 113980 answers

Don't you get a pop-up to ask which application to use?

Did you remove the other mms prefs that you've created?

Try to delete the mimeTypes.rdf file in the Firefox Profile Folder to reset all file actions.

Don't you get a pop-up to ask which application to use? Did you remove the other mms prefs that you've created? Try to delete the mimeTypes.rdf file in the Firefox Profile Folder to reset all file actions. *http://kb.mozillazine.org/mimeTypes.rdf *http://kb.mozillazine.org/File_types_and_download_actions#Resetting_download_actions

Question owner

No pop-up at all.

I then removed other mms prefs in about:config, it ends with the same result (doesn't work).

I then tried delete mimeTypes.rdf in profile folder (with network.protocol-handler.expose.mms set to false in about:config) but it still doesn't fix the issue.

I then read about http://kb.mozillazine.org/mimeTypes.rdf and tried to manually add one entry for mms, it still doesn't work. (it is very possible that the entry I added is malformated so firefox doesn't recognize it).

Firefox keeps telling me it doesn't understand the protocol "mms", seems to me that firefox isn't checking all the user settings I add in about:config.

No pop-up at all. I then removed other mms prefs in about:config, it ends with the same result (doesn't work). I then tried delete mimeTypes.rdf in profile folder (with network.protocol-handler.expose.mms set to false in about:config) but it still doesn't fix the issue. I then read about http://kb.mozillazine.org/mimeTypes.rdf and tried to manually add one entry for mms, it still doesn't work. (it is very possible that the entry I added is malformated so firefox doesn't recognize it). Firefox keeps telling me it doesn't understand the protocol "mms", seems to me that firefox isn't checking all the user settings I add in about:config.
cor-el
  • Top 10 Contributor
  • Moderator
12306 solutions 113980 answers

Does Firefox ask which application to use if you set the network.protocol-handler.expose.mms pref to false?

Did you check the prefs on the about:config page to make sure that you do not have leftover prefs from previous attempts?

Does Firefox ask which application to use if you set the network.protocol-handler.expose.mms pref to false? Did you check the prefs on the <b>about:config</b> page to make sure that you do not have leftover prefs from previous attempts?

Modified by cor-el

Question owner

Firefox didn't pop up anything to ask which application to use at all, through all the tries I made.

I did check on about:config page to make sure there is only one setting for "mms" which is "network.protocol-handler.expose.mms".

I think I can give it another try by reset all settings to defaults and start over again, will update after I try when I have time.

Firefox didn't pop up anything to ask which application to use at all, through all the tries I made. I did check on about:config page to make sure there is only one setting for "mms" which is "network.protocol-handler.expose.mms". I think I can give it another try by reset all settings to defaults and start over again, will update after I try when I have time.

Question owner

Well I tried firefox (17.0.1) on windows xp and it pops up the "Launch Application" dialog asking me to choose an application to open mms://live.hitfm.cn/fm887.wsx, there isn't any settings related to mms in about:config. So firefox behaves differently on windows and linux when handling "unknown protocol".

Well I tried firefox (17.0.1) on windows xp and it pops up the "Launch Application" dialog asking me to choose an application to open mms://live.hitfm.cn/fm887.wsx, there isn't any settings related to mms in about:config. So firefox behaves differently on windows and linux when handling "unknown protocol".