X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Why does Google auto-complete fail in Firefox 17.0.1 when I type something in the search field there is no pull down list of options as I type?

Posted

When I type a word or term into the Google search bar the auto-complete fails; there is no pull down list of options for my search, only what I have completely typed in. I have to type in the complete word or term that I am searching for and then press return to get the results. I'm using a MacBook and OS X 10.7.5 Please help! This is so frustrating!

Chosen solution

It could be one of 3 things.

1. You turned off Show Suggestions inside the Google search bar.

To turn on Show Suggestions:
Click once inside the search bar then right-click inside the bar.
At the bottom of the right-click menu, choose Show Suggestions

2. If you are logged into your Google account, you may have set the option to disable autocomplete in the Google search settings.

Read this guide to find the settings area and check your settings:
http://turnoffgoogleinstant.blogspot.com/2012/02/screen-reader-users-click-here-to-turn.html

3. Or, you maybe have Javascript disabled inside Firefox. In case you were wondering, Javascript and Java are not the same thing. Java is a plugin used for online games and other applications.

To check if Javascript is on:
Firefox button > Options > Options > Content
Make sure there is a checkmark on "Enable Javascript"

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • iPhoto6
  • Displays Java applet content, or a placeholder if Java is not installed.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.5
  • Widevine Media Transformer Plug-In 5.0.0.4679
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:17.0) Gecko/20100101 Firefox/17.0

More Information

iamjayakumars
  • Top 10 Contributor
412 solutions 4877 answers

Please reload the webpage while bypassing the cache using one of the following steps:

  • Hold down the Shift key and click the Reload button with the left mouse key.

OR

  • Press Ctrl + F5 or Ctrl + Shift + R (Windows and Linux)
  • Press Command + Shift + R (Mac)

See if this helps solve the issues you had and please report back to us!

cor-el
  • Top 10 Contributor
  • Moderator
10739 solutions 96651 answers

You can check this:

Note that some Google pages may be using autocomplete=off to prevent Firefox from saving form data.

Question owner

I am sorry but this did not work. I did go into my Firefox Preferences and and I did make sure that the "Remember search and form history" box was checked, and it was. I also used the Command+ Shift+ R(Mac) as suggested and nothing changed other than refreshing the page that I was on. Still, when I type a term into the Google search box it does not auto-complete my word while typing nor does it give a list of options below as I type. This works fine on my desktop just not on my laptop.

cor-el
  • Top 10 Contributor
  • Moderator
10739 solutions 96651 answers

Note that websites may be using autocomplete=off to prevent Firefox from saving and filling autocomplete data as I posted above. Did you check for that?

You can remove autocomplete=off with a bookmarklet.

If a site uses autocomplete="off" then look at this article for a bookmarklet to remove the autocomplete attribute.

You can paste this code in the command line in the Web Console (Web Developer > Web Console; Ctrl+Shift+K) and press the Enter key to verify if there is an input field with autocomplete.

var c=0,e=document.querySelectorAll('input[autocomplete],form[autocomplete]'),T='\n';
for(i=0;E=e[i];++i){T+='['+(++c)+'] '+(E.name||'#'+E.id)+' ('+(V=E.getAttribute('autocomplete').toLowerCase())+')\n';}
console.log('autocomplete: '+c+T);

Question owner

Hi, Yes, I have tried that but it did not resolve the problem. My auto-fill works fine in fields such as username, passwords, addresses, etc. But my auto-complete in the search engine field does not work. I have updated to Firefox 18 and it still does not work. If I am searching for something I must type out the word completely. There are no suggestions or fill-ins as I type. If I do not type in specifically and completely what I want to search the auto-complete is no longer available to assist me. Like I have said, I am not having this problem on my desktop. Please help me this problem...!

Noah_SUMO
  • Moderator
50 solutions 303 answers

Chosen Solution

It could be one of 3 things.

1. You turned off Show Suggestions inside the Google search bar.

To turn on Show Suggestions:
Click once inside the search bar then right-click inside the bar.
At the bottom of the right-click menu, choose Show Suggestions

2. If you are logged into your Google account, you may have set the option to disable autocomplete in the Google search settings.

Read this guide to find the settings area and check your settings:
http://turnoffgoogleinstant.blogspot.com/2012/02/screen-reader-users-click-here-to-turn.html

3. Or, you maybe have Javascript disabled inside Firefox. In case you were wondering, Javascript and Java are not the same thing. Java is a plugin used for online games and other applications.

To check if Javascript is on:
Firefox button > Options > Options > Content
Make sure there is a checkmark on "Enable Javascript"

Modified by Noah_SUMO

Question owner

I turned on "Show Suggestions" by right-clicking inside of the search bar and it worked! Thank you so much Noah_SUMO.