X
Tap here to go to the mobile version of the site.

Support Forum

FF opens link in clipboard by surprise

Posted

If I have a link in the clipboard, anytime I scroll down with the touchpad there is a chance for Firefox to unexpectedly follow the link. But it's totally random. This is a problem, because it usually happens when I'm reading something and I have to go back and try to find what I was reading.

OS : Ubuntu 12.4.1 Windows : GNOME Fallback (Gnome 3 "Classic", with menu bar - no Shell)

If I have a link in the clipboard, anytime I scroll down with the touchpad there is a chance for Firefox to unexpectedly follow the link. But it's totally random. This is a problem, because it usually happens when I'm reading something and I have to go back and try to find what I was reading. OS : Ubuntu 12.4.1 Windows : GNOME Fallback (Gnome 3 "Classic", with menu bar - no Shell)

Chosen solution

That link maybe be opened because you middle click by accident.

See:

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 10.1 r102

Application

  • User Agent: Mozilla/5.0 (X11; Linux i686 on x86_64; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

Application: Firefox 18.0
User Argent: Mozilla/5.0 (X11; Linux i686 on x86_64; rv:18.0) Gecko/20100101 Firefox/18.
Extensions
Name : Version : Enabled: ID
Adblock Plus : 2.2.1 : true : {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
British English Dictionary : 1.19.1 : true : en-GB@dictionaries.addons.mozilla.org
Cuevana Stream : 3.1.5 : true : {a3a5c777-f583-4fef-9380-ab4add1bc2a8}
Diccionario español Argentina : 2.5 : true : es-AR@dictionaries.addons.mozilla.org
DownloadHelper : 4.9.12 : false : {b9db16a4-6edc-47ec-a1f4-b86292ed211d}
Firebug : 1.11.1 : false : firebug@software.joehewitt.com
NoScript : 2.6.4.1 : false : {73a6fe31-595d-460b-a920-fcc0f8843232}
Test Pilot : 1.2.2 : false : testpilot@labs.mozilla.com
Ubuntu Firefox Modifications : 2.6 : false : ubufox@ubuntu.com

Question owner

I forgot to mention that it also happens with a bookmark's keyword. So I can't have an "f" in my clipboard, unless I want to be interrupted by facebook.

I forgot to mention that it also happens with a bookmark's keyword. So I can't have an "f" in my clipboard, unless I want to be interrupted by facebook.
cor-el
  • Top 10 Contributor
  • Moderator
12127 solutions 112672 answers

Chosen Solution

That link maybe be opened because you middle click by accident.

See:

That link maybe be opened because you middle click by accident. See: *http://kb.mozillazine.org/middlemouse.contentLoadURL

Question owner

Thanks!!

Thanks!!
Yousef 13 solutions 71 answers

Helpful Reply

This has already been answered but I thought I should add to it.

On Linux, default middle mouse button behaviour is opening the link on the clipboard. To change this so it behaves like Windows:

Edit > Preferences > Advanced Tab > Tick "Use autoscrolling"

I've attached an images to show you where it is. Hope this helps!

This has already been answered but I thought I should add to it. On Linux, default middle mouse button behaviour is opening the link on the clipboard. To change this so it behaves like Windows: Edit > Preferences > Advanced Tab > Tick "Use autoscrolling" I've attached an images to show you where it is. Hope this helps!