X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Window Zoom Keyboard Shortcut Not Working (cmd+shift+m) Mac OS X

Posted

Hi, the keyboard shortcut cmd+shift+m works for most of my other applications, and it's listed in the Window menu item, but it's not working in Firefox. I should note that cmd+m does work to minimize the window. Also, clicking on the Zoom menu item works as intended, just not the keyboard shortcut.

Could use some advice. Thanks. :)

Mac OS X Mountain Lion with FF 17.0.1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Version 3.10.2.10212
  • Google Talk Plugin Video Accelerator version:0.1.44.23
  • Displays Java applet content, or a placeholder if Java is not installed.
  • Plugin that detects installed Citrix Online products (visit www.citrixonline.com).
  • WebEx64 General Plugin Container Version 202
  • 6.2.0.0
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • LogMeIn remote control components
  • Picasa plugin.
  • DivX Web Player version 2.0.0.263
  • iPhoto6

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:17.0) Gecko/20100101 Firefox/17.0

More Information

Ralph Daub
  • Administrator
58 solutions 431 answers

Hi drewdavid,

I am not sure that I understand your question correctly, but if you wish to zoom in and out of the webpages in Firefox, please try the following shortcuts:

  • Cmd + '+' for zooming in
  • Cmd + '-' for zooming out
  • Cmd + '0' for resetting the zoom

I hope this helps. Thanks!! - Ralph

Question owner

Hi and thanks for the reply.

Not referring to zooming within the browser, but rather maximizing the window to occupy the entire screen (not full screen view). I'm talking about the keyboard shortcut that corresponds to clicking on the green plus button in the top left of the window.

cmd+shift+m works for most Mac OS X applications, but not Firefox. Should this be submitted as a bug?

Again, clicking on the menu item Window and then Zoom works as intended, it seems that it's just the keyboard shortcut that is defunct.

Thanks I hope I was more clear this time. :)

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

Command + Shift + M is currently assigned to one of the web developer features.

Responsive Design View: command + shift + M

You can try to disable this feature by toggling the devtools.responsiveUI.enabled to false on the about:config page to see if that makes the shortcut work for the window zoom.

You may need to quit and restart Firefox to make the change effective.

Richieman 0 solutions 4 answers

I have the same problem and the solution provided doesn't solve the problem. On OSX you can assign any shortcut to any menu item through the Keyboard Preferences. Window\Zoom was assigned to Shift-Command-M, but I tried several other ones that I'm sure FF doesn't use for anything else.

When I press the shortcut, the Window menu-item lights up, which means it is recognized. But the browser window doesn't zoom.

Ralph Daub
  • Administrator
58 solutions 431 answers

Helpful Reply

Hi Richieman and Drewdavid,

I was able to replicate this issue even after creating a unique shortcut (Cmd+Shift+Ctrl+M), so I opened a bug to track this issue:

https://bugzilla.mozilla.org/show_bug.cgi?id=827652

Thanks so much for your reports!

- Ralph

Question owner

Thanks Ralph :)

Richieman 0 solutions 4 answers

As a work-around I created a QuickSilver trigger calling the MaximizeFrontWindow script. Seems to work fine.

Richieman 0 solutions 4 answers

Ralph, I've got two other issues. They are very related to this issue so I'm posting it here in the same Article, I hope that is ok.

The same problem occurs with the "Preferences..." shortcut. It is normally assigned to Command+, (comma). This also shows in the Firefox menu as such. When I depress the keys, The Firefox window lights up but no Preferences window appears. Instead, the text zooms out (same as Command-Minus. Again I reconfigured the shortcut through the Keyboard Preferences to something FF isn't using. The new shortcut doesn't show the Preferences, neither does it Zoom-out. The Firefox menu does light-up. The Command-Minus shortcut still zooms out, and no menuitem lights up.

Richieman 0 solutions 4 answers

Another problem has to do with the Shortcuts that are set to HTML elements with the "accesskey" attribute. For example if you go to this page:

http://en.wikipedia.org/wiki/Wikipedia:Keyboard_shortcuts

If you hoover over the "Edit" tab at the top, you'll see a tooltip telling you that you can press "Control+Option+E" to edit the page. If you do that, it works fine, now you are in Edit mode.

On the edit page, scroll down and hoover over the "Preview" button at the bottom, you'll see that the shortcut is "Control+Option+P".

Now comes the problem. Click somewhere in the textarea and press the Preview shortcut. Nothing happens.

Now click on the input box below "Edit summary" and press the shortcut. Again nothing happens.

Now click on text outside of the edit boxes. Press the shortcut. Now it works. You'll also notice that the shortcut actually inserted some special character  (it shows as a diamond with a question mark) that now shows up in the preview.

Are you able to reproduce these issues?

jasmine131092 0 solutions 1 answers

I have the same problem and the solution provided doesn't solve the problem. On OSX you can assign any shortcut to any menu item through the Keyboard Preferences. Window\Zoom was assigned to Shift-Command-M, but I tried several other ones that I'm sure FF doesn't use for anything else.

When I press the shortcut, the Window menu-item lights up, which means it is recognized. But the browser window doesn't zoom. ..................................................................

[Spam link removed by moderator. Please read Forum rules and guidelines, thanks.]

Modified by Chris Ilias