X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I WANT to open PDF in Adobe NOT FF but updates force me into FF

Posted

My FF decided on 12/1/2012 to open in browser, overriding my settings. No matter what I do, how I change settings, PDFs open in FF. I even totally uninstalled Acrobat 11 and reinstalled Acrobat 10. Still opens in browser (so does that mean it's FF causing the problem?)

My settings in FF were to open in Reader, overridden. Changed to save file. Overriden. No matter what I do, PDFs open in FF. My settings in FF for years have been to open in Adobe, but now I cannot find the setting!

So now, haha, PDF opens in FF and FLASH is mucked up. So I've increased the problems and spent an hour and a half. Can you help? What am I (or they) doing wrong?

Chosen solution

EXcellent! That did it! I'd never have thought of that, but it's exactly what was wrong. I haven't used about:config much, so it never entered my mind! Bravo!

I really appreciate your help. Thanks again!

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Next Generation Java Plug-in 10.9.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • iTunes Detector Plug-in
  • Google Update
  • RealJukebox Netscape Plugin
  • RealNetworks(tm) RealPlayer Chrome Background Extension Plug-In
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 15.0.2.72
  • 5.1.10411.0
  • Picasa plugin
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.0
  • GEPlugin
  • Reader Library Helper Plugin
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • Office Plugin for Netscape Navigator

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

No matter what I do, how I change settings, PDFs open in FF. I even totally uninstalled Acrobat 11 and reinstalled Acrobat 10. Still opens in browser (so does that mean it's FF causing the problem?)
My settings in FF were to open in Reader, overridden. Changed to save file. Overriden. No
matter what I do, PDFs open in FF. My settings in FF for years have been to open in Adobe, but now I cannot find the setting!

philipp
  • Top 10 Contributor
  • Moderator
2046 solutions 8901 answers

hello PhineasBoggs, close firefox & open adobe acrobat, in there go to edit > preferences > internet and uncheck "display pdf in browser". when you start firefox again afterwards you might also want to try disabling the adobe pdf plugin in firefox > addons > plugins.

Question owner

Yes, I still have default in Acrobat 10 set not to display in browser, and I disabled the plugin when I exited from posting question and learned I had a Plugin (not an app). Still opens in browser.

Any other ideas? I'm all out and this is really getting on my nerves. Dunno what FF (or Adobe) did with updates.

Very frustrating! I'm a madperson too <g>

Thanks for answering!!

philipp
  • Top 10 Contributor
  • Moderator
2046 solutions 8901 answers

Helpful Reply

then maybe you're facing the inbuilt pdf reader in firefox that will land in future versions...

try this to switch it off: enter about:config into the firefox location bar (confirm the info message in case it shows up) & search for the preference named pdfjs.disabled. double-click it and change its value to true.

Chosen Solution

EXcellent! That did it! I'd never have thought of that, but it's exactly what was wrong. I haven't used about:config much, so it never entered my mind! Bravo!

I really appreciate your help. Thanks again!

Question owner

PS If the in-browser viewer weren't so crippled, I'd use it, but I can't search or highlight or many of the things I like to highlight.

Now I know and you made my day. I HATE failing to fix things!

philipp
  • Top 10 Contributor
  • Moderator
2046 solutions 8901 answers

actually pdf.js is an extraordinary piece of software - it just uses web-technology (html5, javascript) in order to render pdfs & doesn't come with a huge overload like the common other pdf plugins... it is still under very active development & there will be further improvements on the way (like a dedicated search button). at the moment you can use the default shortcut ctrl+f to search inside a document, but highlighting isn't possible as far as i know...

LotJim 0 solutions 1 answers

Helpful Reply

I solved it as follows:

  in Firefox go to Tools at the top of screen
  then go to Options in the pull down menu
  you will see lists of Contents and Actions
  go down Contents to Portable Document Format (PDF)
  go to Action column click on it a pull down menu will appear
  choose Adobe Reader (default)

that cured the problem for me.

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

Note that the latest version of the PDF viewer is available as an extension and does a better job than the 0.6.143 version shipped with Firefox 19 in a lot of cases.

You can find the latest version of the PDF Viewer (pdfjs) extension here: