Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

problems with Norton

  • 1 reply
  • 1 has this problem
  • 20 views
  • Last reply by James

more options

I have Norton confidential, antivirus and firewall on my Mac running 10.6.8. when I open Firefox, Norton tells me I cannot be protected while surfing the web; that I need 1.5 version.

However, the Firefox version installed on my computert says I have 1.9 yahoo users edition! I want to continue to use Firefox if at all possible (hate SAFARI) Thank you D Clippinger

All Replies (1)

more options

Is this with Norton Confidential?

It appears this is an old product that Norton killed off, which explains the out dated messages about Firefox 1.5. It has been replaced by Norton Identity Safe. https://identitysafe.norton.com/