X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

My.yahoo homepage is not displaying properly all of a sudden in windows 8

Posted

I don't think there was a change to my system unless it was a windows 8 update recently but my homepage, my.yahoo.com which I have been using for years is not displaying properly in Firefox oth 17.0 or beta release.

It works fine in chrome and IE on the same system.

Is this a issue with yahoo or Firefox? Any ideas on how to fix?

Chosen solution

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Bypass Firefox's Cache

Use Ctrl+Shift+r to reload the page fresh from the server.

(You also can clear Firefox's cache completely using:

orange Firefox button or Tools menu > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now")

(2) Remove your yahoo.com cookies (save any pending work first) using either of these. While viewing a page on the site:

  • right-click and choose View Page Info > Security > "View Cookies"
  • Alt+t (open the classic Tools menu) > Page Info > Security > "View Cookies"

Then try reloading the page. Does that help?

Read this answer in context 5

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.95 Safari/537.11

More Information

Downloaded beta version of FF. no change.

jscher2000
  • Top 10 Contributor
2357 solutions 20874 answers

Chosen Solution

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Bypass Firefox's Cache

Use Ctrl+Shift+r to reload the page fresh from the server.

(You also can clear Firefox's cache completely using:

orange Firefox button or Tools menu > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now")

(2) Remove your yahoo.com cookies (save any pending work first) using either of these. While viewing a page on the site:

  • right-click and choose View Page Info > Security > "View Cookies"
  • Alt+t (open the classic Tools menu) > Page Info > Security > "View Cookies"

Then try reloading the page. Does that help?

Question owner

I did exactly as you wrote and yes it did solve the problem.

Thank you so much.