X
Tap here to go to the mobile version of the site.

Support Forum

Firefox 17 scrolling is much slower than Firefox 16 on Windows 8

Posted

I upgraded a few weeks ago to Windows 8 and that time I was mainly using Aurora. After updating to 8, the scrolling was much laggier than Windows 7. At that time Firefox 15 or 16 was out. I then switched to Firefox 16 later and found that there was no lag in the scrolling. FPS was probably higher. Then Firefox 17 came out and it started to have the same affect as Aurora, sluggish and slow.

I have no idea what happened because I had the same addons, just switch between Aurora and Firefox 16 and I can tell the difference. However FPS are better in Aurora and Firefox 17 if you make the browser window smaller (so not maximize).

Initially you will not see lag, but if you use them sequentially, then you can tell the difference. Lag appears on heavier websites and the addons page.

I upgraded a few weeks ago to Windows 8 and that time I was mainly using Aurora. After updating to 8, the scrolling was much laggier than Windows 7. At that time Firefox 15 or 16 was out. I then switched to Firefox 16 later and found that there was no lag in the scrolling. FPS was probably higher. Then Firefox 17 came out and it started to have the same affect as Aurora, sluggish and slow. I have no idea what happened because I had the same addons, just switch between Aurora and Firefox 16 and I can tell the difference. However FPS are better in Aurora and Firefox 17 if you make the browser window smaller (so not maximize). Initially you will not see lag, but if you use them sequentially, then you can tell the difference. Lag appears on heavier websites and the addons page.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • VLC media player Web Plugin 2.0.2

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0

More Information

Application Basics
Name
Firefox
Version
17.0
User Agent
Mozilla/5.0 (Windows NT 6.2; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0
Profile Folder
Show Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Crash Reports
about:crashes
Memory Use
about:memory
Extensions
Name
Version
Enabled
ID
Adblock Plus
2.1.2
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
Download Statusbar
0.9.10
true
{D4DD63FA-01E4-46a7-B6B1-EDAB7D6AD389}
DownThemAll!
2.0.15
true
{DDC359D1-844A-42a7-9AA1-88A850A938A8}
Firebug
1.10.6
true
firebug@software.joehewitt.com
Firefox OS Simulator
0.7
true
r2d2b2g@mozilla.org
FireGestures
1.6.18
true
firegestures@xuldev.org
Firepicker
1.4.2
true
firepicker@thedarkone
Flashblock
1.5.15.1
true
{3d7eb24f-2740-49df-8937-200b1cc08f8a}
FlashGot
1.4.8.5
true
{19503e42-ca3c-4c27-b1e2-9cdb2170ee34}
Greasemonkey
1.4
true
{e4a8a97b-f2ed-450b-b12d-ee082ba24781}
Hide Find Bar
1.3.1
true
hidefindbar@jaredmcateer.com
InstantFox
2.7.6
true
searchy@searchy
JS Deminifier
1.0.7
true
jsdeminifier@murphy.ben.name
keyconfig
20110522
true
keyconfig@dorando
Memory Fox
7.4
true
{E173B749-DB5B-4fd2-BA0E-94ECEA0CA55B}
Personal Menu
5.1.0
true
CompactMenuCE@Merci.chao
Skip Addon Compatibility Check
2
true
skip_compatibility_check@sdrocking.com
Stylish
1.3
true
{46551EC9-40F0-4e47-8E18-8E5CF550CFB8}
Stylish Sync
0.1.4
true
{0e3fc079-afbb-4a00-87e5-9486062d0f9c}
Theme Font & Size Changer
6.1
true
{f69e22c7-bc50-414a-9269-0f5c344cd94c}
Tile Tabs
8.1
true
tiletabs@DW-dev
Tweak Network
1.5.4
true
{DAD0F81A-CF67-4eed-98D6-26F6E47274CA}
UI Fixer
1.4.4
true
ff4uifix@nikolakocic.com
X-notifier
3.0
true
{37fa1426-b82d-11db-8314-0800200c9a66}
FlashFirebug
4.54
false
flashfirebug@o-minds.com
Scriptish
0.1.8
false
scriptish@erikvold.com
Important Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.cache.disk.capacity
358400
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size.use_old_max
false
browser.cache.disk.smart_size_cached_value
358400
browser.places.smartBookmarksVersion
4
browser.startup.homepage
https://www.google.ca/
browser.startup.homepage_override.buildID
20121119183901
browser.startup.homepage_override.mstone
17.0
dom.disable_open_during_load
false
dom.mozApps.used
true
extensions.checkCompatibility.15.0
false
extensions.checkCompatibility.17.0a
false
extensions.checkCompatibility.18.0a
true
extensions.checkCompatibility.nightly
true
extensions.lastAppVersion
17.0
gfx.blacklist.direct2d
3
gfx.direct3d.prefer_10_1
true
network.cookie.prefsMigrated
true
network.http.max-connections-per-server
5
network.http.pipelining
true
network.http.proxy.pipelining
true
places.database.lastMaintenance
1354027290
places.history.expiration.transient_current_max_pages
104858
privacy.cpd.offlineApps
true
privacy.cpd.siteSettings
true
privacy.donottrackheader.enabled
true
privacy.sanitize.migrateFx3Prefs
true
privacy.sanitize.timeSpan
2
security.OCSP.enabled
0
security.warn_viewing_mixed
false
Graphics
Adapter Description
ATI Mobility Radeon HD 4670
Vendor ID
0x1002
Device ID
0x9488
Adapter RAM
1024
Adapter Drivers
aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
Driver Version
8.970.100.3000
Driver Date
7-3-2012
Direct2D Enabled
Blocked for your graphics driver version. Try updating your graphics driver to version > 12.8 or newer.
DirectWrite Enabled
false (6.2.9200.16433)
ClearType Parameters
ClearType parameters not found
WebGL Renderer
Blocked for your graphics driver version. Try updating your graphics driver to version > 12.8 or newer.
GPU Accelerated Windows
0. Blocked for your graphics driver version. Try updating your graphics driver to version > 12.8 or newer.
AzureCanvasBackend
cairo
AzureFallbackCanvasBackend
none
AzureContentBackend
none
JavaScript
Incremental GC
1
Accessibility
Activated
0
Prevent Accessibility
0
Library Versions
Expected minimum version
Version in use
NSPR
4.9.2
4.9.2
NSS
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS Util
3.13.6.0
3.13.6.0
NSS SSL
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS S/MIME
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC

cor-el
  • Top 10 Contributor
  • Moderator
11983 solutions 111361 answers

Helpful Reply

Try to disable hardware acceleration in Firefox.

Try to disable hardware acceleration in Firefox. *Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available" *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes *https://hacks.mozilla.org/2010/09/hardware-acceleration/
wigster 0 solutions 1 answers

Helpful Reply

I've messed around with various settings and seem to have solved the problem (Win 7x64, FF 18, NVidia v307 gfx drivers for a pretty old NVS 160m chipset). I used to have extremely slow scrolling and tab switching, while various graphics tests were quick.

Basically, I had to force FF to enable all the acceleration options. It should have been working out of the box, but it wasn't (maybe some kind of old settings?). So you need to set the following three options in about:config (type it into the address bar) to "true":

  • gfx.direct2d.force-enabled
  • layers.acceleration.force-enabled
  • webgl.force-enabled

Restart and it all seems to be fine, at least on my machine. It's worth looking at about:support in the Graphics table to see if things are enabled.

Hope it helps!

I've messed around with various settings and seem to have solved the problem (Win 7x64, FF 18, NVidia v307 gfx drivers for a pretty old NVS 160m chipset). I used to have extremely slow scrolling and tab switching, while various graphics tests were quick. Basically, I had to force FF to enable all the acceleration options. It should have been working out of the box, but it wasn't (maybe some kind of old settings?). So you need to set the following three options in ''' about:config ''' (type it into the address bar) to "true": * gfx.direct2d.force-enabled * layers.acceleration.force-enabled * webgl.force-enabled Restart and it all seems to be fine, at least on my machine. It's worth looking at '''about:support''' in the Graphics table to see if things are enabled. Hope it helps!

Modified by wigster

Question owner

Even with all the addons off, scrolling is slow. I found out that when enabling smooth scrolling, it slows down however once I turn it off, scrolling is still slightly slower than firefox 16. Also, when maximizing the window, most of the animations (new tab, scrolling etc) is slower than the window when not maximized.

I gave up and I am staying on Firefox 16.

Even with all the addons off, scrolling is slow. I found out that when enabling smooth scrolling, it slows down however once I turn it off, scrolling is still slightly slower than firefox 16. Also, when maximizing the window, most of the animations (new tab, scrolling etc) is slower than the window when not maximized. I gave up and I am staying on Firefox 16.
cor-el
  • Top 10 Contributor
  • Moderator
11983 solutions 111361 answers

Try to disable hardware acceleration in Firefox.

Try to disable hardware acceleration in Firefox. *Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available" *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes