X
Tap here to go to the mobile version of the site.

Support Forum

Why is the Motorola Admiral, which meets the requirements, not supported?

Posted

Unless I'm mistaken it has a resolution of 640x480, Qualcomm Snapdragon S2 MSM8655/1.2 GHz Scorpion which I believe uses ARMv7, Android OS v2.3.5, and 512 MB of RAM which seem to meet the requirements listed. Still listed as not compatible in the Play Store so it requires manual apk installation if you want to use it. Haven't had any issues with it and am looking into what causes the incompatibility.

Unless I'm mistaken it has a resolution of 640x480, Qualcomm Snapdragon S2 MSM8655/1.2 GHz Scorpion which I believe uses ARMv7, Android OS v2.3.5, and 512 MB of RAM which seem to meet the requirements listed. Still listed as not compatible in the Play Store so it requires manual apk installation if you want to use it. Haven't had any issues with it and am looking into what causes the incompatibility.

Chosen solution

This tracking bug may be in relation?.

Bug 810971 - Device on Google Play marked as incompatible despite being recently supported -- smallScreens manifest declaration change?

Read this answer in context 1

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.64 Safari/537.11

More Information

kbrosnan
  • Moderator
588 solutions 3864 answers

Helpful Reply

If you search the Play Store do you see Firefox?

Supported means that someone from the Mozilla team has physical access to a device.

If you search the Play Store do you see Firefox? Supported means that someone from the Mozilla team has physical access to a device.

Question owner

It is listed with "Your device isn't compatible with this version." So it can't be installed from the Play Store although it does seem to meet the requirements.

It is listed with "Your device isn't compatible with this version." So it can't be installed from the Play Store although it does seem to meet the requirements.
James
  • Moderator
1603 solutions 11348 answers

Chosen Solution

This tracking bug may be in relation?.

Bug 810971 - Device on Google Play marked as incompatible despite being recently supported -- smallScreens manifest declaration change?

This tracking bug may be in relation?. [https://bugzilla.mozilla.org/show_bug.cgi?id=810971 Bug 810971] - Device on Google Play marked as incompatible despite being recently supported -- smallScreens manifest declaration change?