X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Since updating from 16 to 17, desktop shortcuts created by dragging show generic Windows icon instead of Firefox-page icon.

Posted

Upon upgrading from FF 16 to 17, I can still drag the icon that's to the left of the url to the desktop (or even to the XP Quick Launch Bar, Folder Shortcuts, etc.) to create an internet shortcut to the current page. However, with 17 this method produces a shortcut that shows a generic Windows icon instead of a Firefox-page icon. Even though a generic Windows icon normally denotes "no program associated," these still open with FF when double-clicked. But it doesn't look right. (BTW, all the shortcuts created by this method in FF 16 or lower retained the FF-page icon with the upgrade to 17.)

Any ideas why this changed and how to fix it so it looks the same as before?

Pending resolution of this (and another issue) I went back to FF 16, and it works normally again. However, the shortcuts that were created while I had 17 still show the generic Windows icon.

fixed in Firefox 21 - locking this old thread

Modified by the-edmeister

Chosen solution

This issue has been finally addressed here: https://bugzilla.mozilla.org/show_bug.cgi?id=827784

An option "browser.shell.shortcutFavicons", accessible through about:config, has been added that allows one to choose the old behavior of using generic FF icon (thus without any favicon) for shortcuts created dragging an URL from the address bar to the desktop (or whatever other directory/folder).

I would like to publicly thanks Josh Yuan for coding and Brian R. Bondy for sponsoring this fix that will be issued with Firefox rev 21.

Apparently the fix is already available with Nightly releases.

Read this answer in context 8

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.6.636
  • Adobe PDF Plug-In For Firefox and Netscape "9.5.2"
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.5.635
  • IE Tab 2 Plug-in for Mozilla/Firefox
  • 6.0.12.709
  • Npdsplay dll
  • np-mswmp
  • Office Plugin for Netscape Navigator

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:16.0) Gecko/20100101 Firefox/16.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10780 solutions 97024 answers

Reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Press and hold Shift and left-click the Reload button.
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (MAC)
Firefoxer 0 solutions 11 answers

Finally. It's here with FF 21. You need to add the browser.shell.shortcutFavicons entry in about:config. It doesn't come with it. Make it boolean and set it to false. Restart FF.

smzit 1 solutions 7 answers

Confirmed: it's working but IMHO the fact that "browser.shell.shortcutFavicons" doesn't comes pre-configured in about:config makes this one of the most hidden options available in FF. I doubt that more than a handful of FF users (those who subscribed to this thread and the corresponding one in bugzilla) will ever be aware of it.

I'll ask in bugzilla to make it more visible.

cor-el
  • Top 10 Contributor
  • Moderator
10780 solutions 97024 answers
  • bug 827784 - Provide an option to disable favicons on webpage shortcuts in Windows
  • bug 828284 - Force shortcut desktop icons off on Windows XP

(please do not comment in bug reports: https://bugzilla.mozilla.org/page.cgi?id=etiquette.html)