X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

<Add-on> could not be installed because Firefox cannot modify the necessary file.

Posted

I see that for the issue:

<Add-on> could not be installed because Firefox cannot modify the necessary file.

The usual fixes include: - ensuring that xpinstall.enabled is set to true - ensuring that extensions.alwaysUnpack is set to true

What might be the non-usual fixes as I have set both to true and I still get the message above.

I have tried installing the <add-on> after I have set the values to true, then again after restarting my browser, then again after restarting my computer and finally tried creating a new profile and repeated each of the steps after setting the 2 preferences to true.

Additional System Details

Installed Plug-ins

  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Google Update
  • Next Generation Java Plug-in 1.6.0_35 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.3 r300
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.5.635
  • RealJukebox Netscape Plugin
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 6.0.12.1863
  • 5.1.10411.0
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.1
  • Citrix Receiver Plugin (Win32)
  • DRM Store Netscape Plugin
  • Npdsplay dll
  • DRM Netscape Network Object
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • np-mswmp
  • Office Plugin for Netscape Navigator
  • Tool bar for Image Web Server Images
  • Progress bar for Image Web Server Images
  • The ECW plugin allows you to view gigabyte size imagery over the internet. Visit http://www.ermapper.com for more information.
  • Macromedia Authorware Web Player Netscape plug-in, version 6.5 F1
  • Streaming 3D Viewer version 2.1 {#2100}
  • PLATINUM technology, inc. Plug-in for viewing 3D worlds authored in VRML

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:10.0.3) Gecko/20100101 Firefox/10.0.3

More Information

Windows XP and Firefox 10 (I cannot upgrade my browser to a new version)

cor-el
  • Top 10 Contributor
  • Moderator
10743 solutions 96657 answers

Can you at least update to the latest Firefox 10.0.10 ESR version?

Firefox 10.0.x ESR:


So a new profile with no other extensions didn't work as well?

Which extension is causing this problem or can't you install any extensions at all?