X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Multiple versions of Shockwave Director

Posted

I just updated Shockwave and now have three versions in my plugins: 11.6.5.636, 11.6.5.636 and 11.6.7.637. I can disable the two older, but not remove them.

Should I and how if so?

Thanks.

Chosen solution

Yes, you should remove the old ones if you can.

Firefox should reveal the full paths if you go through the following procedure.

(1) Re-enable the disabled plugins

(2) Turn on the plugin.expose_full_path setting here:

(i) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(ii) In the filter box, type or paste path and pause while the list is filtered

(iii) Double-click plugin.expose_full_path to switch its value to true

(3) In a new tab, open about:plugins. This page should list all of your Shockwave for Director plugins with full paths. Are they there?

(4) After gathering that information, return to about:config and toggle plugin.expose_full_path back to its default value of false. You can close this tab.

(5) Finally, return to the Add-ons > Plugins page and disable the old plugins again.

If that doesn't work, there's probably a settings file that has the information.

Read this answer in context 5

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.4 r402
  • Next Generation Java Plug-in 10.9.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.0
  • iTunes Detector Plug-in
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.7.637
  • Adobe PDF Plug-In For Firefox and Netscape "9.5.2"
  • CANON iMAGE GATEWAY Mycamera Plugin
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:16.0) Gecko/20100101 Firefox/16.0

More Information

jscher2000
  • Top 10 Contributor
2367 solutions 20957 answers

Chosen Solution

Yes, you should remove the old ones if you can.

Firefox should reveal the full paths if you go through the following procedure.

(1) Re-enable the disabled plugins

(2) Turn on the plugin.expose_full_path setting here:

(i) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(ii) In the filter box, type or paste path and pause while the list is filtered

(iii) Double-click plugin.expose_full_path to switch its value to true

(3) In a new tab, open about:plugins. This page should list all of your Shockwave for Director plugins with full paths. Are they there?

(4) After gathering that information, return to about:config and toggle plugin.expose_full_path back to its default value of false. You can close this tab.

(5) Finally, return to the Add-ons > Plugins page and disable the old plugins again.

If that doesn't work, there's probably a settings file that has the information.

Helpful Reply

Brilliant. Thanks.

A shame Adobe doesn't remove older versions on update or allow manual removal. But worked like a charm

Thanks.

~Bob