X
Tap here to go to the mobile version of the site.

Support Forum

Firefox 16.0.1 warns on closing multiple tabs but options set not to warn

Posted

Firefox just updated itself to version 16.0.1. Now, when attempting to close multiple tabs, I get the "Confirm close" warning even though the "Warn me when closing multiple tabs" option is unchecked. I tried checking that option, confirming the change, then unchecking that option again & confirming the 2nd change, too. This has made no difference. Firefox is not obeying the option setting.

The problem didn't occur before the update to 16.0.1 but did occur in the first session afterwards & has persisted since.

Firefox just updated itself to version 16.0.1. Now, when attempting to close multiple tabs, I get the "Confirm close" warning even though the "Warn me when closing multiple tabs" option is unchecked. I tried checking that option, confirming the change, then unchecking that option again & confirming the 2nd change, too. This has made no difference. Firefox is not obeying the option setting. The problem didn't occur before the update to 16.0.1 but did occur in the first session afterwards & has persisted since.

Chosen solution

Here just do this and you will be perfectly fine... even if option is selected the about:config is always set to "true" by default (on new firefox version)

Read this answer in context 15

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.4 r402
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • RealJukebox Netscape Plugin
  • RealNetworks(tm) RealPlayer Chrome Background Extension Plug-In
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealPlayer Download Plugin
  • Next Generation Java Plug-in 1.6.0_33 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • VLC media player Web Plugin 2.0.2
  • 1.9.0009.1
  • DRM Store Netscape Plugin
  • Npdsplay dll
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:16.0) Gecko/20100101 Firefox/16.0

More Information

Application Basics
Name
Firefox
Version
16.0.1
User Agent
Mozilla/5.0 (Windows NT 5.1; rv:16.0) Gecko/20100101 Firefox/16.0
Profile Folder
Show Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Crash Reports
about:crashes
Memory Use
about:memory
Extensions
Name
Version
Enabled
ID
Adblock Plus
2.1.2
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
DownloadHelper
4.9.10
true
{b9db16a4-6edc-47ec-a1f4-b86292ed211d}
Java Console
6.0.33
true
{CAFEEFAC-0016-0000-0033-ABCDEFFEDCBA}
Java Quick Starter
1.0
true
jqs@sun.com
RealPlayer Browser Record Plugin
15.0.5
true
{C3949AC2-4B17-43ee-B4F1-D26B9D42404D}
UnPlug
2.052
true
unplug@compunach
Anti-Banner
11.0.2.579
false
KavAntiBanner@Kaspersky.ru
Interclue
1.6.3
false
{c33c5b47-69c8-45a4-a5e0-af85bbe628dd}
Kaspersky URL Advisor
11.0.2.579
false
linkfilter@kaspersky.ru
Kaspersky Virtual Keyboard
11.0.2.579
false
virtualKeyboard@kaspersky.ru
Microsoft .NET Framework Assistant
1.2.1
false
{20a82645-c095-46ed-80e3-08825760534b}
SmoothWheel (AMO)
0.45.6.20100202.1
false
{5F590AA2-1221-4113-A6F4-A4BB62414FAC}
TweakTube
1.0.7
false
{15e67a59-bd3d-49ae-90dd-b3d3fd14c2ed}
Important Modified Preferences
Name
Value
accessibility.typeaheadfind.casesensitive
1
accessibility.typeaheadfind.flashBar
0
browser.cache.disk.capacity
1048576
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size_cached_value
1048576
browser.history_expire_days.mirror
180
browser.places.importBookmarksHTML
false
browser.places.importDefaults
false
browser.places.leftPaneFolderId
-1
browser.places.migratePostDataAnnotations
false
browser.places.smartBookmarksVersion
4
browser.places.updateRecentTagsUri
false
browser.startup.homepage
http://www.google.co.uk/firefox?client=firefox-a&rls=org.mozilla:en-GB:official
browser.startup.homepage_override.buildID
20121010144125
browser.startup.homepage_override.mstone
16.0.1
browser.tabs.loadInBackground
false
browser.tabs.onTop
false
browser.tabs.warnOnClose
false
extensions.lastAppVersion
16.0.1
general.useragent.extra.microsoftdotnet
( .NET CLR 3.5.30729; .NET4.0E)
gfx.blacklist.suggested-driver-version
257.21
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1350055472
places.history.expiration.transient_current_max_pages
77154
places.history.expiration.transient_optimal_database_size
123445410
places.last_vacuum
1304371121
print.print_printer
Samsung ML-4500 Series
print.printer_HP_Color_LaserJet_2600n.print_bgcolor
false
print.printer_HP_Color_LaserJet_2600n.print_bgimages
false
print.printer_HP_Color_LaserJet_2600n.print_command
print.printer_HP_Color_LaserJet_2600n.print_downloadfonts
false
print.printer_HP_Color_LaserJet_2600n.print_edge_bottom
0
print.printer_HP_Color_LaserJet_2600n.print_edge_left
0
print.printer_HP_Color_LaserJet_2600n.print_edge_right
0
print.printer_HP_Color_LaserJet_2600n.print_edge_top
0
print.printer_HP_Color_LaserJet_2600n.print_evenpages
true
print.printer_HP_Color_LaserJet_2600n.print_footercenter
print.printer_HP_Color_LaserJet_2600n.print_footerleft
&PT
print.printer_HP_Color_LaserJet_2600n.print_footerright
&D
print.printer_HP_Color_LaserJet_2600n.print_headercenter
print.printer_HP_Color_LaserJet_2600n.print_headerleft
&T
print.printer_HP_Color_LaserJet_2600n.print_headerright
&U
print.printer_HP_Color_LaserJet_2600n.print_in_color
true
print.printer_HP_Color_LaserJet_2600n.print_margin_bottom
0.5
print.printer_HP_Color_LaserJet_2600n.print_margin_left
0.5
print.printer_HP_Color_LaserJet_2600n.print_margin_right
0.5
print.printer_HP_Color_LaserJet_2600n.print_margin_top
0.5
print.printer_HP_Color_LaserJet_2600n.print_oddpages
true
print.printer_HP_Color_LaserJet_2600n.print_orientation
1
print.printer_HP_Color_LaserJet_2600n.print_page_delay
50
print.printer_HP_Color_LaserJet_2600n.print_pagedelay
500
print.printer_HP_Color_LaserJet_2600n.print_paper_data
9
print.printer_HP_Color_LaserJet_2600n.print_paper_height
11.00
print.printer_HP_Color_LaserJet_2600n.print_paper_size_type
0
print.printer_HP_Color_LaserJet_2600n.print_paper_size_unit
1
print.printer_HP_Color_LaserJet_2600n.print_paper_width
8.50
print.printer_HP_Color_LaserJet_2600n.print_reversed
false
print.printer_HP_Color_LaserJet_2600n.print_scaling
1.00
print.printer_HP_Color_LaserJet_2600n.print_shrink_to_fit
true
print.printer_HP_Color_LaserJet_2600n.print_to_file
false
print.printer_HP_Color_LaserJet_2600n.print_unwriteable_margin_bottom
0
print.printer_HP_Color_LaserJet_2600n.print_unwriteable_margin_left
0
print.printer_HP_Color_LaserJet_2600n.print_unwriteable_margin_right
0
print.printer_HP_Color_LaserJet_2600n.print_unwriteable_margin_top
0
print.printer_Samsung_ML-4500_Series.print_bgcolor
false
print.printer_Samsung_ML-4500_Series.print_bgimages
false
print.printer_Samsung_ML-4500_Series.print_command
print.printer_Samsung_ML-4500_Series.print_downloadfonts
false
print.printer_Samsung_ML-4500_Series.print_edge_bottom
0
print.printer_Samsung_ML-4500_Series.print_edge_left
0
print.printer_Samsung_ML-4500_Series.print_edge_right
0
print.printer_Samsung_ML-4500_Series.print_edge_top
0
print.printer_Samsung_ML-4500_Series.print_evenpages
true
print.printer_Samsung_ML-4500_Series.print_footercenter
print.printer_Samsung_ML-4500_Series.print_footerleft
&PT
print.printer_Samsung_ML-4500_Series.print_footerright
&D
print.printer_Samsung_ML-4500_Series.print_headercenter
print.printer_Samsung_ML-4500_Series.print_headerleft
&T
print.printer_Samsung_ML-4500_Series.print_headerright
&U
print.printer_Samsung_ML-4500_Series.print_in_color
true
print.printer_Samsung_ML-4500_Series.print_margin_bottom
0.5
print.printer_Samsung_ML-4500_Series.print_margin_left
0.5
print.printer_Samsung_ML-4500_Series.print_margin_right
0.5
print.printer_Samsung_ML-4500_Series.print_margin_top
0.5
print.printer_Samsung_ML-4500_Series.print_oddpages
true
print.printer_Samsung_ML-4500_Series.print_orientation
0
print.printer_Samsung_ML-4500_Series.print_page_delay
50
print.printer_Samsung_ML-4500_Series.print_pagedelay
500
print.printer_Samsung_ML-4500_Series.print_paper_data
9
print.printer_Samsung_ML-4500_Series.print_paper_height
11.00
print.printer_Samsung_ML-4500_Series.print_paper_size_type
0
print.printer_Samsung_ML-4500_Series.print_paper_size_unit
1
print.printer_Samsung_ML-4500_Series.print_paper_width
8.50
print.printer_Samsung_ML-4500_Series.print_reversed
false
print.printer_Samsung_ML-4500_Series.print_scaling
1.00
print.printer_Samsung_ML-4500_Series.print_shrink_to_fit
true
print.printer_Samsung_ML-4500_Series.print_to_file
false
print.printer_Samsung_ML-4500_Series.print_unwriteable_margin_bottom
0
print.printer_Samsung_ML-4500_Series.print_unwriteable_margin_left
0
print.printer_Samsung_ML-4500_Series.print_unwriteable_margin_right
0
print.printer_Samsung_ML-4500_Series.print_unwriteable_margin_top
0
privacy.popups.showBrowserMessage
false
privacy.sanitize.migrateFx3Prefs
true
privacy.sanitize.timeSpan
4
security.warn_viewing_mixed
false
Graphics
Adapter Description
NVIDIA GeForce 7050 PV / NVIDIA nForce 630a
Vendor ID
0x10de
Device ID
0x053b
Adapter RAM
Unknown
Adapter Drivers
nv4_disp
Driver Version
6.14.11.9621
Driver Date
1-11-2010
WebGL Renderer
Blocked for your graphics driver version. Try updating your graphics driver to version 257.21 or newer.
GPU Accelerated Windows
0. Blocked for your graphics driver version. Try updating your graphics driver to version 257.21 or newer.
JavaScript
Incremental GC
1
Accessibility
Activated
0
Prevent Accessibility
0
Library Versions
Expected minimum version
Version in use
NSPR
4.9.2
4.9.2
NSS
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS Util
3.13.6.0
3.13.6.0
NSS SSL
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS S/MIME
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC

philipp
  • Top 10 Contributor
  • Moderator
3075 solutions 14306 answers

hello NeilFKMcLachlan, unfortunately it isn't possible to deactivate the warning which shows up when you select "close other tabs" at the moment due to a side effect by another bug fix. in firefox 18 there will be a preference added in about:config (browser.tabs.warnOnCloseOtherTabs) which makes it possible to hide the warning again, see bug #772319.

hello NeilFKMcLachlan, unfortunately it isn't possible to deactivate the warning which shows up when you select "close other tabs" at the moment due to a side effect by another bug fix. in firefox 18 there will be a preference added in about:config (browser.tabs.warnOnCloseOtherTabs) which makes it possible to hide the warning again, see [https://bugzilla.mozilla.org/show_bug.cgi?id=772319 bug #772319].

Question owner

To madperson: Please note that my remarks are directed at Mozilla, not you.

That simply isn't good enough. The warning is a nuisance that I'd got rid of by setting an option. Now some twerp has decided I'm too stupid to be allowed to do that. The explanation of why & the advice to wait until version 18 for a fix both simply add insult to injury.

In the Options dialog, you ask me if I want a warning when I close multiple tabs. I've said "No". What part of "no" don't you understand?

To madperson: Please note that my remarks are directed at Mozilla, not you. That simply isn't good enough. The warning is a nuisance that I'd got rid of by setting an option. Now some twerp has decided I'm too stupid to be allowed to do that. The explanation of why & the advice to wait until version 18 for a fix both simply add insult to injury. In the Options dialog, you ask me if I want a warning when I close multiple tabs. I've said "No". What part of "no" don't you understand?

Modified by NeilFKMcLachlan

Helpful Reply

The more I encounter this piece of stupidity, the more annoying it gets. The assumption that no user knows what he/she is doing is one of the things that made Windows Vista such a disaster. Firefox shouldn't be copying failure. If Mozilla had time to cause this problem in version 16, it has no excuse for waiting until version 18 to undo the damage. It has time to reverse the change now.

There's a good argument for the warning option to be enabled by default. There's none whatever for making it compulsorily enabled, regardless of the user's wishes.

It is, of course, possible that someone will go into the options dialog, disable the warning option & then close multiple tabs by mistake. In that situation, it's the user's own fault. If it's too much trouble to undo the error, the user can re-enable the warning option & stop it happening again.

If there's unsaved data on one of the pages, that page ought to (& most will) warn the user that closing/leaving the page will lose the data. If there's no warning, it's the fault of the page code -- provided, of course, that the browser raises the relevant event when the tab is about to be closed. If the browser isn't raising that event for some reason (e.g., because the tab with the page isn't the active tab), that is the problem requiring attention.

The more I encounter this piece of stupidity, the more annoying it gets. The assumption that '''no''' user knows what he/she is doing is one of the things that made Windows Vista such a disaster. Firefox shouldn't be copying failure. If Mozilla had time to cause this problem in version 16, it has no excuse for waiting until version 18 to undo the damage. It has time to reverse the change '''now'''. There's a good argument for the warning option to be enabled by default. There's none whatever for making it compulsorily enabled, regardless of the user's wishes. It is, of course, possible that someone will go into the options dialog, disable the warning option & then close multiple tabs by mistake. In that situation, it's the user's own fault. If it's too much trouble to undo the error, the user can re-enable the warning option & stop it happening again. If there's unsaved data on one of the pages, that page ought to (& most will) warn the user that closing/leaving the page will lose the data. If there's no warning, it's the fault of the page code -- provided, of course, that the browser raises the relevant event when the tab is about to be closed. If the browser isn't raising that event for some reason (e.g., because the tab with the page isn't the active tab), '''that''' is the problem requiring attention.
volrath77 0 solutions 1 answers

Yup, the same thing happened to me. I've checked the options page, checked and rechecked the no warning option and it didn't work. Also checked config as well and the option for browser.tabs.warnOnClose = false as it should be.

Unfortunately, the option/config are doing nothing. This needs to be rectified.

Yup, the same thing happened to me. I've checked the options page, checked and rechecked the no warning option and it didn't work. Also checked config as well and the option for browser.tabs.warnOnClose = false as it should be. Unfortunately, the option/config are doing nothing. This needs to be rectified.
donjag 0 solutions 4 answers

I've been pulling my hair out on this. It brought me to the support forum for the first time. I absolutely hate "Nag" screens and prompts that I have to click through to confirm that I want the product to do exactly what I asked it to do. If I can't get rid of them, I'll try another product. I'll be patient, but really, wait for the next full release?

I've been pulling my hair out on this. It brought me to the support forum for the first time. I absolutely hate "Nag" screens and prompts that I have to click through to confirm that I want the product to do exactly what I asked it to do. If I can't get rid of them, I'll try another product. I'll be patient, but really, wait for the next full release?
o2107549rtrtrcom 0 solutions 1 answers

Hallo Firefox its been a week already, Firefox come out and play.......Firefox come out and play........Firefox come out and play.......version 18? No that’s not an answer sorry!

Or maybe you could make a popup saying “We will now update your browser to a crappy version with annoying popups and perhaps general malfunction in your browsing experience” Many regards the hard smoking cigar team at Firefox!

Hallo Firefox its been a week already, Firefox come out and play.......Firefox come out and play........Firefox come out and play.......version 18? No that’s not an answer sorry! Or maybe you could make a popup saying “We will now update your browser to a crappy version with annoying popups and perhaps general malfunction in your browsing experience” Many regards the hard smoking cigar team at Firefox!
unicodefreak 0 solutions 1 answers

I just patched my Firefox to disallow this annoying behaviour. On OS X, unfortunately, but the patch should be similar on Windows, although the paths will differ. Used Midnight Commander to edit inside omni.ja, which is a plain Zip archive.

I just patched my Firefox to disallow this annoying behaviour. On OS X, unfortunately, but the patch should be similar on Windows, although the paths will differ. Used Midnight Commander to edit inside omni.ja, which is a plain Zip archive.

Modified by unicodefreak

Question owner

Thanks, unicodefreak. I might do the same. However, it doesn't realy solve the problem. An update to Firefox is liable to overwrite the patched file & bring the unwanted nagging back, in which case the patch would need to be repeated. That could happen many times & I don't like having to apply the same fix multiple times.

Also, from what I can see, this fix still commits the mistake of ignoring the setting of the "Warn me when closing multiple tabs" option. If I decide that I want the warning -- temporarily, for an inexperience user, say -- I'd need not only to set the option but also to reverse the code patch.

Furthermore, this is a problem created by Mozilla & ought to be fixed by Mozilla. They need to know they've got it wrong. They need to know that "Wait a couple of versions" isn't good enough. Anyone who actually wanted the warning message could have had it, just by setting the option. The sole effect of their change is to impose the warning on users who don't want it. It doesn't in any way help those users who do want it. Mozilla ought to have known better. Since it seems they didn't know better, we need to get the message across to them so that they will know better in future.

Thanks, unicodefreak. I might do the same. However, it doesn't realy solve the problem. An update to Firefox is liable to overwrite the patched file & bring the unwanted nagging back, in which case the patch would need to be repeated. That could happen many times & I don't like having to apply the same fix multiple times. Also, from what I can see, this fix still commits the mistake of ignoring the setting of the "Warn me when closing multiple tabs" option. If I decide that I want the warning -- temporarily, for an inexperience user, say -- I'd need not only to set the option but also to reverse the code patch. Furthermore, this is a problem created by Mozilla & ought to be fixed by Mozilla. They need to know they've got it wrong. They need to know that "Wait a couple of versions" isn't good enough. Anyone who actually wanted the warning message could have had it, just by setting the option. The '''sole''' effect of their change is to impose the warning on users who don't want it. It doesn't in any way help those users who do want it. Mozilla ought to have known better. Since it seems they didn't know better, we need to get the message across to them so that they will know better in future.

Modified by NeilFKMcLachlan

John99
  • Top 25 Contributor
  • Moderator
725 solutions 10015 answers

Hi everyone,

It is probably worth noting that the bug fix is now included in Firefox beta Aurora, so some of you may consider changing channel and flipping the pref browser.tabs.warnOnCloseOtherTabs

UPDATE

  1. the feature is on 17 beta 4, you will need to wait till next week, for the fix
    Thanks for the prompt Madperson -J99
  2. or use the Aurora channel, where I can confirm the fix is live
  3. any 64 bit Ubuntu users note the Firefox standard installers on Firefox Beta and Aurora all seem to try to install 32bit instead of 64 bit versions, and the download files are likely to have the same names, you may need to specifically manually download 64 bit versions. Drill down from http://ftp.mozilla.org/pub/mozilla.org/firefox/releases

I think it is realised that the changes are contentious, & whilst I am not attempting to censor discussion I feel I should point out that this is not the best place for such a conversation.

(2nd edit minor typos -J99)

Hi everyone, It is probably worth noting that the bug fix is now included in Firefox <s>beta</s> Aurora, so some of you may consider changing channel and flipping the pref ''browser.tabs.warnOnCloseOtherTabs'' * http://www.mozilla.org/en-US/firefox/channel/#beta/beta-desktop * http://kb.mozillazine.org/About:config '''UPDATE''' # the feature is on 17 beta 4, you will need to wait till next week, for the fix <br /> <sup /> Thanks for the prompt Madperson -J99 </ sup> #or use the Aurora channel, where I can confirm the fix is live #any 64 bit Ubuntu users note the Firefox standard installers on Firefox Beta and Aurora all seem to try to install 32bit instead of 64 bit versions, and the download files are likely to have the same names, you may need to specifically manually download 64 bit versions. Drill down from http://ftp.mozilla.org/pub/mozilla.org/firefox/releases ---------- I think it is realised that the changes are contentious, & whilst I am not attempting to censor discussion I feel I should point out that this is not the best place for such a conversation. * this forum is intended to provide solutions to individual problems, not to discus or propose Firefox changes * Firefox developers are unlikely to see or be influenced by posts in this forum * feedback may be provided by using a current Firefox browser to post in <br /> http://input.mozilla.org/en-US/feedback <br /> and there are various fora http://www.mozilla.org/about/forums/ <sub>(2nd edit minor typos -J99)</sub>

Modified by John99

kraemer 1 solutions 5 answers

Hi NeilFKMcLachlan:

Why dont YOU fix it? Firefox is open source... So if You have a firefox that doesnt do what You want it is your fault !!!!!!!!!!

Your benefiting from countless peoples work by using this program free but act as if You had paid a million dollar for software that doesnt work....

Hi NeilFKMcLachlan: Why dont YOU fix it? Firefox is open source... So if You have a firefox that doesnt do what You want it is your fault !!!!!!!!!! Your benefiting from countless peoples work by using this program free but act as if You had paid a million dollar for software that doesnt work....
haruhista4 1 solutions 2 answers

Chosen Solution

Here just do this and you will be perfectly fine... even if option is selected the about:config is always set to "true" by default (on new firefox version)

Here just do this and you will be perfectly fine... even if option is selected the about:config is always set to "true" by default (on new firefox version)

Question owner

Thanks, haruhista4. Tried it & it worked fine. Most helpful.

Thanks, haruhista4. Tried it & it worked fine. Most helpful.
donjag 0 solutions 4 answers

Ah! Setting the WarnOnCloseOtherTabs to false does the trick.

It seems that changing "Warn me when closing multiple tabs" from Tools/Options is actually changing WarnOnClose, which should be the option to be warned when closing the browser with multiple tabs open. That actual option doesn't seem to be there anymore.

Thanks...

Ah! Setting the WarnOnCloseOtherTabs to false does the trick. It seems that changing "Warn me when closing multiple tabs" from Tools/Options is actually changing WarnOnClose, which should be the option to be warned when closing the browser with multiple tabs open. That actual option doesn't seem to be there anymore. Thanks...
StanislavShevchenko 0 solutions 5 answers

Still an issue in Firefox 19.0.

I do not want to be warned when I use the "Close Other Tabs" feature. And forcing users to modify the "about:config" page for such a simple option looks like a bad idea. "about:config" is an Admin tool, isn't it?

Firefox is great, but this issue is so annoying that it made me register here, for the first time ever.

Please make the "Warn me when closing multiple tabs" option do what it is supposed to do.

Still an issue in Firefox 19.0. I do not want to be warned when I use the "Close Other Tabs" feature. And forcing users to modify the "about:config" page for such a simple option looks like a bad idea. "about:config" is an Admin tool, isn't it? Firefox is great, but this issue is so annoying that it made me register here, for the first time ever. Please make the "Warn me when closing multiple tabs" option do what it is supposed to do.
John99
  • Top 25 Contributor
  • Moderator
725 solutions 10015 answers

I wonder if you have already been changing some of the preferences ?

Most things can be changed without resorting to about:config and it is a bad idea to change anything there unless you understand it and or have had reliable advice. (With the possible exception of resetting to default values, which should be relatively safe.

At the moment I am in Firefox 20 and this feature works as intended for me. This thread is old and related to Firefox 16. I suggest you start a new thread by asking your own question using /questons/new. When you do so please ensure you follow the manual steps to include the troubleshooting information. (There is an offer to use an automated method but that is broken at the moment)

Please post back here once you have started a thread. I will make sure it is cross linked, and try to ensure you get a solution.

I wonder if you have already been changing some of the preferences ? Most things can be changed without resorting to about:config and it is a bad idea to change anything there unless you understand it and or have had reliable advice. (With the possible exception of resetting to default values, which should be relatively safe. At the moment I am in Firefox 20 and this feature works as intended for me. This thread is old and related to Firefox 16. I suggest you start a new thread by asking your own question using [/questons/new]. When you do so please ensure you follow the manual steps to include the troubleshooting information. (There is an offer to use an automated method but that is broken at the moment) Please post back here once you have started a thread. I will make sure it is cross linked, and try to ensure you get a solution.
donjag 0 solutions 4 answers

So, if an issue has been ignored through several version updates, you want a new topic which will basically have all of the helpful workarounds in this topic fall out of the spotlight?

Why not just change the title of this topic to Firefox v16.01 - v19 warns on...

It's really pretty simple. There were two options for closing multiple tabs. One disappeared from the options screen, but its function was assigned to the remaining one, without the screen text changing. If the developers have decided that they no longer want to offer the function through the options screen, then they should at least re-title the remaining option so it does what people expect it to do.

So, if an issue has been ignored through several version updates, you want a new topic which will basically have all of the helpful workarounds in this topic fall out of the spotlight? Why not just change the title of this topic to Firefox v16.01 - v19 warns on... It's really pretty simple. There were two options for closing multiple tabs. One disappeared from the options screen, but its function was assigned to the remaining one, without the screen text changing. If the developers have decided that they no longer want to offer the function through the options screen, then they should at least re-title the remaining option so it does what people expect it to do.
John99
  • Top 25 Contributor
  • Moderator
725 solutions 10015 answers

Hi donjag,

Please read my reasoning in my post above. But remember we are now on Firefox 19 and the initial problem no longer exists. If Firefox is set not to warn it now will quietly closes all tabs.

The original Firefox 16 problem was fixed in Firefox 17. All ordinary users should by now be on Firefox 19 or about to update to that.

Other things may have some influence on this, like changed preferences, and what software extensions are in use, if a new thread is started the user is prompted to provide such information, about the new problem

Requests for changes to Firefox

 If the developers have decided that they no longer want to offer the function through the options screen, then they should at least re-title the remaining option so it does what people expect it to do. 

Again see my other post: developers are unlikely to see this forum or this thread. The simplest method of registering the fact you want a change is to use http://input.mozilla.org/en-US/feedback

have all of the helpful workarounds in this topic fall out of the spotlight?  

Please confirm you have started a new thread by posting back here after you have done so and i will make sure the thread is cross linked for anyone wishing to look back at the historical changes.

Hi donjag, Please read my reasoning in [/questions/939340#answer-377267 my post above]. But remember we are now on Firefox 19 and the initial problem no longer exists. If Firefox is set not to warn it now will quietly closes all tabs. The original Firefox 16 problem was fixed in Firefox 17. All ordinary users should by now be on Firefox 19 or about to update to that. Other things may have some influence on this, like changed preferences, and what software extensions are in use, if a new thread is started the user is prompted to provide such information, about the new problem <u>Requests for changes to Firefox</u><br /> '' If the developers have decided that they no longer want to offer the function through the options screen, then they should at least re-title the remaining option so it does what people expect it to do. '' Again see my other post: developers are unlikely to see this forum or this thread. The simplest method of registering the fact you want a change is to use http://input.mozilla.org/en-US/feedback ''have all of the helpful workarounds in this topic fall out of the spotlight? '' Please confirm you have started a new thread by posting back here after you have done so and i will make sure the thread is cross linked for anyone wishing to look back at the historical changes. * you may use this link yourself as a cross link or bookmark [/questions/939340]
haruhista4 1 solutions 2 answers

Hello once again.. I have upgraded few days ago and am NOT getting any warning .. My settings are still the same on about:config (scsreenshot is on my previous reply) as well as the tab-settings unchecked..

Check yours if the were "reseted" after upgrade and try again.. Dont be afraid to use the About:config.. It's there for things like this...

Now if this wont solve i have a few other solutions that WORK

Hello once again.. I have upgraded few days ago and am NOT getting any warning .. My settings are still the same on about:config (scsreenshot is on my previous reply) as well as the tab-settings unchecked.. Check yours if the were "reseted" after upgrade and try again.. Dont be afraid to use the About:config.. It's there for things like this... Now if this wont solve i have a few other solutions that WORK
donjag 0 solutions 4 answers

Let me restate the point and then I'll be done with it. In Tools/Options/Tabs there is a checkbox for "Warn me when closing multiple tabs". Checking or unchecking it does not seem to affect Firefox 19 in any way. It has been this way since FF16 so saying that the problem has been fixed is simply not true. Going into about:config and changing the proper browser.tabs.warnOnCloseOtherTabs setting does give you the behavior that you desire, but many users are intimidated to go to this area because they feel that they may mess something up, and Firefox itself gives a very ominous warning when you first try to enter the config area.

This is no longer an issue for me as I am not afraid to change my settings through about:config and have done so, but you have a lot of users scratching their heads because the option under the menu does not do what they expect it to do.

Let me restate the point and then I'll be done with it. In Tools/Options/Tabs there is a checkbox for "Warn me when closing multiple tabs". Checking or unchecking it does not seem to affect Firefox 19 in any way. It has been this way since FF16 so saying that the problem has been fixed is simply not true. Going into about:config and changing the proper browser.tabs.warnOnCloseOtherTabs setting does give you the behavior that you desire, but many users are intimidated to go to this area because they feel that they may mess something up, and Firefox itself gives a very ominous warning when you first try to enter the config area. This is no longer an issue for me as I am not afraid to change my settings through about:config and have done so, but you have a lot of users scratching their heads because the option under the menu does not do what they expect it to do.
StanislavShevchenko 0 solutions 5 answers

Donjag, thanks a lot. Your description of the issue is absolutely precise. Indeed, this was not fixed in FF 17; behavior of the "Warn me when closing multiple tabs" option remains the same since FF 16 and up to now. And "Close Other Tabs" menu item always displays a warning, since FF 16 and up to now.

> developers are unlikely to see this forum or this thread

What is the purpose of this forum then? Thanks for the link, I've already submitted a feedback here: http://input.mozilla.org/en-US/feedback. But it provides no feedback on my feedback :)

Haruhista4, your solution via "about:config" is clear to me. But users do not go to Windows Registry to modify preferences for MS Word. Similar to this, "about:config" is an admin tool, and most users avoid using it.

Donjag, thanks a lot. Your description of the issue is absolutely precise. Indeed, this was not fixed in FF 17; behavior of the "Warn me when closing multiple tabs" option remains the same since FF 16 and up to now. And "Close Other Tabs" menu item always displays a warning, since FF 16 and up to now. > developers are unlikely to see this forum or this thread What is the purpose of this forum then? Thanks for the link, I've already submitted a feedback here: http://input.mozilla.org/en-US/feedback. But it provides no feedback on my feedback :) Haruhista4, your solution via "about:config" is clear to me. But users do not go to Windows Registry to modify preferences for MS Word. Similar to this, "about:config" is an admin tool, and most users avoid using it.