X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I can't login google's gmail even using firefox latest version, even I turn all cookies on. please help.

Posted

My firefox version is: 15.0.1. I can go to the Google's gmail page, but can't log in. I was asked:

"Your browser's cookie functionality is turned off. Please turn it on. [?]". I follow the direction to turn cookies on. It is already on, but still can't log in since I got above message again. Why?

Thanks,

Chosen solution

Try checking for a site-specific setting here:

orange Firefox button or classic Tools menu > Options > Privacy

If you have Firefox set to "use custom settings for history" click the Exceptions button to check for any google.com or www.google.com entries.

If you do not have Firefox set to "use custom settings for history" go ahead and select that temporarily to provide access to the dialog.


In addition to built-in features, some add-ons or external software could block cookies. Do you have any privacy-related add-ons here that might be relevant:

orange Firefox button or classic Tools menu > Add-ons > Extensions category

You could try disabling them temporarily, or check for any Google-related preferences.

Read this answer in context 19

Additional System Details

Sites Affected

https://accounts.google.com/ServiceLoginAuth

Installed Plug-ins

  • Shockwave Flash 11.4 r402
  • 4.1.10329.0
  • Google Updater pluginhttp://pack.google.com/
  • RealJukebox Netscape Plugin
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 6.0.12.448
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Java(TM) Platform SE binary
  • Picasa plugin
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin
  • Npdsplay dll
  • Office Plugin for Netscape Navigator
  • Hummingbird Xweb Remote Activation Plug-in Version 12.0.0.0 for Windows 2000/XP/2003
  • Rhapsody Player Engine Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:15.0) Gecko/20100101 Firefox/15.0.1

More Information

Browser's cookie functionality turned off
If you're seeing a message that your browser's cookie functionality is turned off, it's possible that your browser's cookies are not enabled.
First-party cookies are cookies that are set by the site domain listed in the address bar. Third-party cookies come from other domain sources that have items, such as ads or images, embedded on the page. Depending on your browser, you can control which types of cookies you allow.
Turning cookies on
Microsoft Internet Explorer
Mozilla Firefox
To enable cookies in Mozilla Firefox 3.x for Windows:
Click Tools > Options.
Click Privacy in the top panel.
Set "Firefox will:" to Use custom settings for history.
Check the box next to "Accept cookies from sites" to enable cookies.
Click OK.
To enable cookies in Mozilla Firefox 2.x for Windows:
Click Tools > Options.
Click Privacy in the top panel.
Select the checkbox labeled "Accept cookies from sites."
Click OK.
To enable cookies in Mozilla Firefox for Mac:
Go to the Firefox drop-down menu.
Select Preferences.
Click Privacy.
Set "Firefox will:" to Use custom settings for history.
Check the box next to "Accept cookies from sites" to enable cookies.
Click OK.

jscher2000
  • Top 10 Contributor
2366 solutions 20923 answers

Chosen Solution

Try checking for a site-specific setting here:

orange Firefox button or classic Tools menu > Options > Privacy

If you have Firefox set to "use custom settings for history" click the Exceptions button to check for any google.com or www.google.com entries.

If you do not have Firefox set to "use custom settings for history" go ahead and select that temporarily to provide access to the dialog.


In addition to built-in features, some add-ons or external software could block cookies. Do you have any privacy-related add-ons here that might be relevant:

orange Firefox button or classic Tools menu > Add-ons > Extensions category

You could try disabling them temporarily, or check for any Google-related preferences.

nandibrown 0 solutions 3 answers

What if I have completely uninstalled and reinstalled Firefox? I've cleared caches and cookies, there's nothing on the Exceptions list under "use custom settings for history," it was working all day and every day for as long as I've had the machine, and then all of a sudden I started getting the "cookie functionality turned off" message and not a single thing I do will work.

I freelance in another country and this is the only way any clients have to reach me. Does anyone have any idea how to overcome this?

jscher2000
  • Top 10 Contributor
2366 solutions 20923 answers

Hi nandibrown, what is your general cookie setting? For example, I use

[X] Accept cookies from sites
[X] Accept third party cookies
Keep until: I close Firefox

Is your setting at least that permissive?


Also, check out the following reply in a different thread about manually deleting the cookies file in case it is corrupted: https://support.mozilla.org/en-US/questions/943218#answer-385398

nandibrown 0 solutions 3 answers

Hi There,

Thanks so much for getting back to me. Yes, all three of those boxes are checked. Literally nothing changed between when everything was working, which has been for months, and when it all of a sudden stopped, which was earlier today. I just suddenly couldn't do anything or open either account. Now I can open my regular Gmail account at least occasionally, but everything takes about a year and a half and just says Still working...; I still can't open the work account at all.

I don't know what I was supposed to see when I clicked Show Folder, but I tried to follow the instructions at the link about corrupted cookies and neither of the two files I was supposed to be looking for were anywhere on the screen, so I couldn't delete them. The whole thing is just inexplicable and I'm helpless.

Thanks again.

nandibrown 0 solutions 3 answers

Well. For lack of any other options, I tried reconnecting my work account to my main personal account, and both seemed to work. I sent a test message to the work account just to make sure it was receiving messages in real time, and then I closed and reopened Firefox to make sure it wasn't a fluke. I don't know what I did, but it seems to be okay now. Thank you very much for your help.