X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox keeps on telling me to update, even though I know I updated.

Posted

On help, when it checks for updates it tells me I'm on the latest one, but everywhere else (such as Devientart or Mozilla Startpage) it tells me that I need to update. I'm sure I updated to, and I can't access certain pages without being on the latest browser.

Chosen solution

You either have Firefox 3.0.19 or your User Agent is locked to that version by something you installed in Firefox some time ago,

http://kb.mozillazine.org/Resetting_your_useragent_string_to_its_compiled-in_default

http://en.wikipedia.org/wiki/User_Agent

type about:config in the URL bar and hit Enter
If you see the warning, you can confirm that you want to access that page.
Filter = general.useragent.
Right-click the preferences that are bold, one line at a time, and select Reset.
Then restart Firefox

Read this answer in context 0

Additional System Details

This happened

Every time Firefox opened

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • Google Update
  • Shockwave Flash 10.3 r183
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.5.635
  • iTunes Detector Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • GEPlugin
  • Google Updater pluginhttp://pack.google.com/
  • Pando Web Plugin
  • Unity Player 2.6.1f3
  • RealJukebox Netscape Plugin
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 6.0.12.448
  • 3DVIA player(5.0.0.12). For more information, visit the 3DVIA player web site.
  • Unity Player 2.5.5b4
  • npdnupdater2
  • npdnu
  • Musicnotes Viewer plugin 1.17.0 For more information visit Musicnotes.com
  • npdivxplayerplugin
  • DivX Web Player version 1.4.2.7
  • Zango Firefox Plugin
  • Picasa plugin
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Office Plugin for Netscape Navigator

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.19) Gecko/2010031422 Firefox/3.0.19 (.NET CLR 3.5.30729) FBSMTWB

More Information

Application Basics
Name
Firefox
Version
15.0.1
User Agent
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.19) Gecko/2010031422 Firefox/3.0.19 (.NET CLR 3.5.30729) FBSMTWB
Profile Folder
Show Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Crash Reports
about:crashes
Memory Use
about:memory
Extensions
Name
Version
Enabled
ID
Personas
1.6.2
true
personas@christopher.beard
Updated Ad Blocker for Firefox 11+
0.7.7
true
{4DC70064-89E2-4a55-8FC6-E8CDEAE3618C}
AVG Safe Search
10.0.0.1423
false
{1E73965B-8B48-48be-9C8D-68B920ABC1C4}
Expat Shield Helper (Please allow this installation)
1.0
false
afurladvisor@anchorfree.com
Google Toolbar for Firefox
2.1.20060807W
false
{3112ca9c-de6d-4884-a869-9855de68056c}
RealPlayer Browser Record Plugin
1.0
false
{ABDE892B-13A8-4d1b-88E6-365A6E755758}
Important Modified Preferences
Name
Value
accessibility.typeaheadfind
true
accessibility.typeaheadfind.flashBar
0
browser.cache.disk.capacity
1048576
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size_cached_value
747520
browser.display.use_system_colors
true
browser.history_expire_days.mirror
180
browser.history_expire_days_min
50
browser.places.importBookmarksHTML
false
browser.places.importDefaults
false
browser.places.leftPaneFolderId
-1
browser.places.migratePostDataAnnotations
false
browser.places.smartBookmarksVersion
4
browser.places.updateRecentTagsUri
false
browser.search.useDBForOrder
true
browser.startup.homepage
about:home
browser.startup.homepage_override.buildID
20120905151427
browser.startup.homepage_override.mstone
15.0.1
browser.zoom.full
false
extensions.lastAppVersion
15.0.1
font.size.variable.x-western
12
general.useragent.extra.microsoftdotnet
(.NET CLR 3.5.30729)
general.useragent.override
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.19) Gecko/2010031422 Firefox/3.0.19 (.NET CLR 3.5.30729) FBSMTW…
gfx.blacklist.suggested-driver-version
7.15.10.1666
keyword.URL
http://www.ask.com/web?o=101447&l=dis&q=
network.cookie.prefsMigrated
true
network.protocol-handler.warn-external.dnupdate
false
places.database.lastMaintenance
1346798497
places.history.expiration.transient_current_max_pages
53417
places.history.expiration.transient_optimal_database_size
85466972
privacy.cpd.downloads
false
privacy.cpd.history
false
privacy.sanitize.migrateFx3Prefs
true
privacy.sanitize.timeSpan
0
security.warn_viewing_mixed
false
Graphics
Adapter Description
Mobile Intel(R) 965 Express Chipset Family
Vendor ID
0x8086
Device ID
0x2a02
Adapter RAM
Unknown
Adapter Drivers
igdumd32
Driver Version
7.14.10.1329
Driver Date
9-13-2007
Direct2D Enabled
Blocked for your graphics driver version. Try updating your graphics driver to version 7.15.10.1666 or newer.
DirectWrite Enabled
false (0.0.0.0)
ClearType Parameters
ClearType parameters not found
WebGL Renderer
Blocked for your graphics driver version. Try updating your graphics driver to version 7.15.10.1666 or newer.
GPU Accelerated Windows
0. Blocked for your graphics driver version. Try updating your graphics driver to version 7.15.10.1666 or newer.
JavaScript
Incremental GC
0
Library Versions
Expected minimum version
Version in use
NSPR
4.9.1
4.9.1
NSS
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS Util
3.13.6.0
3.13.6.0
NSS SSL
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS S/MIME
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC

the-edmeister
  • Top 10 Contributor
  • Moderator
3195 solutions 24387 answers

Chosen Solution

You either have Firefox 3.0.19 or your User Agent is locked to that version by something you installed in Firefox some time ago,

http://kb.mozillazine.org/Resetting_your_useragent_string_to_its_compiled-in_default

http://en.wikipedia.org/wiki/User_Agent

type about:config in the URL bar and hit Enter
If you see the warning, you can confirm that you want to access that page.
Filter = general.useragent.
Right-click the preferences that are bold, one line at a time, and select Reset.
Then restart Firefox

ideato
  • Top 25 Contributor
616 solutions 4260 answers

Probably you are updated to the latest. Your user agent is corrupted by Fast Browser Search (FBSMTWB) and that identifies you as Firefox/3.0.19

see your user agent:

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.19) Gecko/2010031422 Firefox/3.0.19 (.NET CLR 3.5.30729) FBSMTWB

you must reset user agent, see in the link the "Other causes" to do that easily

see also that page about Fast Browser Search, how to uninstall (FBSMTWB in the user agent).

http://help.fastbrowsersearch.com/


thank you

Please mark "Solved" the answer that really solve the problem, to help others with a similar problem.