X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

i have been using firefox 15.0. i have a character encoding problem in gmail and youtube sites

Posted

i have check the character encoding but other site are working fine.now my character encoding showing unicdoe (UTF - 8 ) I have been tried to change western iso(88591) but it doesnt change the site from diamond symbol filled with question mark. gmail page showing diamond symbol with question mark.

Chosen solution

hello rashgang, enter about:config into the firefox location bar (confirm the info message in case it shows up) & search for the preference named network.http.accept-encoding - right-click and reset that entry to the default value.

if this does not resolve the issue already, please also go through the steps offered at Websites look wrong or appear differently than they should.

Read this answer in context 2

Additional System Details

Sites Affected

https://accounts.google.com/ServiceLogin?service=mail&passive=true&rm=false&continue=https://mail.google.com/mail/?tab%3Dwm&scc=1&ltmpl=default&ltmplcache=2

Installed Plug-ins

  • Next Generation Java Plug-in 1.6.0_35 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.4 r402
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • Google Update
  • VLC media player Web Plugin 2.0.2
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • ActiveTouch General Plugin Container Version 105
  • Winamp Application Detector

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.2; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0

More Information

philipp
  • Top 10 Contributor
  • Moderator
2046 solutions 8901 answers

Chosen Solution

hello rashgang, enter about:config into the firefox location bar (confirm the info message in case it shows up) & search for the preference named network.http.accept-encoding - right-click and reset that entry to the default value.

if this does not resolve the issue already, please also go through the steps offered at Websites look wrong or appear differently than they should.

Question owner

Yes its working perfectly. I am really thankful for your help. its works perfect. First it entry value made to true after changing it to default value. works  :)

Straydog 2 solutions 23 answers

This thread is not new, but my problem is much older, and I could never fix it. Maybe someone will kindly help me now, because I have been using Firefox for quite a few years and could never solve this issue. I have version 17 now, updated today, and nothing changed.

The setting on about-config is and was at its default setting. madperson's link does not address the character set encoding issue. I have looked up all I could think of for a long time and could never find a solution that worked for me.

Now, I am working with Spanish written pages and not being my mother tongue I find it very difficult to understand some texts on some sites where too many characters are changed to a black diamond with the with question mark. I usually have UTF-8, but tried several encodings, like Western (ISO-8859-1) (8859-15) (Windows-1258), and the only change I get is on the diamond, never the correct characters. If I look up the page source or selection source I find the same diamonds.

This does not happen on all Spanish written sites. Strange, it does not happen on Chrome or IE, both are set to UTF-8 (as in Firefox). I understand that because it does not happen with all Spanish sites there must be a reason on the sites themselves, however not showing up on other browsers, so that I have to change browser to read Spanish texts. On another thread I learned about how encoding can be determined by meta tags, but this does not reproduce the issue on other browsers, so it must originate on Firefox.

Is there a way that I can fix this for good, please? Thank you.