X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I get rid of bookmark icons

Posted

Not just on the toolbar, but ALL bookmark icons. I hate them. Don't need them.

Is there a simple setting somewhere in Firefox to handle this? If not, perhaps it might be something they'd consider adding in the future to turn them off in the options or something?

The only thing I've seen so far here is an add-on that removes them from the toolbar. I want them all gone from all bookmark menus and prefer not to have to install further 3rd party apps to get this done.

I'm using the Windows version 14.0.1

Thanks in advance for any assistance someone can offer.

Chosen solution

You might need to create a custom style rule to modify the Bookmarks Menu. You can do this using either the Stylish extension or by creating/editing a file named userChrome.css in your personal settings (AKA Firefox profile) folder.

Examples of such rules are shown in these threads:

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 1.6.0_33 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.3 r300
  • Communication Plug-In for Firefox
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin
  • Npdsplay dll

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:14.0) Gecko/20100101 Firefox/14.0.1

More Information

Marc Sances 22 solutions 242 answers

Wow. Never seen anyone wanting that. Well, this planet is full of preferences...

Well, you can always right-click a free space on the toolbar and click Customize...

Set the value of the combo box "Show:" to "Text" and click Done. Bookmark icons should have gone, but unfortunately toolbar icons too.

Question owner

Thanks, but I never get any "Customize" option when I right-click anything, from a blank part of the toolbar, or a bookmark itself, etc. Just the usual context menu that includes "properties" which has not options to do what you state.

By the way, I simply find these icons to be useless. I like things spelled out by name. Adding pictures that websites force upon me, that only take up screen space and distract me, are not something I care for.

To each, his own.

This didn't answer my question.

Question owner

PS: Okay, I found "Customize" by clicking in the unused space of the top bar across the browser (not the "toolbar" as you stated). I then selected "text" and that did get rid of the icons in the "toolbar" but not in the bookmark menus.

Half way there!!!

Question owner

Me again...Okay, by doing the above, it not only got rid of those pesky favicons that I don't like, but all distinguishing features for what links on the my toolbar are folders that contain more links. In other words, folders now look exactly like single links. Can't say that I like that much. The folder icons were helpful, but now gone when selecting text only. So I guess I can't get rid of those favicons that website push on me, without also getting rid of the browsers own "folder" icons?

jscher2000
  • Top 10 Contributor
2358 solutions 20888 answers

Chosen Solution

You might need to create a custom style rule to modify the Bookmarks Menu. You can do this using either the Stylish extension or by creating/editing a file named userChrome.css in your personal settings (AKA Firefox profile) folder.

Examples of such rules are shown in these threads:

Question owner

First, thanks for attempting to assist me with this, I appreciate it.

You can see my previous added comments on the main thread. I just realized I could reply directly to your answer, which I should have done.

Anyway, this is what I have determined so far.

Using "Customize" as you suggested to change "Show" to "Text" only, only removed icons from the toolbar, not the bookmark menus. Furthermore, it does more than remove the favicons from bookmark links in the Bookmark Toolbar, but also all of the icons for basic browser "tools" like "Forward, Backward, Print", etc. I didn't want that to all go to. I'm just wanting to get rid of the favicons that websites push upon my browser. And so far, I guess there is no solution for this?

Thanks again.

jscher2000
  • Top 10 Contributor
2358 solutions 20888 answers

Hi cufford2, this forums doesn't support threading, it's just a "flat view" with all responses tacked on. I agree that the toolbar setting is not the way to go, you need something a bit more surgical. Please see the above note about using a style rule to customize the Firefox UI. Apparently there were (are?) add-ons with this feature, but if you don't want yet another add-on, using userChrome.css is the solution for you. Please note that you need to restart Firefox after editing the file in order to apply the changes.

Question owner

Thanks, jscher.

It now seems clear that there is no easy way to just turn of website favicons that come from websites. The toolbar only solutions don't deal with all the rest of the bookmark menus, only the toolbar. And Firefox's own "Customize" menu only kills all icons on the tool bars, including Firefox's own for "Backward", "Print", etc. Those are helpful icons to me. Little pictures that come from websites aren't. It also kills the delineation between individual bookmarks and folders of bookmarks, another counterproductive result of that change.

So, I guess I've had my question answered, in that there is no real practical solution to getting rid of these, to me, annoying pictures from every website.

Perhaps I'm just the odd man out here, but I really, really have no use for those little pictures from websites, and so they are just unwanted clutter to me.

Thanks for your help guys.

Question owner

PS: I realized after one of my previous posts that the little "reply" button under each post didn't do anything other than what the bottom reply window does. I had assumed it created a thread. Also, that post of mine was in reply to the first person who answered above, as I had not yet seen yours, jscher.

Thanks again, and I guess we're done here.

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

If you do not care for placeholders then set these prefs to false on the about:config page.

  • browser.chrome.favicons [false]
  • browser.chrome.site_icons [false]

Type about:config in the location (address) bar to open the about:config page and press the "Enter" key, just like you type the URL of a website to open a website.

  • If you see a warning then you can confirm that you want to access the about:config page.

(the MozillaZine KB seems to be done atm)

Question owner

Thank you, cor-el

I'm able to open the file in my browser (display only), but how do I edit the file so that the changes take effect?

Question owner

Update: I figured out that you edit this file by right-clicking a line and selecting "toggle", which I did for both of the preferences you listed. I then closed my browser and reopened, and it had made no difference at all. Nothing changed.

jscher2000
  • Top 10 Contributor
2358 solutions 20888 answers

Hi cufford2, this was a confusing thread with so many different suggestions. I think you found the solution, but in case it helps, I'll elaborate on what I tested.

(1) Open your personal settings folder using

Help > Troubleshooting Information and click "Show Folder"

(2) Double-click the chrome folder.

(3) If you see a file named userChrome.css open it for editing. If not, right-click > New > Text Document and name it userChrome.css (don't let Windows add .txt to the end. Then open the new blank file for editing.

(4) The first line of the file should be the following. Add it or move it to the top if needed:

@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul);

(5) Copy and paste the following into the file:


/* Bookmarks Toolbar - hide favicons/placeholders for sites, but show folder icons for menus */ #personal-bookmarks toolbarbutton:not([type="menu"]) .toolbarbutton-icon {display:none !important;} #personal-bookmarks menuitem .menu-iconic-icon {display:none !important;}

/* Bookmarks Menu - hide favicons/placeholders for sites, but show folder icons for menus */ #bookmarksMenu menuitem .menu-iconic-icon {display:none !important;}

(6) Save your userChrome.css file, then close Firefox using

Firefox > Exit or File > Exit

(7) Restart Firefox and, if desired, restore your previous session using the home page button or the History menu. You should see no favicons for site bookmarks, but you will still have a folder icon indicating which bookmarks are actually menus of bookmarks.

Hope this helps.

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

You can only remove favicons that are already stored if you delete the places.sqlite database file.
Firefox shouldn't show favicons on tabs and store new favicons (try Ctrl+F5) with the two prefs set to false.

marlowe23 0 solutions 1 answers

I've spent days trying to get rid of the sidebar bookmark favicons and placeholders. I want them all gone permanently and it seems impossible. I actually thought the bookmarks menu tweak might work. But I added it to my userChrome file and it did nothing.

Why is this so hard? In IE all you have to do is uncheck one box in options and you never see the favicons or the placeholder. But in Firefox it is impossible. So much for the easily customizable Firefox browser.

jscher2000
  • Top 10 Contributor
2358 solutions 20888 answers

Hi marlowe23, I don't know why there isn't an easier way to do this. The developers are constantly debating which preferences to put in the dialogs and which to leave out. I think they want to avoid the long scrolling panes you see in IE's options.

The construction of the sidebar is quite different than for the menu, so you need a very different rule. I don't fully understand the subtleties, but you could try this, which is a brute force method that knocks out both site and folder icons:

/* Bookmarks Sidebar - hide all icons */
#bookmarks-view treechildren::-moz-tree-image{
  width: 0px !important;
  height: 0px !important;
  margin: 0px !important;
}