X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox tells me I'm runnign an old version, and asks me to Update. Then it says automatic update is normal! Which is it?

Posted

I AM trying to update my Firefox! When I get to the download page, all I seem to be able to do is register for "news"! Is the Software Update it self, instead of being called Version no 456.789, called "Firefox for Apps"? I have been getting a lot of crashes!

Additional System Details

Installed Plug-ins

  • Office Plugin for Netscape Navigator
  • np-mswmp
  • Default Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape 10.0.1
  • ActiveTouch General Plugin Container Version 105
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 11.3 r300
  • iTunes Detector Plug-in
  • npsitesafety
  • Picasa plugin
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 10.5.1 for Mozilla browsers
  • 6.0.12.1212
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealJukebox Netscape Plugin
  • BlackBerry WebSL Browser Plug-In
  • Classic Java Plug-in 10.5.0 for Netscape and Mozilla

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.4) Gecko/20100611 Firefox/3.6.4 GTB7.1 ( .NET CLR 3.5.30729; .NET4.0C)

More Information

dumdidadida 172 solutions 1436 answers

Hi,

You can try to download the latest here and install it over the current version. Hopefully the update will go smoothly, though you may also want to consider taking a backup.

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96861 answers

Helpful Reply

You may have a user agent that is corrupted and that identifies you as Firefox/3.6.4

  • Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.4) Gecko/20100611 Firefox/3.6.4 GTB7.1 ( .NET CLR 3.5.30729; .NET4.0C)

See: