X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox 14.01 and Flash 11.3 Issues

Posted

I was previously having problems with Firefox 13 (forget which version specifically) after it updated with using Flash as many others were. I was excited to see that a v. 14 is now out and updated hoping it would solve my issues, but I am still having trouble. I feel confident it is an issue with Flash; I have gone through and individually disabled and re-enabled add-ons, and can use Firefox fine when Flash is disabled, and everyone goes down hill once re-enabled.

In general, my issues are that Gmail, Facebook, and many other websites won't load when Flash is enabled. They will start to open, get stuck, and the Firefox completely freezes. Turning off the add-on fixes all of this, and turning it back on brings it back.

I have Windows Vista as my O/S.

Any suggestions for further troubleshooting? I've tried uninstalling and reinstalling both Firefox and Flash.

Chosen solution

Flash Player 11.4 is now released. It includes fixes for many issues as well as a security update (see Adobe's Announcement and the release notes for details.)

You can use the links in this article to download and install Flash 11.4

For anyone who may have disabled protected mode in Flash 11.3 and is now updating to Flash 11.4, you should re-edit the mms.cfg file to remove the ProtectedMode=0 line (reference) to see if the problems are now resolved.

Read this answer in context 12

Additional System Details

Installed Plug-ins

  • Google Update
  • Google Talk Plugin Video Accelerator version:0.1.44.16
  • Version 3.2.3.8331
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.5.635
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 10.5.1 for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.3
  • VLC media player Web Plugin 2.0.0
  • AmazonMP3DownloaderPlugin 1.0.15
  • iTunes Detector Plug-in
  • E-centives Coupon Activator
  • Coupons, Inc. Coupon Printer Plugin
  • Coupons, Inc. Coupon Printer DLL
  • npmnqmp 989898989877
  • npdnupdater2
  • npdnu
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • np-mswmp

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:14.0) Gecko/20100101 Firefox/14.0.1

More Information

Tyler Downer
  • Administrator
  • Moderator
1165 solutions 6641 answers

Helpful Reply

Unfortunately, the Flash problems are waiting for an update from Flash to fix the majority of them. Flash 11.3 doesn't load video in Firefox [[Flash 11.3 crashes]

Your best solution is to downgrade to Flash 10.3, and use that until an update for Flash is released.

viking42 0 solutions 4 answers

@ tylerdowner I did not find this reply helpful. I uninstalled Flash and then followed a link to get version 10.3 which I downloaded. I tried to install this whereupon I got the message that this was not the latest version of Flash therefore I couldn't install it. :-(

Modified by viking42

Question owner

@Tylerdowner Thanks for the response. It allowed me to download version 10.3. There are a few websites I go to that require the newest version, but in the big picture I can at least use my web browser now!

@viking42 Sorry to hear it didn't go as well for you! Here's where I dowloaded mine: http://helpx.adobe.com/flash-player/kb/archived-flash-player-versions.html

Not sure if that will result in anything different or not. Good luck!

viking42 0 solutions 4 answers

@neffer85. Thanks for your help! I downloaded the version and read the accompanying text which includes this Before installing a different Flash Player we recommend uninstalling the currently installed Flash Player and restarting the system. For more information on removing and installing the Flash Player, see How to uninstall the Flash plug-in and ActiveX Control (TechNote 14157, http://www.adobe.com/cfusion/knowledgebase/index.cfm?id=tn_14157). If you previously installed a version of Flash Player for Internet Explorer, then you may be prevented from installing an earlier version. To resolve this issue, follow the additional instructions found in Safe versions security restrictions when installing Flash Player (TechNote kb402435, http://kb.adobe.com/selfservice/viewContent.do?externalId=kb402435&sliceId=2). I think the clue is that I didn't restart the system after uninstalling the newest version. I shall have to try again....

AnarchyAngel 0 solutions 4 answers

Helpful Reply

This is the Solution that I found, thing is Adobe added something called "Protection Mode" to Flash in 11.3 and you need to disable it and all is well.

To do that you need to restart your pc so you know flash is turned off other wise you can't modify the config files for it.


For 32bit users:

C:\Windows\System32\Macromed\Flash\mms.cfg

For 64bit users:

C:\Windows\SysWOW64\Macromed\Flash\mms.cfg


In both cases all you need to do is add:

ProtectedMode=0

To the next line in the file and save it.

Worked for me, and I had been searching for weeks, if it works for you please do what you can to spread the word!

John99
  • Top 25 Contributor
  • Moderator
622 solutions 8022 answers

Readers of this thread may also be interested in

nofal 1 solutions 11 answers

Both Chrome and IE are working perfectly with Flash 11.300, I don't believe it is a flash problem. Don't change anything in the CFG file or any flash file. Firefox needs to be fixed absolutely.

Modified by nofal

jscher2000
  • Top 10 Contributor
2365 solutions 20923 answers

Hi nofal, you're right that IE and Chrome are not affected, and here's why: the Flash 11.3 protected mode is a unique feature available on Firefox in Windows Vista and Windows 7. It has created problems for some people and not others. Mozilla and Adobe have been working together since shortly after Flash 11.3 was released on June 8th to work out the kinks so that all users could benefit from this feature, but I don't think we're there yet. Flash 11.4 is available for testing if anyone is interested.

AliceWyman
  • Top 25 Contributor
  • Moderator
191 solutions 1967 answers

Chosen Solution

Flash Player 11.4 is now released. It includes fixes for many issues as well as a security update (see Adobe's Announcement and the release notes for details.)

You can use the links in this article to download and install Flash 11.4

For anyone who may have disabled protected mode in Flash 11.3 and is now updating to Flash 11.4, you should re-edit the mms.cfg file to remove the ProtectedMode=0 line (reference) to see if the problems are now resolved.

nofal 1 solutions 11 answers

I deleted the mms.cfg file, installed install_flash_player_11_plugin 11.400, the protected mode value was not there only: AutoUpdateDisable=0 SilentAutoUpdateEnable=1 I used v 14.01, same problem (mainly youtube ) , changed to 13.01 same problem. hardware acceleration disables. In both versions I have to end the process of plugin-container to get out from the freezing. Reloading the page the process starts again and the freezing continue (I hear audio for short time 5-10 seconds) the all bottoms freezes within 10 seconds again ending the process of the plugin container enables the bottoms. This site for example doesn't have problems: http://www.gooddrama.net/hong-kong-drama/the-book-and-the-sword-episode-11/1-3 For youtube I can't use Firefox. The moment the video starts I can't change the setting to disable hardware acceleration.

jscher2000
  • Top 10 Contributor
2365 solutions 20923 answers

Hi nofal, if you restore the mms.cfg file, does that resolve it?

AliceWyman
  • Top 25 Contributor
  • Moderator
191 solutions 1967 answers

nofal, You said, The moment the video starts I can't change the setting to disable hardware acceleration.

Try disabling hardware acceleration in Flash Player settings (Display tab) by right-clicking the red Flash Player logo shown here, instead of using an actual Flash video: http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues

nofal 1 solutions 11 answers

jscher2000 Hi: If you mean adding the : AutoUpdateDisable=1 SilentAutoUpdateEnable=0 ProtectedMode=1 (This wasn't there but I added it, though others recommend removing it, anyway I did try adding it, with no result, so I removed it) It won't change anything, the freezing/crash still happen on 13.01/14.01 . AliceWyman: Hi: I did that but didn't stop the freezing both 13.01/14.01

I believe it is plugin compatibility issue with Firefox, because the others (Chrome and IE) use the same plugin folder (and mss.cfg) in Flash folder. I have no other versions of Flash installed. But tried the 11.200 and was working fine with 13.01, not with 14.01.

nofal 1 solutions 11 answers

AliceWyman: Hi : I did find that betterprivacy is removing the LSO settings, because when I reloaded the Flash setting page (you send with little flash image there) I noticed hardware acceleration was enabled again, very strange. Also noticed that clicking on Close bottom of the setting will not close immediately. Couple of days when updating to 14.01 I noticed this starts happening, so I removed all Java components and installed the latest Java (Fresh install) then reinstalled Firefox (14.01), but the problem persists, currently it is also happening with 13.01. (But not with other browsers Chr and IE).

AliceWyman
  • Top 25 Contributor
  • Moderator
191 solutions 1967 answers

nofal, Try disabling the BetterPrivacy extension in your Firefox Add-ons Extensions list, in case it is interfering. Restart Firefox, then go to http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues and right-click the red Flash logo, select Settings, and uncheck the hardware acceleration option in Flash settings Display panel. Does that help?

For more information on disabling this Flash Display setting, see http://www.macromedia.com/support/documentation/en/flashplayer/help/help01.html

nofal 1 solutions 11 answers

This worked for me, still checking it, but no freezing and with 13.01 , didn't check the 14.01 and without disabling anything: dom.ipc.plugins.enabled;false dom.ipc.plugins.java.enabled;false dom.ipc.plugins.parentTimeoutSecs;2 dom.ipc.plugins.processLaunchTimeoutSecs;4 dom.ipc.plugins.timeoutSecs;3 dom.ipc.processCount;1

AliceWyman
  • Top 25 Contributor
  • Moderator
191 solutions 1967 answers

nofal, You made these changes in your Firefox preferences settings?

dom.ipc.plugins.enabled;false 
dom.ipc.plugins.java.enabled;false 
dom.ipc.plugins.parentTimeoutSecs;2
dom.ipc.plugins.processLaunchTimeoutSecs;4
dom.ipc.plugins.timeoutSecs;3 
dom.ipc.processCount;1 

dom.ipc.plugins.java.enabled is supposed to be set to false by default to protect against stability issues when OOPP ("out-of-process plugins") is enabled for Java (ref). Did you have it set to "true" before? If so, you did right by resetting it to the default false value.

For dom.ipc.processCount the default value is also 1 but for the others:

Setting dom.ipc.plugins.enabled to false disables Firefox OOPP crash protection, which isn't a good idea (note that this setting has no effect on Flash in Firefox 14 or higher on Windows Vista and above, since Flash is force-enabled to run out-of-process (ref).

I would reset all dom.ipc.plugins.* preferences back to the default values unless you have a specific reason for modifying them. For more information see: http://kb.mozillazine.org/Plugin-container_and_out-of-process_plugins

You should really start your own thread, by the way, since this question was from another user and has been solved for him. You can use this link as a starting point: https://support.mozilla.org/questions/new

nofal 1 solutions 11 answers

Hi Alice: It is too late to start new thread with same topic "Firefox 14.01 and Flash 11.3 Issues". Same issue. Right now , still testing my settings, no problems.

dhanu9 0 solutions 1 answers

There is a fix for this flash fiasco. For 32bit, go to My computers--> Windows--> System32-->Macromed--> Flash. For 64bit, go to My computers--> Windows--> SysWoW64-->Macromed--> Flash. In the Flash folder you'll find a file called mms.cfg. Right click the file and open it with notepad. You'll find two lines as below:

  • AutoUpdateDisable=0
  • SilentAutoUpdateEnable=0

Now add a third line as ProtectedMode=0. So now your file will look like below:

  • AutoUpdateDisable=0
  • SilentAutoUpdateEnable=0
  • ProtectedMode=0

Now click on File--> Save as (choose the location as Desktop or My Documents) and put the file name a mms.cfg and File Type: All Files and click on save.

Now cut the file that you've saved and paste it in: For 32bit, My computers--> Windows--> System32-->Macromed--> Flash folder For 64bit, My computers--> Windows--> SysWoW64-->Macromed--> Flash folder.

While pasting it will ask 'would you like to replace the existing file', click on Yes. Now your youtube would be working fine.

Modified by dhanu9

John99
  • Top 25 Contributor
  • Moderator
622 solutions 8022 answers

It is interesting to note that editing the .cfg file enables changing the updating behaviour of Flash.

It is also worth noting that the Flash Player problems may be resolved by a Flash Update at some stage. Also remember that Flash Updates often involve security fixes.