X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Ever since Firefox 13.0.1 my scrolling speed is very slow and sluggish. All plugins disabled, still won't work. Any fix? I HATE IT!

Posted

As soon as Firefox when through it's automatic "upgrade" the scroll action became very slow and sluggish. I've tried everything suggested (disable plug ins, re-installing Firefox, rebooting computer etc) but I still can't get it back to the way it was. Is there any fix, or how can I re-install the old version that worked so well? I HATE THIS!!!

Modified by mjg263

Chosen solution

hello mjg263, firefox 13 introduced smooth scrolling by default - it might not work well on older hardware.

please either try to update your graphics driver or if this does not improve the matter you can disable smooth scrolling in firefox/tools > options > advanced > general.

Read this answer in context 13

Additional System Details

This happened

Every time Firefox opened

This started when...

immediately after Firefox automatic update

Installed Plug-ins

all disabled

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:13.0) Gecko/20100101 Firefox/13.0.1

More Information

digifish 0 solutions 2 answers

Helpful Reply

About two or three weeks ago Adobe updated their Flash player, from that point on flash based stuff in FF has scrolled vertically with a lot of glitches and is a real mess. The recent FF 13.0.1 update seems to have improved things a little but it's still not as it was.

Lots of screen re-draw issues here and feels sluggish.

philipp
  • Top 10 Contributor
  • Moderator
2046 solutions 8901 answers

Chosen Solution

hello mjg263, firefox 13 introduced smooth scrolling by default - it might not work well on older hardware.

please either try to update your graphics driver or if this does not improve the matter you can disable smooth scrolling in firefox/tools > options > advanced > general.

digifish 0 solutions 2 answers

Hmmm...turning off Smooth scrolling AND use hardware acceleration seems to have solved my problems. My graphics card is a Nvidia GeForce GTS 240 ... not that shabby.

Question owner

Thanks very much, madperson. Now I'm not a mad person anymore! The smooth scroll switch got turned on with the last update, and turning it off solved my problem. Why would they change my personal preference settings like that? Caused hours of grief and frustration trying to get back to the way it was. Only bad experience I've EVER had with FF!

jperry76 0 solutions 1 answers

Any idea when FF is going to fix this? It works fine with IE, so it seems like a FF problem! I updated my video driver, turned off smooth scrolling, and nothing helped.

Modified by jperry76

Question owner

Switching off the smooth scrolling fixed it for me, but I know there are other people who have had deeper issues. Someone mentioned something about using the old version of FF to fix it?

Modified by mjg263

bbwong01 0 solutions 1 answers

Firefox sometimes was very very slow and the web pages took ages to download, I sometimes even can't download it and have to restart my computer again. I really hate it since when I restart my computer again, all the things and websites I'm using and working have to restart again. I really hate this! But it never happens in google Chrome which is more stable. The only reason I use Firefox is that it has the toolbar like the old IE and I can't transfer the data from IE to Chrome. But I really hate the bug that Firefox has and I wondering why they don't fix it!