X
Tap here to go to the mobile version of the site.

Support Forum

Sound is choppy on Firefox, but not IE

Posted

Every time I try to play a YouTube video or a streaming song on Grooveshark, on Firefox, the sound is very choppy. It stutters and sounds similar to the way your voice sounds if you are speaking through the rotating blades of an electric fan.

The problem began shortly after I disabled the Paging File (swap file) on Windows XP Professional (due to a nearly full hard drive). After freeing up some space on my hard drive, I re-enabled the paging file, but the problem persists.

Here are some troubleshooting steps that I attempted:

1) Ran Firefox in Safe Mode

2) Went to Control Panel-->Flash Player-->Advance-->Delete All Browsing Data and Settings

3) Cleared Cached Web Content in Firefox

4) Troubleshooting Information-->Reset Firefox

5) Uninstalled Firefox as directed by Mozilla (deleted Program Files-->Mozilla Firefox folder, then re-downloaded and reinstalled Firefox)

The sound is fine when listening to these websites in Internet Explorer, so the problem does not appear to be hardware-related. It is specific to Firefox.

Every time I try to play a YouTube video or a streaming song on Grooveshark, on Firefox, the sound is very choppy. It stutters and sounds similar to the way your voice sounds if you are speaking through the rotating blades of an electric fan. The problem began shortly after I disabled the Paging File (swap file) on Windows XP Professional (due to a nearly full hard drive). After freeing up some space on my hard drive, I re-enabled the paging file, but the problem persists. Here are some troubleshooting steps that I attempted: 1) Ran Firefox in Safe Mode 2) Went to Control Panel-->Flash Player-->Advance-->Delete All Browsing Data and Settings 3) Cleared Cached Web Content in Firefox 4) Troubleshooting Information-->Reset Firefox 5) Uninstalled Firefox as directed by Mozilla (deleted Program Files-->Mozilla Firefox folder, then re-downloaded and reinstalled Firefox) The sound is fine when listening to these websites in Internet Explorer, so the problem does not appear to be hardware-related. It is specific to Firefox.

Chosen solution

hello, this is likely a by-product of the update of adobe's flash plugin to version 11.3 (IE gets supplied with a different veriant of the plugin by adobe) which reportedly causes loss of audio or stuttering sound on some systems. you could try downgrading to version 11.2 of the flash plugin, until adobe provides a fix for those issues, see Adobe Flash plugin has crashed - Prevent it from happening again

Read this answer in context 4

Additional System Details

This happened

Every time Firefox opened

This started when...

I disabled the paging file on Windows XP Professional

Installed Plug-ins

Not relevant (problem persists when Firefox is in Safe Mode)

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:13.0) Gecko/20100101 Firefox/13.0.1

More Information

Application Basics
Name
Firefox
Version
13.0.1
User Agent
Mozilla/5.0 (Windows NT 5.1; rv:13.0) Gecko/20100101 Firefox/13.0.1
Profile Folder
Show Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Crash Reports
about:crashes
Memory Use
about:memory
Extensions
Name
Version
Enabled
ID
Ancestry.com Advanced Image Viewer
1.0.0.1
true
support@ancestry.com
Norton Toolbar
2012.7.3.1
true
{2D3F3651-74B9-4795-BDEC-6DA2F431CB62}
Norton Vulnerability Protection
10.1.1.8 - 4
true
{BBDA0591-3099-440a-AA10-41764D9DB4DB}
Greasemonkey
0.9.20
false
{e4a8a97b-f2ed-450b-b12d-ee082ba24781}
Java Quick Starter
1.0
false
jqs@sun.com
Microsoft .NET Framework Assistant
1.2.1
false
{20a82645-c095-46ed-80e3-08825760534b}
Important Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.cache.disk.capacity
1048576
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size_cached_value
532480
browser.history_expire_days.mirror
30
browser.history_expire_days_min
365
browser.places.smartBookmarksVersion
3
browser.startup.homepage
www.google.com
browser.startup.homepage_override.buildID
20120614114901
browser.startup.homepage_override.mstone
13.0.1
browser.tabs.closeWindowWithLastTab
false
browser.tabs.loadInBackground
false
browser.tabs.warnOnClose
false
browser.tabs.warnOnOpen
false
extensions.lastAppVersion
13.0.1
font.name.serif.x-western
Arial
font.size.fixed.x-western
18
font.size.variable.x-western
18
general.useragent.extra.microsoftdotnet
( .NET CLR 3.5.30729)
general.useragent.extra.searchtoolbar
PicMorphSearchToolbar/1.2
gfx.blacklist.suggested-driver-version
257.21
keyword.URL
http://www.bing.com/search?pc=Z006&form=ZGAADF&q=
network.cookie.cookieBehavior
1
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1339669974
places.history.expiration.transient_current_max_pages
93634
places.history.expiration.transient_optimal_database_size
66304737
places.last_vacuum
1299769813
privacy.sanitize.migrateFx3Prefs
true
security.OCSP.disable_button.managecrl
false
security.disable_button.openCertManager
false
security.disable_button.openDeviceManager
false
security.warn_viewing_mixed
false
Graphics
Adapter Description
NVIDIA Quadro NVS 160M
Vendor ID
0x10de
Device ID
0x06eb
Adapter RAM
Unknown
Adapter Drivers
nv4_disp
Driver Version
6.14.11.7626
Driver Date
8-1-2008
WebGL Renderer
Blocked for your graphics driver version. Try updating your graphics driver to version 257.21 or newer.
GPU Accelerated Windows
0. Blocked for your graphics driver version. Try updating your graphics driver to version 257.21 or newer.
JavaScript
Incremental GC
1
Library Versions
Expected minimum version
Version in use
NSPR
4.9
4.9
NSS
3.13.4.0 Basic ECC
3.13.4.0 Basic ECC
NSS Util
3.13.4.0
3.13.4.0
NSS SSL
3.13.4.0 Basic ECC
3.13.4.0 Basic ECC
NSS S/MIME
3.13.4.0 Basic ECC
3.13.4.0 Basic ECC

MozillaFirefox911 0 solutions 128 answers

try safe mode and test which extension may be causing problem.

try safe mode and test which extension may be causing problem.
MozillaFirefox911 0 solutions 128 answers

might need to disable everything and test that way.

plz report results if you do this.

might need to disable everything and test that way. plz report results if you do this.
philipp
  • Top 25 Contributor
  • Moderator
5114 solutions 22659 answers

Chosen Solution

hello, this is likely a by-product of the update of adobe's flash plugin to version 11.3 (IE gets supplied with a different veriant of the plugin by adobe) which reportedly causes loss of audio or stuttering sound on some systems. you could try downgrading to version 11.2 of the flash plugin, until adobe provides a fix for those issues, see Adobe Flash plugin has crashed - Prevent it from happening again

hello, this is likely a by-product of the update of adobe's flash plugin to version 11.3 (IE gets supplied with a different veriant of the plugin by adobe) which reportedly causes loss of audio or stuttering sound on some systems. you could try downgrading to version 11.2 of the flash plugin, until adobe provides a fix for those issues, see [[Flash 11.3 crashes]]

Question owner

I already tried running Firefox in Safe Mode (see #1 in my OP), which should have eliminated any plugins from being the culprit, unless I am misunderstanding what Safe Mode does.

I already tried running Firefox in Safe Mode (see #1 in my OP), which should have eliminated any plugins from being the culprit, unless I am misunderstanding what Safe Mode does.
philipp
  • Top 25 Contributor
  • Moderator
5114 solutions 22659 answers

Helpful Reply

safemode disables addons, hardware acceleration and some custom settings but not plugins!

safemode disables addons, hardware acceleration and some custom settings but not plugins!
MozillaFirefox911 0 solutions 128 answers

exactly. you need to disable them manually.

exactly. you need to disable them manually.

Question owner

Thanks for the explanation of what Safe Mode does (and doesn't) do. I downgraded to Flash 11.2 as Madperson suggested, and that fixed the problem. Thanks for the help!

Thanks for the explanation of what Safe Mode does (and doesn't) do. I downgraded to Flash 11.2 as Madperson suggested, and that fixed the problem. Thanks for the help!
ash_liz 0 solutions 2 answers

I was having the same problem--terrible sound quality in Firefox. I downgraded Flash and the problem is solved. You will need to uninstall Flash and then install the previous version. I installed 10.3 and my sound problem is fixed. This Flash Player help page was helpful: http://helpx.adobe.com/flash-player/kb/archived-flash-player-versions.html#main_Archived_versions

I was having the same problem--terrible sound quality in Firefox. I downgraded Flash and the problem is solved. You will need to uninstall Flash and then install the previous version. I installed 10.3 and my sound problem is fixed. This Flash Player help page was helpful: [http://example.com http://helpx.adobe.com/flash-player/kb/archived-flash-player-versions.html#main_Archived_versions]
ash_liz 0 solutions 2 answers

<------- And yes, I am, in fact, a cat.

<------- And yes, I am, in fact, a cat.