X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

STILL Not Able to Stop Search Suggestions

Posted

This is a follow-up to an earlier question I asked, viz. Stop Search Suggestions in the Awesome Bar. The solution presented in that question worked for a while, but now the ugly problem has returned.

I made sure to turn off Search Suggestions for Google search (indeed, for all included search engines), and I inserted the URL described in the answer. It did no good - Search Suggestions are back.

I am able to turn off Search Suggestions in Google Chrome. I am also able to turn off Google Instant, something else I can't (yet) do in Firefox.

Modified by Bulldogger

Chosen solution

Problem solved at last by choosing "When Firefox starts: Show a blank page" and setting my Home Page to about:blank.

When Firefox starts or when I go to my Home Page or when I open a new tab, I enter my search term in the Awesome Bar. (No other place to enter it.) The search opens to the following URI:

https://www.google.com/search?hl=en&complete=0&site=webhp&q=[search term]

Now I can type a new search term into Google's own search box with no search suggestions. The resulting URL is:

https://www.google.com/search?hl=en&complete=0&site=webhp&q=[new search term]&[long string of code]

Of course, this means I need to forgo FF 13's fancy new Home Page, but I can live with that.

I should add that this is not a Firefox problem per se. It's really about how to outwit Google.

Read this answer in context 0

Additional System Details

Installed Plug-ins

Adblock Plus w/Element Hiding Helper; Better Privacy; LastPass; Xmarks; Stratiform; YouTube Comment Snob and DoNotTrack Plus.

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20100101 Firefox/13.0

More Information

Application Basics
Name
Firefox
Version
13.0
User Agent
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20100101 Firefox/13.0
Profile Folder
Show Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Crash Reports
about:crashes
Memory Use
about:memory
Extensions
Name
Version
Enabled
ID
Adblock Plus
2.0.3
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
BetterPrivacy
1.68
true
{d40f5e7b-d2cf-4856-b441-cc613eeffbe3}
DoNotTrackPlus
2.2.0.515
true
donottrackplus@abine.com
Element Hiding Helper for Adblock Plus
1.2.2
true
elemhidehelper@adblockplus.org
LastPass
1.90.6
true
support@lastpass.com
Norton Vulnerability Protection
10.1.1.8 - 4
true
{BBDA0591-3099-440a-AA10-41764D9DB4DB}
Stratiform
2.1.1
true
Stratiform@SoapySpew
WordWeb one-click lookup
5.0.4405
true
wcapturex@deskperience.com
Xmarks
4.1.0
true
foxmarks@kei.com
YouTube Comment Snob
1.5.2
true
youtube-comment-snob@efinke.com
Norton Toolbar
2012.5.4.6
false
{2D3F3651-74B9-4795-BDEC-6DA2F431CB62}
Important Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.cache.disk.capacity
51200
browser.cache.disk.smart_size.enabled
false
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size_cached_value
1048576
browser.places.smartBookmarksVersion
3
browser.startup.homepage_override.buildID
20120601045813
browser.startup.homepage_override.mstone
13.0
browser.tabs.warnOnClose
false
dom.disable_window_move_resize
true
dom.event.contextmenu.enabled
false
extensions.lastAppVersion
13.0
gfx.direct3d.prefer_10_1
true
keyword.URL
https://www.google.com/search?hl=en&complete=0&site=webhp&q=
network.cookie.cookieBehavior
1
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1338679161
places.history.expiration.transient_current_max_pages
104858
plugin.disable_full_page_plugin_for_types
privacy.clearOnShutdown.cookies
false
privacy.clearOnShutdown.extensions-betterprivacy
true
privacy.clearOnShutdown.passwords
true
privacy.cpd.cookies
false
privacy.cpd.extensions-betterprivacy
true
privacy.cpd.offlineApps
true
privacy.cpd.siteSettings
true
privacy.donottrackheader.enabled
true
privacy.sanitize.migrateFx3Prefs
true
privacy.sanitize.sanitizeOnShutdown
true
privacy.sanitize.timeSpan
0
security.warn_viewing_mixed
false
Graphics
Adapter Description
ATI Radeon HD 5670
Vendor ID
0x1002
Device ID
0x68d8
Adapter RAM
1024
Adapter Drivers
aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
Driver Version
8.930.0.0
Driver Date
12-5-2011
Direct2D Enabled
true
DirectWrite Enabled
true (6.1.7601.17789)
ClearType Parameters
ClearType parameters not found
WebGL Renderer
Google Inc. -- ANGLE (ATI Radeon HD 5670) -- OpenGL ES 2.0 (ANGLE 1.0.0.963)
GPU Accelerated Windows
1/1 Direct3D 10
AzureBackend
direct2d
JavaScript
Incremental GC
1
Library Versions
Expected minimum version
Version in use
NSPR
4.9
4.9
NSS
3.13.4.0 Basic ECC
3.13.4.0 Basic ECC
NSS Util
3.13.4.0
3.13.4.0
NSS SSL
3.13.4.0 Basic ECC
3.13.4.0 Basic ECC
NSS S/MIME
3.13.4.0 Basic ECC
3.13.4.0 Basic ECC

philipp
  • Top 10 Contributor
  • Moderator
2046 solutions 8905 answers

hello, if you are visiting google.com manually & do a search, those settings won't work. this is an issue of google not remembering your search settings, as a workaround you could create a bookmark for https://www.google.com/search?hl=en&complete=0&site=webhp&q= and always use that when going to google and conducting a search.

(turning off suggestions in the dedicated search bar in firefox will only have an effect there, and the keyword.url setting only has an effect when entering a search term in the firefox location bar)

Question owner

Thanks again for your help. In Chrome I was able to 'create' a search provider from a similar URL, and select that as my default search provider. Can this be done in Firefox?

In Chrome, selecting such a URL as default search provider effectively kills search suggestions in Chrome's version of the Awesome Bar (they call it their Omnibox) and also in Google search boxes. The only exception being that Chrome will continue to suggest search terms from your history and bookmarks, but nothing else. Of course, if I go directly to google.com and search from there, search suggestions appear.

philipp
  • Top 10 Contributor
  • Moderator
2046 solutions 8905 answers

hello, i think i'm still not entirely sure to which search suggestions you are referring to - because the screenshot, that you've attached on your earlier question is showing the suggestions on the google page & not the firefox awesomebar...

Chosen Solution

Problem solved at last by choosing "When Firefox starts: Show a blank page" and setting my Home Page to about:blank.

When Firefox starts or when I go to my Home Page or when I open a new tab, I enter my search term in the Awesome Bar. (No other place to enter it.) The search opens to the following URI:

https://www.google.com/search?hl=en&complete=0&site=webhp&q=[search term]

Now I can type a new search term into Google's own search box with no search suggestions. The resulting URL is:

https://www.google.com/search?hl=en&complete=0&site=webhp&q=[new search term]&[long string of code]

Of course, this means I need to forgo FF 13's fancy new Home Page, but I can live with that.

I should add that this is not a Firefox problem per se. It's really about how to outwit Google.

Modified by Bulldogger

aparente001 0 solutions 7 answers

Here's what helped for me:

Tools -> Options -> Privacy -> Location Bar (at the bottom).

It asks "When using the location bar, suggest:"

And I chose "nothing" from the drop-down.