Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

network.protocol-handler.external.magnet type = boolean value = true

  • 6 replies
  • 21 have this problem
  • 393 views
  • Last reply by hangul

more options

Associating magnet files with firefox and qbittorrent

With firefox 3.x the following entries in about:config worked just fine. network.protocol-handler.app.magnet type = string value = /usr/bin/qbittorrent network.protocol-handler.external.magnet type = boolean value = true network.protocol-handler.warn-external.magnet type = boolean value = false

With 4.0 they don't, and as far as I can see the problem is that 4.0 will not accept "network.protocol-handler.external.magnet type = boolean", because it persistently changes its type to string.

So how do I get magnet links transferred to qbittorrent through firefox 4.0?

Associating magnet files with firefox and qbittorrent With firefox 3.x the following entries in about:config worked just fine. network.protocol-handler.app.magnet type = string value = /usr/bin/qbittorrent network.protocol-handler.external.magnet type = boolean value = true network.protocol-handler.warn-external.magnet type = boolean value = false With 4.0 they don't, and as far as I can see the problem is that 4.0 will not accept "network.protocol-handler.external.magnet type = boolean", because it persistently changes its type to string. So how do I get magnet links transferred to qbittorrent through firefox 4.0?

Chosen solution

I found the solution. Previously, when I right clicked the about:config page and selected New to create the network.protocol-handler.app.magnet entry, firefox would immediately follow with a second window requesting the path to the torrent app, and with /usr/bin/qbittorrent already entered for me (which tells me firefox already knew qbittorrent is the app to use). I'd click OK, and firefox would then error when I clicked a magnet link.

This time, I deleted the pre-selected value /usr/bin/qbittorrent, then pasted the exact same value back into the box, and clicked OK. And now it works. The only difference between the two methods; in the method that fails, the path /usr/bin/qbittorrent is highlighted when I click OK, in the method that works, the path is not highlighted.

Read this answer in context 👍 0

All Replies (6)

more options

See:

You only need to create the Boolean pref network.protocol-handler.expose.magnet with the value set to true on the about:config page.

more options

network.protocol-handler.expose.magnet with the value set to true didn't work, so I tried
http://kb.mozillazine.org/Register_protocol
which recommends that network.protocol-handler.expose.magnet be set to false and that Firefox would then ask which app to use for magnet links.
So I did that and unset network.protocol-handler.app.magnet but it did not work either.

Whatever I do for this I get the same Firefox message
"Firefox doesn't know how to open this address, because the protocol (magnet) isn't associated with any program."

more options

That most likely means that you haven't installed an application that has added that protocol, so Firefox can't find it.
You will first have to install an application that supports the magnet protocol.

more options

Sorry, but that makes no sense. With Firefox 3.x I had no problems with magnet links, as I explained in my first post. I installed Firefox 4.0 some time ago and now that I want to use a magnet link, I can't. If I didn't need to install some other unknown app to get it to work with 3.x, why would I need to with 4.0?

more options

Chosen Solution

I found the solution. Previously, when I right clicked the about:config page and selected New to create the network.protocol-handler.app.magnet entry, firefox would immediately follow with a second window requesting the path to the torrent app, and with /usr/bin/qbittorrent already entered for me (which tells me firefox already knew qbittorrent is the app to use). I'd click OK, and firefox would then error when I clicked a magnet link.

This time, I deleted the pre-selected value /usr/bin/qbittorrent, then pasted the exact same value back into the box, and clicked OK. And now it works. The only difference between the two methods; in the method that fails, the path /usr/bin/qbittorrent is highlighted when I click OK, in the method that works, the path is not highlighted.

more options

I too was trying hard to get it work, and none of them was working, but then i did something accidently ended doing, what gl00637@gmail.com had done certainly with a little change. it didn work at first then, after couple of firefox restarts it asked for application to open magnet. firefox 4.

  1. network.protocol-handler.app.magnet = usr/bin/azureus
  2. network.protocol-handler.expose.magnet = false

hope it helps//./