X
Tap here to go to the mobile version of the site.

Support Forum

flash doesn't work, then shouldn't HTML5 video work at least okay??

Posted

i know that flash doesn't work on Firefox for mobile. and although mozilla claims that it works on firefox aurora, it actually doesn't, on my Android 4.0.4 tablet. IIam actually happy about this, as i think flash makes android web browsing experience laggy, and I don't want it to support flash. HOWEVER, if there is no flash (at all), the borwser should play HTML5 video solidly. well, guess what? Even HTML5 video is unwatchable, because it stutters like hell. i tried ALL versions of Firefox for Android: The stable version, beta, aurora, and nightly. and they all have the same problem. i REALLY like Firefox AURORA that I'm using right now, because of the overscroll effect just like on iOS, and also its pretty smooth. However, if it wont play at least html 5 video well, i don't think i can use this browser for long. If there is a setting in about:config that iIcan change to make it work better, then please let me know. one different issue is that the font size setting in preference doesn't work.

i know that flash doesn't work on Firefox for mobile. and although mozilla claims that it works on firefox aurora, it actually doesn't, on my Android 4.0.4 tablet. IIam actually happy about this, as i think flash makes android web browsing experience laggy, and I don't want it to support flash. HOWEVER, if there is no flash (at all), the borwser should play HTML5 video solidly. well, guess what? Even HTML5 video is unwatchable, because it stutters like hell. i tried ALL versions of Firefox for Android: The stable version, beta, aurora, and nightly. and they all have the same problem. i REALLY like Firefox AURORA that I'm using right now, because of the overscroll effect just like on iOS, and also its pretty smooth. However, if it wont play at least html 5 video well, i don't think i can use this browser for long. If there is a setting in about:config that iIcan change to make it work better, then please let me know. one different issue is that the font size setting in preference doesn't work.

Additional System Details

Installed Plug-ins

phony, which doesn't seem to even work.

Application

  • User Agent: Mozilla/5.0 (Linux; U; Android 2.1-update1; en-us; Nexus One Build/ERE27) AppleWebkit/530.17 (KHTML, like Gecko) Version/4.0 Mobile Safari/530.17

More Information

mluna
  • Administrator
70 solutions 486 answers

Hi,

Thank you for using Aurora on your tablet and sending in these detailed comments! We are making updates to Aurora every day to improve the graphics and video playback. Both flash and HTML5 should work.

Can you tell me what make/model of tablet you are using, so I can see if there are existing bugs on file for these issues?

I will ask our video guys about any settings in about:config that could improve the playback in the meantime. Thanks again for this valuable feedback on Aurora and do let me know if you continue to have the problem with today's May 7th update to Aurora (you can check for updates on about:aurora page).

Also, if you can tell me which websites phony is not working and the font settings don't work, I'll relay that to engineering and QA also, so we can figure it out and get them working.

Regards, Michelle

Hi, Thank you for using Aurora on your tablet and sending in these detailed comments! We are making updates to Aurora every day to improve the graphics and video playback. Both flash and HTML5 should work. Can you tell me what make/model of tablet you are using, so I can see if there are existing bugs on file for these issues? I will ask our video guys about any settings in about:config that could improve the playback in the meantime. Thanks again for this valuable feedback on Aurora and do let me know if you continue to have the problem with today's May 7th update to Aurora (you can check for updates on about:aurora page). Also, if you can tell me which websites phony is not working and the font settings don't work, I'll relay that to engineering and QA also, so we can figure it out and get them working. Regards, Michelle

Modified by mluna

Question owner

Thanks for trying to help. I have a tablet called Cube U9GT2. Flash should be working fine, because it works on Dolphin HD for me, even 720p. HTML5 works in dolphin and stock browser too, and its smooth, but jumpy at times, so I don't know if that's my tablet problem or android problem. Both stock browser and dolphin are like that but opera mobile plays HTML5 videos perfectly, except its scrolling is choppy while playing a video. I tried the May 7 update for Aurora, and it still has the same problem. Its unwatchable. I tried playing a youtube video on MobileTechReview.com. Hope you guys fix it soon. I actually read someone asking about the same problem here in the forum, and the question was from middle of last year, and a Firefox staff said it will be fixed by March, April this year. However, no fix came. So hopefully, soon. Regarding phony, I think it worked once? I tried setting UA to Microsoft IE or Firefox desktop to try flash player, instead of html5, as the plugin setting in the preference doesn't work. It plays html5 no matter what. So it worked sometimes (showed flash), but sometimes not (showed html5) on the same website MobiletechReview.com.

Please let me know if you get any info on changing settings via about:debug.

Thanks.

Thanks for trying to help. I have a tablet called Cube U9GT2. Flash should be working fine, because it works on Dolphin HD for me, even 720p. HTML5 works in dolphin and stock browser too, and its smooth, but jumpy at times, so I don't know if that's my tablet problem or android problem. Both stock browser and dolphin are like that but opera mobile plays HTML5 videos perfectly, except its scrolling is choppy while playing a video. I tried the May 7 update for Aurora, and it still has the same problem. Its unwatchable. I tried playing a youtube video on MobileTechReview.com. Hope you guys fix it soon. I actually read someone asking about the same problem here in the forum, and the question was from middle of last year, and a Firefox staff said it will be fixed by March, April this year. However, no fix came. So hopefully, soon. Regarding phony, I think it worked once? I tried setting UA to Microsoft IE or Firefox desktop to try flash player, instead of html5, as the plugin setting in the preference doesn't work. It plays html5 no matter what. So it worked sometimes (showed flash), but sometimes not (showed html5) on the same website MobiletechReview.com. Please let me know if you get any info on changing settings via about:debug. Thanks.