X
Tap here to go to the mobile version of the site.

Support Forum

No more quicktime plugin in latest version of Firefox.

Posted

Since I installed the latest version of Firefox, every time I attempt to view a Quicktime formatted video, I'm told to download Quicktime. I have a Mac and already have Quicktime. When I go to manage my Firefox add-ons, the Quicktime plugin is no longer there, nor can I find it to download.

Why?

Since I installed the latest version of Firefox, every time I attempt to view a Quicktime formatted video, I'm told to download Quicktime. I have a Mac and already have Quicktime. When I go to manage my Firefox add-ons, the Quicktime plugin is no longer there, nor can I find it to download. Why?

Additional System Details

Installed Plug-ins

  • Java Plug-In 2 for NPAPI Browsers
  • Shockwave Flash 11.2 r202
  • Adobe® Acrobat® Plug-in for Web Browsers, Version 10.1.3
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • DivX VOD Helper Plug-in
  • DivX Plus Web Player version 2.2.0.55
  • D'Fusion Web Plug-In (3.10.17865.0)
  • D'Fusion Web Plug-In for Safari 64 bits (3.10.17865.0)
  • 4.0.60531.0
  • npmnqmp 071706000001
  • RealPlayer Plugin
  • iPhoto6
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:12.0) Gecko/20100101 Firefox/12.0

More Information

Has disappeared from add-ons.

ideato 893 solutions 6250 answers

Sometimes the QuickTime plugins are not detected properly.

see if QuickTime is installed and working, in Testing QuickTime in this link : Using the QuickTime plugin with Firefox .

see also: QuickTime .



thank you

Please mark "Solved" the answer that really solve the problem, to help others with a similar problem.

Sometimes the QuickTime plugins are not detected properly. see if QuickTime is installed and working, in Testing QuickTime in this link : [https://support.mozilla.org/en-US/kb/Using%20the%20QuickTime%20plugin%20with%20Firefox Using the QuickTime plugin with Firefox] . see also: [http://kb.mozillazine.org/Quicktime QuickTime] . thank you Please mark "Solved" the answer that really solve the problem, to help others with a similar problem.
tyeguy37 0 solutions 8 answers

Helpful Reply

I finally figured out how to solve this problem. Once I made the move to Mountain Lion via clean install, Quicktime stopped working in FF, but it worked in all my other Mac browsers. The Quicktime plugin will only first register as an FF plugin when you run FF in 32-bit mode. So I quit FF, went to the Applications folder, did a "Get Info" on FF, checked the 32-bit mode box, re-ran FF, was able to see an online Quicktime video (trailers.apple.com), then quit FF, unchecked the 32-bit mode setting, and all is right in the world again.

I actually gave up on FF after all these years and tried to switch full-time to Google Chrome. That did not go as well as I expected, and so I had to figure out the FF problem or else I was going to go mad!

I finally figured out how to solve this problem. Once I made the move to Mountain Lion via clean install, Quicktime stopped working in FF, but it worked in all my other Mac browsers. The Quicktime plugin will only first register as an FF plugin when you run FF in 32-bit mode. So I quit FF, went to the Applications folder, did a "Get Info" on FF, checked the 32-bit mode box, re-ran FF, was able to see an online Quicktime video (trailers.apple.com), then quit FF, unchecked the 32-bit mode setting, and all is right in the world again. I actually gave up on FF after all these years and tried to switch full-time to Google Chrome. That did not go as well as I expected, and so I had to figure out the FF problem or else I was going to go mad!
Allenjbj 0 solutions 8 answers

I was thrilled when I read this and went off to implement it. When I opened the 'get info' box I did not find anywhere to select 32-bit mode. Can you help me? I am on Lion.

I was thrilled when I read this and went off to implement it. When I opened the 'get info' box I did not find anywhere to select 32-bit mode. Can you help me? I am on Lion.
tyeguy37 0 solutions 8 answers

Allenjbj, you should see the attached window when you do a "Get Info" on the Firefox app.

Allenjbj, you should see the attached window when you do a "Get Info" on the Firefox app.
Allenjbj 0 solutions 8 answers

Helpful Reply

My "get info" does not look like that. I am on Version 12 and it says I'm up to date. Under the general tab I have the "locked" check box but not the one above it to select 32 but mode. Is this because I'm on Mac?

My "get info" does not look like that. I am on Version 12 and it says I'm up to date. Under the general tab I have the "locked" check box but not the one above it to select 32 but mode. Is this because I'm on Mac?
tyeguy37 0 solutions 8 answers

I am on a Mac as well. I believe this option is only available on Macs. Which version of the Mac OS are you running?

I am on a Mac as well. I believe this option is only available on Macs. Which version of the Mac OS are you running?
Allenjbj 0 solutions 8 answers

I am running Lion, 10.7.4

I am running Lion, 10.7.4
tyeguy37 0 solutions 8 answers

Can you post a screenshot of your full "Get Info" window for the Firefox app?

Can you post a screenshot of your full "Get Info" window for the Firefox app?
Allenjbj 0 solutions 8 answers

Yes, here it is.

Yes, here it is.
tyeguy37 0 solutions 8 answers

What model Mac do you have?

What model Mac do you have?
Allenjbj 0 solutions 8 answers

MakBookPro 4,1 I believe that is called a late 2008 when I looked to see if I could upgrade to Mountain Lion, which I plan to do soon.

MakBookPro 4,1 I believe that is called a late 2008 when I looked to see if I could upgrade to Mountain Lion, which I plan to do soon.
tyeguy37 0 solutions 8 answers

I'm wondering if your Mac supports 64-bit. I think it does if it is a late 2008 model, but I'm not sure. If not, then that means it is running in 32-bit, which also means that the Quicktime issue should resolve itself. Strange...

I'm wondering if your Mac supports 64-bit. I think it does if it is a late 2008 model, but I'm not sure. If not, then that means it is running in 32-bit, which also means that the Quicktime issue should resolve itself. Strange...
Allenjbj 0 solutions 8 answers

It does support 64 bit. I appreciate your assistance. I guess I'll just have to switch to Chrome.

I seem to remember some option when installing Lion regarding 32 vs 64 bit mode. I think I may have selected 64 bit since I didn't have any programs that appeared to need 32bit. I cannot find anything on this in a few quick searches but I'll keep looking.

It does support 64 bit. I appreciate your assistance. I guess I'll just have to switch to Chrome. I seem to remember some option when installing Lion regarding 32 vs 64 bit mode. I think I may have selected 64 bit since I didn't have any programs that appeared to need 32bit. I cannot find anything on this in a few quick searches but I'll keep looking.
tyeguy37 0 solutions 8 answers

You do have the option to either boot into 32 or 64 bit mode on the Mac (http://9to5mac.com/2011/03/20/new-macbook-pros-default-boot-in-64-bit-mode/). Maybe that will help.

I would also recommend downloading and installing the latest version of Firefox, v.15, just to see if that makes a difference for you.

You do have the option to either boot into 32 or 64 bit mode on the Mac (http://9to5mac.com/2011/03/20/new-macbook-pros-default-boot-in-64-bit-mode/). Maybe that will help. I would also recommend downloading and installing the latest version of Firefox, v.15, just to see if that makes a difference for you.
Allenjbj 0 solutions 8 answers

I updated Firefox - nothing changed. I will try booting in 32bit mode from your example and see if it helps. Thanks.

I updated Firefox - nothing changed. I will try booting in 32bit mode from your example and see if it helps. Thanks.
Allenjbj 0 solutions 8 answers

I rebooted using the 3 and 2 keys to force the boot in 32bit mode. I restarted Firefox but it was not corrected. I checked the 'get info' screen and the option to start Firefox in 32bit mode was present this time. I selected it and restarted Firefox. IT CORRECTED MY PROBLEM.

Thanks a bunch!

I rebooted using the 3 and 2 keys to force the boot in 32bit mode. I restarted Firefox but it was not corrected. I checked the 'get info' screen and the option to start Firefox in 32bit mode was present this time. I selected it and restarted Firefox. IT CORRECTED MY PROBLEM. Thanks a bunch!
tyeguy37 0 solutions 8 answers

Sweet! Glad to hear! Now never speak of switching to Chrome ever again :-) LOL

Sweet! Glad to hear! Now never speak of switching to Chrome ever again :-) LOL

Modified by tyeguy37

vampyren 1 solutions 35 answers

THANK YOU! I have had this problem and got me pissed but your simple solution worked like a charm. I tried Chrome but it had to many limitations compared to FF so here i am.

THANK YOU! I have had this problem and got me pissed but your simple solution worked like a charm. I tried Chrome but it had to many limitations compared to FF so here i am.