X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Suddenly Can't Open PDFs. Starting about three days ago firefox will no longer open any PDFs. I get a blank page in a new tab.

Posted

Suddenly Can't Open PDFs in Firefox. Starting about three days ago firefox will no longer open any PDFs. I get a blank page in a new tab. Nice timing, with finals and everything where I need to view PDFs of practice tests.

Additional System Details

Installed Plug-ins

  • Adobe® Acrobat® Plug-in for Web Browsers, Version 10.1.3
  • Java Plug-In 2 for NPAPI Browsers
  • 5.0.61118.0
  • Shockwave Flash 11.1 r102
  • View PDF documents within your web browser.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Google Talk Plugin Video Accelerator version:0.1.43.4
  • Version 1.9.2.1599
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • Office Live Update v1.0
  • iPhoto6
  • RealPlayer Plugin

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:11.0) Gecko/20100101 Firefox/11.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10737 solutions 96600 answers

See [/questions/925119]

Question owner

That helps, but I still would like to view PDFs in the browser. Its very useful when I'm trying to find scientific articles. They're usually PDFs and I don't want to download them just to see if its what I need. I tries restarting Firefox in 32 bit mode but that didn't make a difference. Is this because of some update? If it is I could just go back to the old version of whichever thing causes the problem until it is fixed.

hughejd 0 solutions 2 answers

I've tried everything suggested, from disabling the Adobe plugin to telling Firefox to view PDFs with Adobe Reader and/or Preview, to installing another PDF reader plug-in. Nothing works. I still just get a blank page in Firefox when I click on a PDF link.

douglastedford 0 solutions 1 answers

Helpful Reply

Mozilla Firefox did not do their job, here. I am an editor and am constantly online. Now, I have to go to Safari to download PDFs. I reinstalled an earlier version of Firefox to get rid of the problem, but somehow Firefox has deactivated my PDF download feature. This is a total wreck and I am so angry I could spit. Stop launching new products until you have fully tested them. Customers are not your guinea pigs. Please fix this now- and fire a few idiots on the way- the ones who let this happen.

lauriehammons 0 solutions 3 answers

Now I can't find PDFs in Preferences>Applications. Help!

cor-el
  • Top 10 Contributor
  • Moderator
10737 solutions 96600 answers
  • Firefox > Preferences > Applications > Adobe PDF document : Use Adobe Reader

PDF files may also be found under another entry like Portable document.

Try to delete the mimeTypes.rdf file in the Firefox Profile Folder to reset all file actions.

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder
lauriehammons 0 solutions 3 answers

Not having any luck. (I'm running OS X 10.6.8) Under applications, none of the items have "PDF" or "Portable" in the name. (The adobe items are: Adobe Acrobat FDF document, Adobe Acrobat XML Data Package File, and Adobe Form Client Data File.)

Under Help>Troubleshooting Information, there is not Profile Directory. The closest is "Profile Folder" but it doesn't have anything about Folders. It only has my profile, and I don't want to lose all my bookmarks.

What am I doing wrong? Thanks!

rosiegrl320 0 solutions 2 answers

Helpful Reply

"If using a Mac, go to the Firefox Plugins and disable the Adobe Acrobat NPAPI Plug-in, Version 10.1.3 or 10.1..4. This was a plugin update, and as soon as it was installed I noticed that PDFs wouldn't download.

Location: [Menu] Tools/Add-Ons/Plugins

I don't know what other issues it can create, but it solved my problem."

lauriehammons 0 solutions 3 answers

It worked! Thanks so much!