X
Tap here to go to the mobile version of the site.

Support Forum

How to enable Java Platform SE 6?

Posted

I am a professional software developer, and the product that I work on requires Java SE 6 30. It also uses a Java applet for a critical part of its functionality. I was using Firefox for debugging through Firebug. How can I enable java(tm) platform se 6 u30? Is there a later version, u31? How can I get it? It is not listed as a Firefox add-on. If neither of these alternatives work, can I install an older version of Firefox that will allow the Java(tm) platform se 6 u30 to be enabled?

I am a professional software developer, and the product that I work on requires Java SE 6 30. It also uses a Java applet for a critical part of its functionality. I was using Firefox for debugging through Firebug. How can I enable java(tm) platform se 6 u30? Is there a later version, u31? How can I get it? It is not listed as a Firefox add-on. If neither of these alternatives work, can I install an older version of Firefox that will allow the Java(tm) platform se 6 u30 to be enabled?

Additional System Details

Installed Plug-ins

Firebug Sikuli

Application

  • User Agent: Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; WOW64; Trident/5.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E; BRI/2; InfoPath.3)

More Information

The applet does not run. Instead, this message is displayed: Please turn on Java support and refresh this page.
Java(tm) platform se 6 u30 is disabled and there is no button to enable it. Firefox Add-ons does not list a Java platform to download.

Tyler Downer
  • Administrator
  • Moderator
1344 solutions 8970 answers

Helpful Reply

You can download the latest version of Java, which is 6 update 31, from www.java.com. It isn't an add-on, it's a plugin, which is why it doesn't show up on the addon website.

You can download the latest version of Java, which is 6 update 31, from [http://www.java.com www.java.com]. It isn't an add-on, it's a plugin, which is why it doesn't show up on the addon website.
ideato 893 solutions 6250 answers

Blocked older versions of Java, for security issue for a while

https://support.mozilla.org/en-US/forums/contributors/708284?last=46038#post-46038

thank you

Blocked older versions of Java, for security issue for a while https://support.mozilla.org/en-US/forums/contributors/708284?last=46038#post-46038 thank you