X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I re-enable a blocked Java Plugin?

Posted

First, let me explain. I work in a support role for a company that utilizes certain element management systems to monitor and troubleshoot network faults. Due to our company's security and application support policies we are forced to use a dated version of Firefox and Java to access the EMS's webserver.

The problem: With the recent update to Mozilla's blocking policies the Java version we utilize is being blocked and access to the site no longer functions properly. We need some method of workaround that will enable us to circumvent the block.

Disclaimers ahoy: we actively and willingly acknowledge the risks that are inherent in actions such as I request. I would ask that discussion pertains to the topic as we need an immediate workaround to access our tool and a long-term -safe- solution will be cooked up with the help of our company's processes.

I am happy to provide any details that may be needed.

Thanks! EDIT: I resolved the issue myself: see reply below.

Modified by Noah_SUMO

Chosen solution

I solved it. Proceed at your own risk

  1. Open new Tab
  2. Navigate to about:config
  3. Accept security warning
  4. Change extensions.blocklist.enabled to false
  5. Restart browser

This prevents firefox from checking the blocklist you have configured at extensions.blocklist.detailsURL

Read this answer in context 14

Additional System Details

Installed Plug-ins

  • ActiveTouch General Plugin Container Version 105
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 4.1.10111.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:5.0.1) Gecko/20100101 Firefox/5.0.1

More Information

Application Basics
Name
Firefox
Version
5.0.1
User Agent
Mozilla/5.0 (Windows NT 5.1; rv:5.0.1) Gecko/20100101 Firefox/5.0.1
Profile Directory
Open Containing Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Java Quick Starter
1.0
true
jqs@sun.com
McAfee SiteAdvisor Enterprise
3.0.0.476
false
{B7082FAA-CB62-4872-9106-E42DD88EDE45}
Microsoft .NET Framework Assistant
1.0
false
{20a82645-c095-46ed-80e3-08825760534b}
Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.places.smartBookmarksVersion
2
browser.startup.homepage
//SNIP//
browser.startup.homepage_override.buildID
20110707182747
browser.startup.homepage_override.mstone
rv:5.0.1
extensions.lastAppVersion
5.0.1
gfx.blacklist.direct2d
2
gfx.blacklist.layers.direct3d10
2
gfx.blacklist.layers.direct3d10-1
2
network.cookie.prefsMigrated
true
network.http.proxy.version
1.0
places.database.lastMaintenance
1333389780
places.history.expiration.transient_current_max_pages
112467
//SNIP//
privacy.cpd.siteSettings
true
privacy.sanitize.migrateFx3Prefs
true
security.warn_viewing_mixed
false
Graphics
Adapter Description
Intel(R) Q965/Q963 Express Chipset Family
Vendor ID
8086
Device ID
2992
Adapter RAM
Unknown
Adapter Drivers
igxprd32
Driver Version
6.14.10.4642
Driver Date
7-21-2006
Direct2D Enabled
false
DirectWrite Enabled
false (0.0.0.0, font cache n/a)
WebGL Renderer
(WebGL unavailable)
GPU Accelerated Windows
0/1

Chosen Solution

I solved it. Proceed at your own risk

  1. Open new Tab
  2. Navigate to about:config
  3. Accept security warning
  4. Change extensions.blocklist.enabled to false
  5. Restart browser

This prevents firefox from checking the blocklist you have configured at extensions.blocklist.detailsURL

mauricev 0 solutions 1 answers

I've tried this solution and it doesn't work. The preference is marked false and it's written in italics, but java remains disabled. Could it be that java is a plugin and not an extension?

Tanner1294 0 solutions 2 answers

Helpful Reply

I don't know if you're still having this problem but the last guy forgot to mention something. Once you change that string in the about:config page, you have to go to Tools > Add-ons Manager, switch to the plugins tab, and re-enable Java. The option you changed in about:config is just meant to prevent FireFox from disabling plugins in the future, not re-enable ones it's already disabled. :)

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

If prefs on the about:config page show as italic then they may have been locked (Status column shows locked) and you can't change them in cases like this.

BRRL 0 solutions 2 answers

I HIGHLY DISCOURAGE ANYONE FROM DOING THIS

THIS WILL DISABLE Firefox from checking to see if you have insecure plugins and also re-enable ANY disabled plugins, not just Java!

However, sometimes we don't get a choice.

I haven't been able to find any documentation whatsoever on how Firefox manages enabling and disabling plugins. The only place I've been able to find details is inside pluginreg.dat. It's a mostly human readable file, but it's automatically generated by Firefox and appears to be too complicated to parse and edit with any sort of simple script.

So what I did was the following:

  1. Follow blang1's instructions above in the first post to set extensions.blocklist.enabled to false using about:config or using a script or echo >> command to add the line user_pref("extensions.blocklist.enabled", false); to the users prefs.js file
  2. Delete blocklist.xml from their Firefox profile
  3. Delete pluginreg.dat from their Firefox profile

Make sure Firefox isn't open when you modify prefs.js directly (not using about:config) or try and remove the blocklist.xml or pluginreg.dat or they will just get re-written unmodified when Firefox closes down.

When Firefox starts the next time it will automatically regenerate pluginreg.dat with Java enabled and the blocklist.xml file shouldn't be downloaded anymore to disable it again.

Modified by BRRL