X
Tap here to go to the mobile version of the site.

Support Forum

New computer ff install not listing all file types under tools-options-applications

Posted

New windows installation on another with the same version of ff (10.0.2). Clicking local .pls files in this machine gives option to launch VLC media player but on other computer just text appears.

The extension appears in the applications tab after clicking tools and options on this computer, but the list is far shorter on the other machine and does not include this extension. Is this rectified by installing a plugin? If so which one?

New windows installation on another with the same version of ff (10.0.2). Clicking local .pls files in this machine gives option to launch VLC media player but on other computer just text appears. The extension appears in the applications tab after clicking tools and options on this computer, but the list is far shorter on the other machine and does not include this extension. Is this rectified by installing a plugin? If so which one?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.1 r102
  • Next Generation Java Plug-in 1.6.0_31 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.2
  • iTunes Detector Plug-in
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin
  • Npdsplay dll

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:10.0.2) Gecko/20100101 Firefox/10.0.2

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17680 solutions 159921 answers

You need the RealPlayer or another program like VLC to have support for media files like .pls.

You need the RealPlayer or another program like VLC to have support for media files like .pls. *https://support.mozilla.org/kb/Popular+plugins

Question owner

I already have vlc on both machines. The file extension doesn't appear in the applications list when I click tools-options and select the applications tab with the computer in question. It DOES appear in the list with this computer and the list is significantly longer. Clicking on a file with this machine gives me the option of saving the file (even though it already resides on the HD) or opening VLC. Click on the file with the computer in question and a text appears on the page- almost as though the file were a text file.

I already have vlc on both machines. '''The file extension doesn't appear in the applications list''' when I click tools-options and select the applications tab with the computer in question. '''It DOES appear in the list with this computer and the list is significantly longer'''. Clicking on a file with this machine gives me the option of saving the file (even though it already resides on the HD) or opening VLC. Click on the file with the computer in question and a text appears on the page- almost as though the file were a text file.

Question owner

Perhaps this is related... what determines the items that populate the list you get from clicking the applications tab? I do get that I cannot edit it so I'm puzzled by why the differences between the two computers, each running XP pro and the same version of Firefox (10.0.2). Thank you for your time.

Perhaps this is related... what determines the items that populate the list you get from clicking the applications tab? I do get that I cannot edit it so I'm puzzled by why the differences between the two computers, each running XP pro and the same version of Firefox (10.0.2). Thank you for your time.
AliceWyman
  • Moderator
240 solutions 2607 answers

See Change what Firefox does when you click on or download a file.
Quote:
When you click a link to download a file, the MIME type determines what action Firefox will take. You may already have a plugin installed that will automatically handle the download, such as Windows Media Player or QuickTime. Other times, you may see a dialog asking whether you want to save the file or open it with a specific application. When you tell Firefox to open or save the file and also check the option to "Do this automatically for files like this from now on", an entry appears for that type of file in the Firefox Applications panel.

On other words, the Applications panel - Set how Firefox handles different types of files lists file types for which you have an installed plugin or, if you don't have a plugin, for which you have downloaded the file and told Firefox to always take a specific action, such as saving it or opening it with a particular application.

You can try it out with some of the links to media files listed here:

See [[Managing file types]]. <br> '''Quote:'''<br> ''When you click a link to download a file, the MIME type determines what action Firefox will take. You may already have a plugin installed that will automatically handle the download, such as Windows Media Player or QuickTime. Other times, you may see a dialog asking whether you want to save the file or open it with a specific application. When you tell Firefox to open or save the file and also check the option to "Do this automatically for files like this from now on", an entry appears for that type of file in the Firefox Applications panel.'' On other words, the [[Options window - Applications panel]] lists file types for which you have an installed plugin or, if you don't have a plugin, for which you have downloaded the file and told Firefox to always take a specific action, such as saving it or opening it with a particular application. You can try it out with some of the links to media files listed here: *http://kb.mozillazine.org/Testing_plugins#Other_media_tests

Modified by AliceWyman

Question owner

Thank you for replying (thanks also to cor-el above) I already have VLC. The plugins list is probably where I'm going to have to go but I get the feeling that nothing is going to change that applications list... already added a couple plugins to no avail. On the computer I'm typing from I can save the ".pls" file to my hd, click on it and select the option to play... on the computer in question, clicking the local file just produces text though the icon suggests that the machine already associates it with VLC, Firefox doesn't know how to handle the file.

Thank you for replying (thanks also to cor-el above) I already have VLC. The plugins list is probably where I'm going to have to go but I get the feeling that nothing is going to change that applications list... already added a couple plugins to no avail. On the computer I'm typing from I can save the ".pls" file to my hd, click on it and select the option to play... on the computer in question, clicking the local file just produces text though the icon suggests that the machine already associates it with VLC, Firefox doesn't know how to handle the file.
cor-el
  • Top 10 Contributor
  • Moderator
17680 solutions 159921 answers

The VLC plugin doesn't show in your system details list, so Firefox can't play media files that are supported by VLC or other possible candidate plugins embedded.
If you have VLC installed then you need to check in the VLC settings if the VLC plugin for Firefox is enabled.

The VLC plugin doesn't show in your system details list, so Firefox can't play media files that are supported by VLC or other possible candidate plugins embedded.<br /> If you have VLC installed then you need to check in the VLC settings if the VLC plugin for Firefox is enabled.

Question owner

From VLC; "tools" then "plugins and extensions"?

If so what is it that I'm looking for? it doesn't look like anything I can set or enable Nothing seems to make any sense under "preferences"

Not sure what it is that I'm looking for nor what to do with it if I actually find something.

Thanks

From VLC; "tools" then "plugins and extensions"? If so what is it that I'm looking for? it doesn't look like anything I can set or enable Nothing seems to make any sense under "preferences" Not sure what it is that I'm looking for nor what to do with it if I actually find something. Thanks
cor-el
  • Top 10 Contributor
  • Moderator
17680 solutions 159921 answers
See http://wiki.videolan.org/Windows#VLC_Plugin_for_Firefox_.28Mozilla.29

Question owner

Maddeningly close... uninstalled VLC, then downloaded and reinstalled it- ensuring that the plugin for Mozilla was checked. Voila... a large number of extensions got added with the notable exception of.... you guessed it; ".pls" (playlist)

I can't win... I CAN play them directly in VLC but firefox persists in opening a text description. So close and yet no dice.

Thanks

Maddeningly close... uninstalled VLC, then downloaded and reinstalled it- ensuring that the plugin for Mozilla was checked. Voila... a large number of extensions got added with the notable exception of.... you guessed it; ".pls" (playlist) I can't win... I CAN play them directly in VLC but firefox persists in opening a text description. So close and yet no dice. Thanks
AliceWyman
  • Moderator
240 solutions 2607 answers

Here's a link to a pls file I had in my bookmarks (to play WFMU radio stream)

I never installed the VLC Media Player Mozilla plugin, just the VLC application but when I installed VLC I picked the file associations I wanted in the setup options. Currently, I have these selected as "VLC Media File" types:

  • AUDIO: OGA
  • Video: divx, FLV nsv OGG OGM OGX OGV RM RMVB WEBM
  • OTHER: pls RAM vlc

I noticed that only my selected types are listed in the VLC "Set file association" Preferences so if I ever wanted to add new types, the easiest way would be a reinstall. Ref: http://wiki.videolan.org/How_to_make_VLC_the_default_player

When I click the above .pls file link, I get an Opening dialog (see the screenshot below) and if I choose to open it with vlc.exe it plays in VLC Media player ... so it doesn't require a plugin.

If you don't see an option to "open with" the VLC application but you see a Browse button, click on it and browse to the VideoLan\VLC program folder and choose vlc. exe, for example, on my Win7 64-bit system, it's here:

  • C:\Program Files (x86)\VideoLAN\VLC\vlc.exe
Here's a link to a pls file I had in my bookmarks (to play WFMU radio stream) *http://www.wfmu.org/wfmu.pls I never installed the VLC Media Player Mozilla plugin, just the VLC application but when I installed VLC I picked the file associations I wanted in the setup options. Currently, I have these selected as "VLC Media File" types: *AUDIO: OGA *Video: divx, FLV nsv OGG OGM OGX OGV RM RMVB WEBM *OTHER: pls RAM vlc I noticed that only my selected types are listed in the VLC "Set file association" Preferences so if I ever wanted to add new types, the easiest way would be a reinstall. Ref: http://wiki.videolan.org/How_to_make_VLC_the_default_player When I click the above .pls file link, I get an Opening dialog (see the screenshot below) and if I choose to open it with vlc.exe it plays in VLC Media player ... so it doesn't require a plugin. If you don't see an option to "open with" the VLC application but you see a Browse button, click on it and browse to the VideoLan\VLC program folder and choose vlc. exe, for example, on my Win7 64-bit system, it's here: *C:\Program Files (x86)\VideoLAN\VLC\'''vlc.exe'''

Modified by AliceWyman

Question owner

The issue isn't that VLC isn't playing the files- it is... but linking to the files saved on my system does not launch VLC from Firefox on the other computer like it does on this one. I've actually been able to add to the applications list. Technically I can run the same apps and associations on both machines except that Firefox isn't handling the ".pls" files at all with the other machine

I've saved a directory structure with .pls files to different streaming radio stations and the directory is linked to from Firefox on both computers... identical directories and files stored. When I bring up one of the folders in this machine and click on the file, I first get the same dialog as you attached- I launch VLC by selecting "Open with" then clicking OK. The radio station plays. I've set it to change stations when I click within the iframe without having to go to VLC and use the open media feature- it does the trick with a single click from Firefox,

The other machine when I click the file the iframe in which the directory was displayed shows text information (urls and other arcane digital nonsense) as though the file were a text file. Both machines have similar installations.... I do not want to overload on the other machine- it's my communications backup but I would like this arrangement to work as it does on this computer.

Again, the biggest hint I see is the absence of the ".pls" file type in the list under the "applications" tab after clicking "Tools"-"Options" in Firefox on the machine in question.

Can something be done either by transplanting missing files from one machine to the next or from about:config to induce the desirable result from the other machine in Firefox?

.

The issue isn't that VLC isn't playing the files- it is... but linking to the files saved on my system does not launch VLC from Firefox on the other computer like it does on this one. I've actually been able to add to the applications list. Technically I can run the same apps and associations on both machines except that Firefox isn't handling the ".pls" files at all with the other machine I've saved a directory structure with .pls files to different streaming radio stations and the directory is linked to from Firefox on both computers... identical directories and files stored. When I bring up one of the folders in this machine and click on the file, I first get the same dialog as you attached- I launch VLC by selecting "Open with" then clicking OK. The radio station plays. I've set it to change stations when I click within the iframe without having to go to VLC and use the open media feature- it does the trick with a single click from Firefox, The other machine when I click the file the iframe in which the directory was displayed shows text information (urls and other arcane digital nonsense) as though the file were a text file. Both machines have similar installations.... I do not want to overload on the other machine- it's my communications backup but I would like this arrangement to work as it does on this computer. Again, the biggest hint I see is the absence of the ".pls" file type in the list under the "applications" tab after clicking "Tools"-"Options" in Firefox on the machine in question. Can something be done either by transplanting missing files from one machine to the next or from about:config to induce the desirable result from the other machine in Firefox? .

Question owner

By the way- thanks for the cool station... just added another file.  :)

By the way- thanks for the cool station... just added another file. :)

Question owner

Redoing the install... checked for "other" file types and ".pls" was checked by default.

Redoing the install... checked for "other" file types and ".pls" was checked by default.

Question owner

No go... I think I'm SOL here.

No go... I think I'm SOL here.
AliceWyman
  • Moderator
240 solutions 2607 answers

I guess I don't understand what you mean by "linking to the files saved on my system does not launch VLC from Firefox on the other computer like it does on this one."

How are you trying to open these .pls files on the "problem" machine?

For example, I saved the wfmu.pls file to my computer and when I open it from within Firefox from the Menu Bar (press the alt key, then click File -> Open File and browse to it) I get a similar "Opening wfmu.pls dialog (except that it shows the local file path, C:\Alice-Shel\Alice\Media) and when I choose to open it, VLC Media Player is launched and plays the radio stream. If I double-click the file, then VLC opens and plays the stream without any intervening Firefox "Opening" prompt.

I'm also not sure what you want to do now. If you want an entry in the Firefox Applications list for VLC media file (.pls) just open a pls file in Firefox like http://www.wfmu.org/wfmu.pls and then, when the "Opening wfmu.pls" dialog comes up, choose to open with VLC.exe and check the ""Do this automatically" box.

I guess I don't understand what you mean by "linking to the files saved on my system does not launch VLC from Firefox on the other computer like it does on this one." How are you trying to open these .pls files on the "problem" machine? For example, I saved the wfmu.pls file to my computer and when I open it from within Firefox from the Menu Bar (press the alt key, then click File -> Open File and browse to it) I get a similar "Opening wfmu.pls dialog (except that it shows the local file path, C:\Alice-Shel\Alice\Media) and when I choose to open it, VLC Media Player is launched and plays the radio stream. If I double-click the file, then VLC opens and plays the stream without any intervening Firefox "Opening" prompt. I'm also not sure what you want to do now. If you want an entry in the Firefox Applications list for VLC media file (.pls) just open a pls file in Firefox like http://www.wfmu.org/wfmu.pls and then, when the "Opening wfmu.pls" dialog comes up, choose to open with VLC.exe and check the ""Do this automatically" box.

Modified by AliceWyman

Question owner

I save the files on my computer. Clicking on the files in this computer launches VLC after I check the appropriate option and click ok. It appears that I am not going to be able to do the same on the other computer... I'll have to figure something else out... I've uninstalled and reinstalled VLC several times... and Firefox a couple times. I have no idea how the extension shows up in the applications list in Firefox on this computer but I cannot get it to do the same on the other regardless of what I do during the installation of VLC. It's entirely possible that it isn't supposed to work like I have it set up now with this computer and I've inadvertently exploited a glitch somewhere in the works.

I save the files on my computer. Clicking on the files in this computer launches VLC after I check the appropriate option and click ok. It appears that I am not going to be able to do the same on the other computer... I'll have to figure something else out... I've uninstalled and reinstalled VLC several times... and Firefox a couple times. I have no idea how the extension shows up in the applications list in Firefox on this computer but I cannot get it to do the same on the other regardless of what I do during the installation of VLC. It's entirely possible that it isn't supposed to work like I have it set up now with this computer and I've inadvertently exploited a glitch somewhere in the works.
AliceWyman
  • Moderator
240 solutions 2607 answers

I was editing my last reply while you were posting.

If you want an entry in the Firefox Applications list for VLC media file (.pls) just open a pls file in Firefox like http://www.wfmu.org/wfmu.pls and then, when the "Opening wfmu.pls" dialog comes up, choose to open with VLC.exe and check the ""Do this automatically" box.

I was editing my last reply while you were posting. If you want an entry in the Firefox Applications list for VLC media file (.pls) just open a pls file in Firefox like http://www.wfmu.org/wfmu.pls and then, when the "Opening wfmu.pls" dialog comes up, choose to open with VLC.exe and check the ""Do this automatically" box.
cor-el
  • Top 10 Contributor
  • Moderator
17680 solutions 159921 answers

If Firefox opens a .pls file as a text file in a tab then that means that Firefox sees a file that is send as text/plain and not with the correct MIME type for such a .pls file.

  • Tools > Page Info > General

You may have other software or a Firefox extension that changes to content type in that case.

If Firefox opens a .pls file as a text file in a tab then that means that Firefox sees a file that is send as text/plain and not with the correct MIME type for such a .pls file. * Tools > Page Info > General You may have other software or a Firefox extension that changes to content type in that case.

Question owner

It does this on a website but not on my computer.

It does this on a website but not on my computer.

Question owner

To cor-el, it shows up as text, plain ISO-8859-1 with the address being the file name (with directory route) on the afflicted machine and opening in a new tab with this computer produces, text/html UTF-8 with about:blank... basically showing the file in another application and not on the page.

To cor-el, it shows up as text, plain ISO-8859-1 with the address being the file name (with directory route) on the afflicted machine and opening in a new tab with this computer produces, text/html UTF-8 with about:blank... basically showing the file in another application and not on the page.