X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Store locator does not work on the HomeDepot and Lowes sites

Posted

When I enter my zipcode and try to find a store on the Lowes or Home Depot sites nothing happens. I set NoScript to allow the page.

Chosen solution

I had the same issue. Was running the add-on TACO Abine. When I disabled this add-on, the store locator worked.

Read this answer in context 2

Additional System Details

Sites Affected

http://

Installed Plug-ins

  • Garmin Communicator Plug-In 4.0.1.0
  • Shockwave Flash 11.1 r102
  • Next Generation Java Plug-in 1.6.0_31 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Google Update
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.2
  • DivX Plus Web Player version 2.2.0.52
  • 5.0.61118.0
  • GEPlugin
  • Google Updater pluginhttp://pack.google.com/
  • Logitech Device Detection
  • DivX VOD Helper Plug-in
  • getplusplusadobe16263
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin
  • Npdsplay dll
  • Rhapsody Player Engine Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:10.0.2) Gecko/20100101 Firefox/10.0.2

More Information

jscher2000
  • Top 10 Contributor
2344 solutions 20790 answers

The NoScript popup shows several others sites contributing scripts on those pages.

For Lowes, it works with the 3 Google-related domains allowed.

For Home Depot, make sure to allow mapquestapi.com as well (not sure whether you need the Google sites, too, I had already allowed them).

Question owner

Everything on the page is allowed now. It didn't work???

Modified by ulrs2007

Question owner

I even unstalled NoScript but I still can't use store locator. It does not seem to be associated with NoScript.

jscher2000
  • Top 10 Contributor
2344 solutions 20790 answers

So it's not really solved?

It's curious because Lowes uses Google Maps, and Home Depot uses Mapquest. The fact that neither is working seems like a strange coincidence.

Can you fill and submit the form -- but you don't get results -- or can you not use the form at all?

In case the problem is a different add-on, you could try Firefox's Safe Mode as a diagnostic test.

First, I recommend backing up your Firefox settings in case something goes wrong. See Backing up your information. (You can copy your entire Firefox profile folder somewhere outside of the Mozilla folder.)

Next, try restarting Firefox with add-ons disabled through Firefox's Safe Mode. Be careful not to "reset" anything permanently if you didn't back up.

If the sites work in Safe Mode, one of your other add-ons might be the culprit.

If Safe Mode doesn't work, either, perhaps there is some other security software on your system that is blocking it. For example, some security suites will look for form submissions containing personal information and filter them. A zip code isn't that personal, but...

Question owner

Thank you for your help. I decided to check my security software. I disabled it temporally and no change. I tried a few add on disables, e.g. NoScript, Search Engine Security and finally Disconnect 1.0.1 which was the problem. There are probably other add ons that cause this problem.

Modified by ulrs2007

ahr1 1 solutions 1 answers

Chosen Solution

I had the same issue. Was running the add-on TACO Abine. When I disabled this add-on, the store locator worked.

chelsea46 0 solutions 2 answers

I have related problem with Lowe’s store locator. The Lowe’s acct/locator header will not record ‘MY store’. The feature to find store –zip & map work, but locator will not register selection. The header constantly loops making scrolling / accessing content impossible ( web site goes back to header). The Lowe's web sits working fine in Internet Explorer. I have: Tried Firefox in safe mode , scanned for malware / viruses, turn off all firewall & security. Have no problems with other websites - I am using Win7 - I am baffled

Modified by chelsea46

jscher2000
  • Top 10 Contributor
2344 solutions 20790 answers

Hi chelsea46, can you post the URL of the page that isn't working correctly and describe the steps to reproduce the problem?

Also, when you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

1. Clear Firefox's Cache

orange Firefox button or Tools menu > Options > Advanced

On the Network mini-tab > Offline Storage : "Clear Now"

2. If needed, delete the site's cookies here

While viewing a page on the site, right-click and choose View Page Info > Security > "View Cookies"

Then try reloading the page. Does that help?

cor-el
  • Top 10 Contributor
  • Moderator
10737 solutions 96600 answers

Also make sure that you aren't blocking cookies from that site (the site may be using other domains as well).

  • Tools > Options > Privacy > Cookies: "Exceptions"
chelsea46 0 solutions 2 answers

Must thank everyone for there help... cleared cookies but that was not the solution, turned out to be Lowe's blocked in cookies 'exceptions'. Once removed the site now works correctly... Thanks...