X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Need a 32-bit Firefox for my 64-bit Vista system

Posted

Certain web sites won't work with the 64-bit Firefox browser - I want to install a 32-bit version onto my 64-bit Vista system.

The automatic download of Firefox does not give me any options nor are there any obvious links on the Mozilla site.

Where can I get this 32-bit version?

Thanks.

Chosen solution

There is not 64-bit version for firefox, only 32 see:

Firefox 10 System Requirements


64-bit version is only Nightly but it is for testing purposes only, and there is not in release channel, as latest 10.0.

Firefox Nightly


thanks again

Read this answer in context 0

Additional System Details

Sites Affected

http://

Installed Plug-ins

  • Shockwave Flash 11.1 r102
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_30 for Mozilla browsers
  • 4.0.60831.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape "9.3.3"
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • np-mswmp

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; WOW64; rv:10.0) Gecko/20100101 Firefox/10.0

More Information

ideato
  • Top 25 Contributor
617 solutions 4264 answers

try from : http://www.mozilla.org/en-US/firefox/all.html


thank you

Question owner

Hi - that just gives me the option to download the regular file which will detect my 64-bit system and give me the 64-bit version (as far as I can tell)

Thanks anyway.

ideato
  • Top 25 Contributor
617 solutions 4264 answers

Chosen Solution

There is not 64-bit version for firefox, only 32 see:

Firefox 10 System Requirements


64-bit version is only Nightly but it is for testing purposes only, and there is not in release channel, as latest 10.0.

Firefox Nightly


thanks again

Question owner

Thanks - then my software vendour telling me his software doesn't work because I am using a 64-bit browser and need to use a 32-bit browser obviously doesn't know what he's talking about!