X
Tap here to go to the mobile version of the site.

Support Forum

Websites show dates in American format - if I use Internet Exporer the dates show correctly in English format.

Posted

I am running FF 3.6.25 on Windows 2000. My Windows locale and date format are correctly set to UK.

When I go to a site that has a date column, the date is formatted wrongly in American style (e.g. 12/30/2011). If I use Internet Explorer to reach the same sites the date is correctly formatted in British style (e.g. 30/12/2011). How can I set the display style within Firefox?

With thanks for any advice you can offer.

Keith

I am running FF 3.6.25 on Windows 2000. My Windows locale and date format are correctly set to UK. When I go to a site that has a date column, the date is formatted wrongly in American style (e.g. 12/30/2011). If I use Internet Explorer to reach the same sites the date is correctly formatted in British style (e.g. 30/12/2011). How can I set the display style within Firefox? With thanks for any advice you can offer. Keith

Chosen solution

You can check the order of the installed Languages and make sure that en-GB is on top..

  • Tools > Options > Content > Languages
Read this answer in context 2

Additional System Details

Sites Affected

http://

Installed Plug-ins

  • Default Plug-in
  • Shockwave Flash 10.3 r183
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_17 for Mozilla browsers
  • Adobe Acrobat Plug-In Version 7.00 for Netscape
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object
  • Npdsplay dll

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2.25) Gecko/20111212 Firefox/3.6.25

More Information

Application Basics
Name
Firefox
Version
3.6.25
Profile Directory
Open Containing Folder
Installed Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Java Quick Starter
1.0
true
jqs@sun.com
Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.history_expire_days
20
browser.history_expire_days.mirror
20
browser.history_expire_days_min
60
browser.places.smartBookmarksVersion
2
browser.startup.homepage
http://www.tesco.net/
browser.startup.homepage_override.mstone
rv:1.9.2.25
extensions.lastAppVersion
3.6.25
network.cookie.prefsMigrated
true
places.last_vacuum
1326317313
print.print_printer
HP Deskjet D2560
print.printer_HP_Deskjet_D2560.print_bgcolor
false
print.printer_HP_Deskjet_D2560.print_bgimages
false
print.printer_HP_Deskjet_D2560.print_command
print.printer_HP_Deskjet_D2560.print_downloadfonts
false
print.printer_HP_Deskjet_D2560.print_edge_bottom
0
print.printer_HP_Deskjet_D2560.print_edge_left
0
print.printer_HP_Deskjet_D2560.print_edge_right
0
print.printer_HP_Deskjet_D2560.print_edge_top
0
print.printer_HP_Deskjet_D2560.print_evenpages
true
print.printer_HP_Deskjet_D2560.print_footercenter
print.printer_HP_Deskjet_D2560.print_footerleft
&PT
print.printer_HP_Deskjet_D2560.print_footerright
&D
print.printer_HP_Deskjet_D2560.print_headercenter
print.printer_HP_Deskjet_D2560.print_headerleft
&T
print.printer_HP_Deskjet_D2560.print_headerright
&U
print.printer_HP_Deskjet_D2560.print_in_color
true
print.printer_HP_Deskjet_D2560.print_margin_bottom
0.5
print.printer_HP_Deskjet_D2560.print_margin_left
0.303472220897675
print.printer_HP_Deskjet_D2560.print_margin_right
0.5
print.printer_HP_Deskjet_D2560.print_margin_top
0.421527773141861
print.printer_HP_Deskjet_D2560.print_oddpages
true
print.printer_HP_Deskjet_D2560.print_orientation
0
print.printer_HP_Deskjet_D2560.print_pagedelay
500
print.printer_HP_Deskjet_D2560.print_paper_data
9
print.printer_HP_Deskjet_D2560.print_paper_height
11.00
print.printer_HP_Deskjet_D2560.print_paper_size_type
0
print.printer_HP_Deskjet_D2560.print_paper_size_unit
1
print.printer_HP_Deskjet_D2560.print_paper_width
8.50
print.printer_HP_Deskjet_D2560.print_reversed
false
print.printer_HP_Deskjet_D2560.print_scaling
1.00
print.printer_HP_Deskjet_D2560.print_shrink_to_fit
false
print.printer_HP_Deskjet_D2560.print_to_file
false
print.printer_HP_Deskjet_D2560.print_unwriteable_margin_bottom
0
print.printer_HP_Deskjet_D2560.print_unwriteable_margin_left
0
print.printer_HP_Deskjet_D2560.print_unwriteable_margin_right
0
print.printer_HP_Deskjet_D2560.print_unwriteable_margin_top
0
privacy.sanitize.migrateFx3Prefs
true
security.enable_ssl2
true
security.warn_viewing_mixed
false

cor-el
  • Top 10 Contributor
  • Moderator
17574 solutions 158975 answers

Chosen Solution

You can check the order of the installed Languages and make sure that en-GB is on top..

  • Tools > Options > Content > Languages
You can check the order of the installed Languages and make sure that en-GB is on top.. *Tools > Options > Content > Languages

Question owner

Yes, that worked. My languages list had English at the top but I had not known there was also an en-GB. I added it to the list and moved to the top.

Thank you.

Yes, that worked. My languages list had English at the top but I had not known there was also an en-GB. I added it to the list and moved to the top. Thank you.