X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Why am I now having certificate issues with Firefox but not IE?

Posted

I can no longer log into Gmail, Facebook, Amazon, etc... using Firefox. I get the following error "accounts.google.com uses an invalid security certificate. The certificate is not trusted because no issuer chain was provided. (Error code: sec_error_unknown_issuer)". It works with IE but not Firefox. This just started a few days ago - prior to that I was able to log into those https sites without issue. Any suggestions? Thank you.

Additional System Details

Sites Affected

https://accounts.google.com/ServiceLogin?service=mail&passive=true&rm=false&continue=https://mail.google.com/mail/?tab%3Dwm&scc=1&ltmpl=googlemail

Installed Plug-ins

  • Shockwave Flash 11.1 r102
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.3.633
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_29 for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.1
  • 4.0.60831.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DBsign Web Signer Plugin
  • The DBsign Government Smart Card Information Tool allows data elements from GSC compliant smartcards to be read from browser based applications. USE OF THIS PRODUCT IS GOVERNED BY THE DBSIGN LICENSE AGREEMENT.

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:9.0.1) Gecko/20100101 Firefox/9.0.1

More Information

Hasan 477 solutions 5600 answers

Perform the suggestions mentioned in the following articles:

Check and tell if its working.

Helpful Reply

No it will not let me bypass the warning

Hasan 477 solutions 5600 answers

Make sure that the values of the following Preferences are set to True on the about:config page

  • browser.xul.error_pages.enabled
  • browser.xul.error_pages.expert_bad_cert

You can check who issued that certificate.

You can retrieve the certificate to check who issued the certificate. You should always do that to see if that helps to identify the problem (missing intermediate certificate or something else).

-> click the link at the bottom of the error page: "I Understand the Risks"

-> Let Firefox retrieve the certificate: "Add Exception" -> "Get Certificate".

  • click the "View..." button to inspect the certificate and check who is the issuer.

-> Only leave the checkmark in the box at the bottom to "Permanently store this exception" if you trust that certificate.

  • click "Confirm Security Exception" to enter the site if you still want to go to that website.

Check and tell if its working.

Helpful Reply

"browser.xul.error_pages.expert_bad_cert" was set on false so I set it to true and tried reloading. Got the page giving me the option to add exception and continue. Kept trying that and would not continue to the page even after accepting 10+ times.

Hasan 477 solutions 5600 answers

-> Clear Cookies & Cache

-> Clear the Network Cache

Check and tell if its working.

Question owner

Did both, no luck. Still getting the page with this (see below). I don't understand why it's letting me use FF to log in to Mozilla to reply to these...but I can't log into facebook, gmail, etc.


This Connection is Untrusted

         You have asked Firefox to connect securely to accounts.google.com, but we can't confirm that your connection is secure. Normally, when you try to connect securely, sites will present trusted identification to prove that you are

going to the right place. However, this site's identity can't be verified.

         What Should I Do?
         
           If you usually connect to this site without problems, this error could mean that someone is trying to impersonate the site, and you shouldn't continue.
       
         Technical Details
         accounts.google.com uses an invalid security certificate.

The certificate is not trusted because no issuer chain was provided.

(Error code: sec_error_unknown_issuer)


         I Understand the Risks
         
           If you understand what's going on, you can tell Firefox to start trusting this site's identification. Even if you trust the site, this error could mean that someone is tampering with your connection.
           Don't add an exception unless you know there's a good reason why this site doesn't use trusted identification.
Hasan 477 solutions 5600 answers

In your Firefox Connection settings, what kind of connection is selected ??

Question owner

No proxy

Hasan 477 solutions 5600 answers

Try changing it to Auto-Detect Proxy Settings for this Network or Use System Proxy Settings.

Check and tell if it works.

Question owner

Tried both and did not work.

cor-el
  • Top 10 Contributor
  • Moderator
10745 solutions 96690 answers

Who is the issuer of the certificates?

You can retrieve the certificate and check details like who issued certificates and expiration dates of certificates.

  • Click the link at the bottom of the error page: "I Understand the Risks"

Let Firefox retrieve the certificate: "Add Exception" -> "Get Certificate".

  • Click the "View..." button and inspect the certificate and check who is the issuer.

You can see more Details like intermediate certificates that are used in the Details pane.

Question owner

Starting in Safe Mode, did not work.

Hasan 477 solutions 5600 answers

Create a New Profile as a test to check if your current profile is causing the problems.

Now browse the website on which you were having problems earlier. Check and tell if it works.

Question owner

Created a new profile. I was able to log into Gmail but still had some features disabled (would not show contacts online). Also still could not log onto Facebook

Hasan 477 solutions 5600 answers

-> Fix login issues on websites that require a username and password

Check and tell if its working.

cor-el
  • Top 10 Contributor
  • Moderator
10745 solutions 96690 answers

You haven't told us who issued the rejected certificate, so can you please do that?

curapy 0 solutions 1 answers

The problem was that the certificate was issued by ESET. I unistalled ESET Internet Security and re-installed the new version with parental control disabled. Now firefox opens gmail sign in just fine. I had no trouble before with IE, just with firefox 13. Now the google certificate appears as issued by Thawte SGC CA and not by ESET.

a40098 0 solutions 16 answers

I've had problems with Firefox 13 and gmail/google accounts. In Firefox 13 the SPDY is enabled by default, previous Firefox versions had it disabled.

Once I disabled SPDY in Firefox 13, all my gmail and google accounts have no problems or errors but with it enabled, google can't handle it for some reason.

To disable, about:config and change:

network.http.spdy.enabled - set to false.