X
Tap here to go to the mobile version of the site.

Support Forum

Untrusted site, no option to click I understand the risks

Posted

So someone screwed something up on the proxy servers here at work (at least that's all we can figure out). When I try to go to Google.com, I get one of those Untrusted Sites warning messages that it is trying to connect to accounts.google.com and can't verify that it's secure.

Problem is, I don't have the option to click I understand the Risks and tell it to just go through anyway. I only get the option to Leave or view the details.

Is there any way to add accounts.google.com to an exception list or anything like that so I can just force it to work? Or is there any way to force the Understand Risks area to show up so I can do the Add Exception thing?

Thanks.

So someone screwed something up on the proxy servers here at work (at least that's all we can figure out). When I try to go to Google.com, I get one of those Untrusted Sites warning messages that it is trying to connect to accounts.google.com and can't verify that it's secure. Problem is, I don't have the option to click I understand the Risks and tell it to just go through anyway. I only get the option to Leave or view the details. Is there any way to add accounts.google.com to an exception list or anything like that so I can just force it to work? Or is there any way to force the Understand Risks area to show up so I can do the Add Exception thing? Thanks.

Additional System Details

Sites Affected

https://accounts.google.com

Installed Plug-ins

  • CouponNetwork Coupon Activator
  • Shockwave Flash 10.3 r183
  • Google Update
  • GEPlugin
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_29 for Mozilla browsers
  • ActiveTouch General Plugin Container Version 105
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Coupons, Inc. Coupon Printer Plugin
  • Coupons, Inc. Coupon Printer DLL
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.5"
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin
  • Npdsplay dll

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:9.0.1) Gecko/20100101 Firefox/9.0.1

More Information

Hasan 469 solutions 5600 answers

Check the pref browser.xul.error_pages.enabled on the about:config page and make sure that the value is set to true (default).

Check and tell if its working.

Check the pref '''browser.xul.error_pages.enabled''' on the '''about:config''' page and make sure that the value is set to '''true''' (default). * http://kb.mozillazine.org/about%3Aconfig Check and tell if its working.

Modified by Hasan

Question owner

That setting was set to True but the one underneath it was set to False. I set that one to True and then I did get the Add Exception box. However, when I click it to add the exception, it didn't do anything.

That setting was set to True but the one underneath it was set to False. I set that one to True and then I did get the Add Exception box. However, when I click it to add the exception, it didn't do anything.
Hasan 469 solutions 5600 answers

You can check who issued that certificate.

You can retrieve the certificate to check who issued the certificate. You should always do that to see if that helps to identify the problem (missing intermediate certificate or something else).

-> click the link at the bottom of the error page: "I Understand the Risks"

-> Let Firefox retrieve the certificate: "Add Exception" -> "Get Certificate".

  • click the "View..." button to inspect the certificate and check who is the issuer.

-> Only leave the checkmark in the box at the bottom to "Permanently store this exception" if you trust that certificate.

  • click "Confirm Security Exception" to enter the site if you still want to go to that website.

-> Troubleshoot the "Secure Connection Failed" error message

Check and tell if its working.

You can check who issued that certificate. You can retrieve the certificate to check who issued the certificate. You should always do that to see if that helps to identify the problem (missing intermediate certificate or something else). -> click the link at the bottom of the error page: "I Understand the Risks" -> Let Firefox retrieve the certificate: "Add Exception" -> "Get Certificate". * click the "View..." button to inspect the certificate and check who is the issuer. -> Only leave the checkmark in the box at the bottom to "Permanently store this exception" if you trust that certificate. * click "Confirm Security Exception" to enter the site if you still want to go to that website. -> [[Secure Connection Failed]] Check and tell if its working.

Modified by Hasan

Question owner

Issues to: Google. Issued By: Our internal proxy server

I checked the box and clicked Confirm but it still goes right back to the Untrusted page. It's just not taking.

Issues to: Google. Issued By: Our internal proxy server I checked the box and clicked Confirm but it still goes right back to the Untrusted page. It's just not taking.
Hasan 469 solutions 5600 answers
-> Clear Cookies & Cache * https://support.mozilla.com/en-US/kb/Template:clearCookiesCache -> [[How to clear the cache#w_clear-the-cache|Clear the Network Cache]] -> [[This connection is untrusted]] Check and tell if its working.

Question owner

Tried all that. Didn't help.

Tried all that. Didn't help.
Vivek 289 solutions 2084 answers

From the image it looks like SSL proxying is not working, so you may be able to entirely disable SSL for the browsing session in Tools (Alt + T) > Options > Advanced > Network > Settings or at least exempt .google .com

From the image it looks like SSL proxying is not working, so you may be able to entirely disable SSL for the browsing session in '''Tools''' ('''Alt''' + '''T''') > '''Options''' > '''Advanced''' > '''Network''' > '''Settings''' or at least exempt .google .com
cor-el
  • Top 10 Contributor
  • Moderator
12307 solutions 113979 answers

You write: Issued By: Our internal proxy server

You seem to be using a proxy server that makes its own secure connection to the server and that send a certificate to to Firefox.
Such a setup will only work properly if you can install a root certificate from that proxy server.
If you do not need to use that proxy server then choose a direct connection.

You write: Issued By: Our internal proxy server You seem to be using a proxy server that makes its own secure connection to the server and that send a certificate to to Firefox.<br /> Such a setup will only work properly if you can install a root certificate from that proxy server.<br /> If you do not need to use that proxy server then choose a direct connection.
WmHayashi 0 solutions 1 answers

Helpful Reply

Okay, I tried all the suggestions already mentioned above and they didn't work. The system I'm using is a Ubuntu 11.10 with Firefox 11.0. Here's the way I worked around the problem:

1. Started Firefox and went to the "offending site." 2. Opened a new tab and entered "about:certerror" and got the add exception panel (finally). 3. Copied the URL of the offending site from the first tab and pasted it into the URL field of the exception panel. 4. Followed the directions to make the exception permanent.

What a pain in the butt to get there {grin}!

Happy computing...

WmH

Okay, I tried all the suggestions already mentioned above and they didn't work. The system I'm using is a Ubuntu 11.10 with Firefox 11.0. Here's the way I worked around the problem: 1. Started Firefox and went to the "offending site." 2. Opened a new tab and entered "about:certerror" and got the add exception panel (finally). 3. Copied the URL of the offending site from the first tab and pasted it into the URL field of the exception panel. 4. Followed the directions to make the exception permanent. What a pain in the butt to get there {grin}! Happy computing... WmH