Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why isn't there an override for the following?

  • 9 replies
  • 5 have this problem
  • 42 views
  • Last reply by nomedigas

more options

Websites prohibit password saving

Some websites do not allow for passwords to be saved for security reasons. If you have followed the steps above, but are still not prompted to save a password when logging into a certain website, that site may have disabled password saving.

Chosen solution

The website may be using autocomplete=off to prevent Firefox from saving the name and password or create the login form via JavaScript.

You can remove autocomplete=off with a bookmarklet to make Firefox save the name and password.

There is also this extension to create new entries yourself, but that won't help in all cases to make Firefox fill them.

Read this answer in context 👍 1

All Replies (9)

more options

No, because the website software controls whether you are prompted to save the password for that site; "Some websites do not allow..." and "that site may have disabled password saving."


If this reply solves your problem, please click "Solved It" next to this reply when signed-in to the forum.



Not related to your question, but...

You may need to update some plug-ins. Check your plug-ins and update as necessary:

more options

Chosen Solution

The website may be using autocomplete=off to prevent Firefox from saving the name and password or create the login form via JavaScript.

You can remove autocomplete=off with a bookmarklet to make Firefox save the name and password.

There is also this extension to create new entries yourself, but that won't help in all cases to make Firefox fill them.

more options

Hi, thanks for you help and quick reply, but none of this is working. When I right clicked, "Save login info", was not an option. There was no "autocomplete=off", when I first clicked on "Do not save password", and this isn't a website that "doesn't allow" or has "that site may have disabled password saving." Please help! This is becoming a mission. I am imac by the way.

more options

I'm not sure what you mean with "Save login info" in the right-click context menu. Such a choice can only be added by an extension.

Websites can change the code at any time, so if you got a chance to save the password earlier then what doesn't mean that it will wok now. The bookmarklet should give information about the presence of autocomplete.
There can be other reasons for not getting that offer like an exception or other problems with the password manager.

  • Tools > Options > Security: Passwords: Exceptions
more options

Someone else suggested 'Right-click on one of its fields and select from among "Save login info" (to create a new entry), "Edit login info", and "Delete login info".' (on the log-in page)

I have tried 'Tools > Options > Security: Passwords: Exceptions' and there was only one exception (for an AOL page, which I removed anyway). The website I want to use was not listed in the 'Exceptions' panel.
more options

You need this extension to get that option.

more options

I repeat:

Someone else suggested 'Right-click on one of its fields and select from among "Save login info" (to create a new entry), "Edit login info", and "Delete login info".' (on the log-in page)

I have tried 'Tools > Options > Security: Passwords: Exceptions' and there was only one exception (for an AOL page, which I removed anyway). The website I want to use was not listed in the 'Exceptions' panel.

If anyone has any suggestions why none of this is working, please help. Thanks.

more options

Hi. I am the developer of Saved Password Editor. The menu items you are talking about ("Save login info", etc.) are provided by my extension. They do not normally exist in Firefox; you have to install Saved Password Editor to use them. See the link cor-el has already provided.

I'm pretty sure you are the one who emailed me a few days ago with this same "problem". I misunderstood you because I assumed (reasonably, I think) that you had already installed SPE and it wasn't working for you. But it looks as though, for some reason, you picked up a "tip" that you thought was for Firefox itself. Sorry for not realizing that.

The thing you say "someone else suggested" is a direct quote from the add-on description for SPE and is to be understood in the context that they are instructions for the add-on, not Firefox in general. If you saw that out of context, I would be interested to know where you read it. The same goes for the instructional video; after all, it is titled "HOWTO: Saved Password Editor 2.5", and I begin by saying that this is how to use Saved Password Editor.

Now, if you actually have installed SPE and you're still experiencing this, that's another thing entirely. Look in the Tools menu; there should be a "Saved Passwords" item if SPE is installed. You can also go to Tools > Add-ons and look under "Extensions"; it should be listed and not say, "(disabled)". Also, what version of Firefox are you using?

more options

Yes you are correct on both counts. It was me and I hadn't installed it. I did think that was the case, but was trying to sort this problem whist doing a hundred other things and didn't spend enough time on it. I really appreciate your time and help, but I was more interested in trying to work out why Firefox's password saver wasn't working and what I could do to overcome that. Thanks, again.