X
Tap here to go to the mobile version of the site.

Support Forum

How do I permanently get rid of Yahoo in the search bar?

Posted

I "Manage Search Engines" and remove it, but every time I restart Firefox it's there again as the default. How do I get rid of Yahoo permanently? It is not my chosen search engine, and brings up very limited results.

I "Manage Search Engines" and remove it, but every time I restart Firefox it's there again as the default. How do I get rid of Yahoo permanently? It is not my chosen search engine, and brings up very limited results.

Chosen solution

The right click does not work when I highlight the link

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.1 r102
  • Google Update
  • GEPlugin
  • 4.0.60831.0
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.5"
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.1"
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • ActiveTouch General Plugin Container Version 105
  • 1.9.0009.1
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin
  • Npdsplay dll
  • np-mswmp

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:9.0.1) Gecko/20100101 Firefox/9.0.1

More Information

Swarnava Sengupta 482 solutions 3210 answers
  • Step 1: Open a new Firefox browser window.
  • Step 2: Type about:config in the search field and press Enter.
  • Step 3: Click the "I Will Be Careful" button if necessary.
  • Step 4: Scroll to find a configuration key titled: keyword.URL
  • Step 5: Select "keyword.URL" and right-click, then hit "Reset" from the drop-down menu.
* Step 1: Open a new Firefox browser window. * Step 2: Type '''about:config''' in the search field and press Enter. * Step 3: Click the''' "I Will Be Careful"''' button if necessary. * Step 4: Scroll to find a configuration key titled:''' keyword.URL''' * Step 5: Select '''"keyword.URL"''' and right-click, then hit "Reset" from the drop-down menu.

Modified by Swarnava Sengupta

Question owner

I tried that and Yahoo took over again. But your reply gave me someplace to start! In Firefox I had clicked on not allowing other search engines to take over, so I did another Internet search and found this string: http://www.google.com/search?ie=UTF-8&oe=utf-8&q= which restores Google as the default search engine. I UNclicked not allowing other search engines to take over, then back into Firefox, managed my search engines to delete Yahoo (AGAIN!) then went to the config, right clicked on keyword.url, hit MODIFY and popped that string in there. It works! Now I'll go back and click again on not allowing other search engines to take over. THANKS!

I tried that and Yahoo took over again. But your reply gave me someplace to start! In Firefox I had clicked on not allowing other search engines to take over, so I did another Internet search and found this string: http://www.google.com/search?ie=UTF-8&oe=utf-8&q= which restores Google as the default search engine. I UNclicked not allowing other search engines to take over, then back into Firefox, managed my search engines to delete Yahoo (AGAIN!) then went to the config, right clicked on '''keyword.url''', hit '''MODIFY''' and popped that string in there. It works! Now I'll go back and click again on not allowing other search engines to take over. THANKS!

Modified by ChesapkLady

stomperud 0 solutions 1 answers

Here is the reason of the problem. http://howtodosteps.blogspot.com/2011/06/what-is-spigot-inc-searchsettingexe.html You have to stop this progrem from starting. "c:\program files\common files\spigot\Search setting\searchsetting.exe"

Here is the reason of the problem. [http://howtodosteps.blogspot.com/2011/06/what-is-spigot-inc-searchsettingexe.html http://howtodosteps.blogspot.com/2011/06/what-is-spigot-inc-searchsettingexe.html] You have to stop this progrem from starting. "c:\program files\common files\spigot\Search setting\searchsetting.exe"
TRose2342 0 solutions 1 answers

Helpful Reply

Nothing here works (1/22/2012). The only thing I could do was go to the Firefox tab in the left corner, go to Help, click Restart with Add-ons Disabled, wait for the little window to come up and check reset everything then click restart to make Yahoo go away. Of course my other tabs went away, but I had the URLs written down anyway. Now Google is my default engine again.

Nothing here works (1/22/2012). The only thing I could do was go to the Firefox tab in the left corner, go to Help, click Restart with Add-ons Disabled, wait for the little window to come up and check reset everything then click restart to make Yahoo go away. Of course my other tabs went away, but I had the URLs written down anyway. Now Google is my default engine again.

Question owner

I basically ended up doing the same, but I actually uninstalled and reinstalled Firefox with all default settings. I didn't know that you could "reset everything," because that would have been even easier.

Thanks all!

I basically ended up doing the same, but I actually uninstalled and reinstalled Firefox with all default settings. I didn't know that you could "reset everything," because that would have been even easier. Thanks all!
ct-connie 1 solutions 2 answers

Chosen Solution

The right click does not work when I highlight the link

The right click does not work when I highlight the link
ct-connie 1 solutions 2 answers

Yahoo installed as a tab in Firefox and I could not close it. I checked for Yahoo in the add on after a while I could not find the answer but I do have the answer now. Go into the add-ons. Highlight extenisons there is a program that says "Default search engine" something like that I removed that Default thing and the Yahoo tab was gone.

Yahoo installed as a tab in Firefox and I could not close it. I checked for Yahoo in the add on after a while I could not find the answer but I do have the answer now. Go into the add-ons. Highlight extenisons there is a program that says "Default search engine" something like that I removed that Default thing and the Yahoo tab was gone.