Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

No Bookmark Button (icon)

  • 15 replies
  • 17 have this problem
  • 1221 views
  • Last reply by ptoye

more options

New to Firefox. Bookmark Toolbar is checked, but no Bookmark Button on the right side of the bar with the Back icon at the left side.

Chosen solution

You only see the Bookmarks Menu button if the Menu bar is hidden (View > Toolbars or Firefox > Options).
If the Bookmarks Toolbar is visible then the Bookmarks Menu button is displayed on the Bookmarks Toolbar as part of the Bookmarks Toolbar Items (bookmarks).
Otherwise the Bookmarks Menu button will appear on the right side of the Navigation Toolbar.

Read this answer in context 👍 1

All Replies (15)

more options

Go to:

1.Orange Firefox button >

2.HOVER OVER Options >

3.Click Toolbar Layout.... >

4. Then drag the bookmarks to where you want it to go. >

5. Click "Done".

Hope this helps.

more options

You only see the Bookmarks Menu button on the Navigation Toolbar if the Menu bar is hidden and the Bookmarks Toolbar is hidden (View > Toolbars or Firefox > Options).
If the Bookmarks Toolbar is visible then the Bookmarks Menu button will appear on that toolbar.

more options

Tomatoweb. Didn't find the Firefox button, step 1, initially. Looking in the wrong place. Finally spotted it, and followed your recommendation successfully. cor-el. Unchecking Menu Bar worked. Tks to both for your effort.

Modified by stardustdrv

more options

I'm on Firefox version 11 on Linux.

Resetting to default doesn't help either. But then, it was a new installation and I'd have expected the defaults to have been active anyway.

Modified by ptoye

more options

Firefox 4+ versions have two bookmark buttons with a star in the Customize window.
One star button has a drop marker that open a Bookmark menu.
The other star button without the drop marker opens the bookmarks in the sidebar.

You can drag the Bookmarks menu button with the drop marker in the Customize window from the toolbar palette on a toolbar (e.g. Navigation Toolbar or Tab Bar or to the left side of the Bookmarks Menu Items).

Open the Customize window via "View > Toolbars > Customize"

more options

Firstly, thanks for this (which I'd not found when poking around).

But the result is interesting - as soon as I get into the "customisation" window the "bookmarks" button appears on the main window (see attached screenshot) where I'd put it. But when I close the Customisation window it disappears again. Neither rebooting or opening FF in safe mode make any difference. Odd.

Modified by ptoye

more options

Chosen Solution

You only see the Bookmarks Menu button if the Menu bar is hidden (View > Toolbars or Firefox > Options).
If the Bookmarks Toolbar is visible then the Bookmarks Menu button is displayed on the Bookmarks Toolbar as part of the Bookmarks Toolbar Items (bookmarks).
Otherwise the Bookmarks Menu button will appear on the right side of the Navigation Toolbar.

more options

Problem solved. Tks all for your help

more options

Not solved here, though. There's no Bookmarks toolbar and no icon, even though I've tried adding it several times. See the screenshot.

Modified by ptoye

more options

Quoting Co-el: "You only see the Bookmarks Menu button on the Navigation Toolbar if the Menu bar is hidden and the Bookmarks Toolbar is hidden (View > Toolbars or Firefox > Options). If the Bookmarks Toolbar is visible then the Bookmarks Menu button will appear on that toolbar."

Well, I see that now, BUT I used to have BOTH the Menu bar AND the BM button on the Navigation Bar (before upgrade) and liked it that way. I use View, History, Tools Menu items regularly, but the BM button at the end of the navigation bar is my preference due to the very quick nature of that location. How can I get this former setting back?

more options

Are you on Linux (which distribution)?

If the menu bar is hidden then press the F10 key to make the menu bar appear or move the mouse to the top left side of the screen.

Make sure that toolbars like the "Navigation Toolbar" and the "Bookmarks Toolbar" are visible: "View > Toolbars"

  • Open the Customize window via "View > Toolbars > Customize"
  • Check that the "Bookmarks Toolbar items" is on the Bookmarks Toolbar
  • If the "Bookmarks Toolbar items" is not on the Bookmarks Toolbar then drag it back from the toolbar palette in the customize window to the Bookmarks Toolbar
  • If missing items are in the toolbar palette then drag them back from the Customize window on the toolbar
  • If you do not see an item on a toolbar and in the toolbar palette then click the "Restore Default Set" button to restore the default toolbar set up
more options

Well, this still isn't working for me. I don't have (and don't much want) the Bookmarks toolbar. But when I go into "Customize" the bookmarks menu button seems to be on the Navigation toolbar. But this disappears when I exit from Customize. See my previous screenshots - no point in posting them again!

more options

I found a solution. It seems this is limited to linux in my case Ubuntu 12.04. The unity integration seems to be trigering a bug. So I thought I should look for an alternetive bookmark icon in the firefox addons. That led me to this:

https://addons.mozilla.org/en-US/firefox/addon/bug582139/?src=search

Please confirm if this works for you as well. Cheers

more options

You only see the Bookmarks Menu button if the Menu bar is hidden (View > Toolbars or Firefox > Options).
If the Bookmarks Toolbar is visible then the Bookmarks Menu button is displayed on the Bookmarks Toolbar as part of the Bookmarks Toolbar Items (bookmarks).
Otherwise the Bookmarks Menu button will appear on the right side of the Navigation Toolbar.

more options

Sorry, cor-el, but what you say (and keep on saying) just isn't true in at least my case. Look at the screen shots please before replying.

I'll have a look at Confused's solution though.

[Later] And it seems to work. Thanks a lot!

Modified by ptoye