X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Can't upgrade because I am running MAC OSX 10.4.11 on a MacMini. Am I still secure?

Posted

I am getting alerts that my version of Firefox will not be supported much longer but I can't find an upgrade that works on my Mac Mini running MAC OSX 10.4.11. Shall I use a different browser?

Chosen solution

As of Firefox 4.0 and newer one needs both OSX 10.5+ and Intel hardware. You have PPC. http://www.mozilla.org/en-US/firefox/9.0/system-requirements/

Two options since you have PPC: either continue to use Firefox 3.6 (3.6.25 is current, released yesterday) which you have. http://www.mozilla.org/en-US/firefox/all-older.html

Or you can use a third-party build from http://www.floodgap.com/software/tenfourfox/ in order to have Firefox 9.0 though do note http://code.google.com/p/tenfourfox/wiki/PluginsNoLongerSupported

Read this answer in context 3

Additional System Details

Installed Plug-ins

  • Runs Java applets using the latest installed versions of Java. For more information: Java Embedding Plugin. Run version test: Java Information.
  • Gecko default plugin
  • Java 1.3.1 Plug-in
  • DivX Content Upload Plug-In: Uploads DivX video in your browser!
  • DivX Browser Plug-In: Plays DivX video in your browser!
  • 1.0.30715
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • Shockwave Flash 10.0 r32
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.2.25) Gecko/20111212 Firefox/3.6.25

More Information

James
  • Top 25 Contributor
  • Moderator
437 solutions 3164 answers

Chosen Solution

As of Firefox 4.0 and newer one needs both OSX 10.5+ and Intel hardware. You have PPC. http://www.mozilla.org/en-US/firefox/9.0/system-requirements/

Two options since you have PPC: either continue to use Firefox 3.6 (3.6.25 is current, released yesterday) which you have. http://www.mozilla.org/en-US/firefox/all-older.html

Or you can use a third-party build from http://www.floodgap.com/software/tenfourfox/ in order to have Firefox 9.0 though do note http://code.google.com/p/tenfourfox/wiki/PluginsNoLongerSupported

Modified by James

Cheng Wang
  • Administrator
  • Moderator
36 solutions 435 answers

You can use Safari (which came with your OS) just fine. All things considered, because Apple no longer supports 10.4, and most plugin vendors (Java, Adobe) don't either, you're likely to have massive security holes that are unpatched for that reason.

In that sense, sticking to Firefox 3.6 shouldn't make you materially worse off than if you switched browsers or even if there were an update.

Question owner

Does that mean that there is no way to avoid security holes until I buy a new computer with an intel processor? My MacMini OSX meets all my current needs reliably.

Question owner

Thank you. I wish Apple had made it clear when I used Safari that it had security holes like Firefox notified me. Based on your info, I am now using TenFourFox as recommended by James. If I miss the plug ins I will buy a more modern computer.