Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

While updating my facebbook profile, I accidentally clicked on the option 'block image from profile' and a notification popped up that Firefox will no longer display images on my profile. I can't access images on my facebook page. How do I reverse this?

  • 3 replies
  • 60 have this problem
  • 11 views
  • Last reply by evahevans

more options

Profile photos of friends as well as mine cannot be displayed, instead, Firefox is only displaying names, minus any pictures. I need to have the images unblocked so that they can appear on my page. Kindly help.bold text

Chosen solution

If images are missing then check that you aren't blocking images from some domains (sphotos.ak.fbcdn.net).

  • Check the permissions for the domain in the current tab in "Tools > Page Info > Permissions"
  • Check that images are enabled: Tools > Options > Content: [X] Load images automatically
  • Check the exceptions in "Tools > Options > Content: Load Images > Exceptions"
  • Check the "Tools > Page Info > Media" tab for blocked images (scroll through all the images with the cursor Down key).

If an image in the list is grayed and there is a check-mark in the box "Block Images from..." then remove that mark to unblock the images from that domain.

There are also extensions (Tools > Add-ons > Extensions) and security software (firewall, anti-virus) that can block images.

Read this answer in context 👍 10

All Replies (3)

more options

Hi,

Please try right-clicking on the said page and choose View Page Info > Permissions and enable Allow for Load Images.

Alternatively Tools (Alt + T) > Options > Content, click Exceptions beside Load images automatically and remove the entry for Facebook.

more options

Chosen Solution

If images are missing then check that you aren't blocking images from some domains (sphotos.ak.fbcdn.net).

  • Check the permissions for the domain in the current tab in "Tools > Page Info > Permissions"
  • Check that images are enabled: Tools > Options > Content: [X] Load images automatically
  • Check the exceptions in "Tools > Options > Content: Load Images > Exceptions"
  • Check the "Tools > Page Info > Media" tab for blocked images (scroll through all the images with the cursor Down key).

If an image in the list is grayed and there is a check-mark in the box "Block Images from..." then remove that mark to unblock the images from that domain.

There are also extensions (Tools > Add-ons > Extensions) and security software (firewall, anti-virus) that can block images.

Modified by cor-el

more options

Thanks a lot good people, my problem is solved! The action of: Tools> Page info> Media> Blocked images ....... worked perfectly. God bless.