X
Tap here to go to the mobile version of the site.
An updated version of Firefox is available to address the issues with Add-ons disabled or fail to install on Firefox. You can download the update for your OS here: https://www.mozilla.org/firefox/new/ For Known Issues and Workarounds, please check out the update at https://support.mozilla.org/kb/add-ons-disabled-or-fail-to-install-firefox

Support Forum

How do I set FF to always open links in a background tab? (as if ctrl-left click is always on)

Posted

I used to have FF set to to this, but since upgrading to a new laptop, I cannot figure out *how* I set it up to open all links as background tabs. I do have TabMix installed, and obv. I can ctrl-click, but I want that to be the default setting.

I used to have FF set to to this, but since upgrading to a new laptop, I cannot figure out *how* I set it up to open all links as background tabs. I do have TabMix installed, and obv. I can ctrl-click, but I want that to be the default setting.

Chosen solution

In Tools -> Options - Tabs, there is a checkbox for "When I open a new tab, switch to it immediately". Uncheck that box and restart your browser.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Google Update
  • iTunes Detector Plug-in
  • 4.0.60831.0
  • Foxit Reader Plug-In For Firefox and Netscape
  • IE Tab 2 Plug-in for Mozilla/Firefox
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:8.0.1) Gecko/20100101 Firefox/8.0.1

More Information

sctl 35 solutions 219 answers

Chosen Solution

In Tools -> Options - Tabs, there is a checkbox for "When I open a new tab, switch to it immediately". Uncheck that box and restart your browser.

In Tools -> Options - Tabs, there is a checkbox for "When I open a new tab, switch to it immediately". Uncheck that box and restart your browser.

Question owner

Thanks, that was the first thing I did, never worked as I thought it would. I ended up using about:config and finding "browser.tabs.loadDivertedInBackground," switched that to true and things are back to normal.

Thanks, that was the first thing I did, never worked as I thought it would. I ended up using about:config and finding "browser.tabs.loadDivertedInBackground," switched that to true and things are back to normal.