Search Support

FF8 + dialog box popup "application/vnd.wap.xhtml+xml" when accessing a certain website.

  • 4 replies
  • 4 have this problem
  • 268 views
  • Last reply by arinacca

more options

FF8 can't use www.translink.com.au Journey Planner.

When I fill in the fields and click on "Find Journey" - a dialog box pops up

"You have chosen to open journey-planner which is a: application/vnd.wap.xhtml+xml (27.6 KB) from: http://jp.translink.com.au What should Firefox do with this file? Open with browse ... Save file.

Also some other buttons on this website do the same thing, eg. Train journey planner, and on this page: http://translink.com.au/travel-information/services-and-timetables/buses/route-204 - if you click "Show Timetables" button - it does the same thing.

This site worked before ok with FF7 and IE8. Contacted the website's troubleshooter - no reply. Now can't use it and don't know what to do.

Other than this problem FF8 seems to be working ok - so this website is to blame??

Have googled the problem and searched forums for a solution - this is a similar problem to mine: http://support.mozilla.com/en-US/questions/796303?s=application%2Fvnd.wap.xhtml%2Bxml&r=1&as=s

PS - to confirm - I am using a desktop pc with a usb mobile broadband dongle.

Hope someone can help. Thanks in advance.

Modified by arinacca

Chosen solution

"FF8 + dialog box popup "application/vnd.wap.xhtml+xml" when accessing a certain website."

THE PROBLEM ABOVE IS NOW COMPLETELY SOLVED.

The website in question was the problem - NOT Firefox 8 or Linux Mint.

The website has been fixed and now works as it should.

If anyone else gets a similar pop-up dialog box to the above - suggest they contact the problem website's administrator and inform them that their website's user-agent detection is incorrectly identifying your Firefox version as a mobile browser, and therefore redirecting it to a mobile version, returning mobile specific markup (and Content-Type).

Refer to the Whirlpool forum: http://forums.whirlpool.net.au/forum-replies.cfm?t=1821427

and here for a similar problem: http://support.mozilla.com/en-US/questions/796303#answer-158925

As mentioned above, to gain temporary functionality of the problem website while it is being fixed, install the User agent switcher extension -

https://addons.mozilla.org/en-US/firefox/addon/user-agent-switcher/
Read this answer in context 👍 0

All Replies (4)

more options
more options

Hi, This is what I got from those websites:

Browser Information

Shows some of the basic information available in the browser like codename, version, platform and online information.

Test Result

navigator.appName Netscape

navigator.appCodeName Mozilla

navigator.appVersion 5.0 (X11)

navigator.appMinorVersion Property is not supported!

navigator.appMinorVersion is not a string. It's a undefined

navigator.vendor

navigator.userAgent Mozilla/5.0 (Ubuntu; X11; Linux i686; rv:8.0)

Gecko/20100101 Firefox/8.0 . More info...

navigator.oscpu Linux i686 . More info...

navigator.platform Linux i686

navigator.securityPolicy Property is not supported! navigator.securityPolicy is not a string. It's a undefined . More info...

navigator.onLine true . More info...

Info browser.name firefox

Info browser.version 8.0

Info layout.name gecko

Info layout.version 8.0

Info os.name linux

Internet Explorer real version This only works in Microsoft Internet Explorer!

Operating System Linux/Unix - More info...

UserAgent Information

Test Result

UserAgent from header Mozilla/5.0 (Ubuntu; X11; Linux i686; rv:8.0) Gecko/20100101 Firefox/8.0

User Agent from JavaScript Mozilla/5.0 (Ubuntu; X11; Linux i686; rv:8.0) Gecko/20100101 Firefox/8.0

Browser string Mozilla/Netscape 6.x

Operating System Linux/Unix

Browser name Yes - version firefox

Browser version Yes - version 8

Modified by arinacca

more options

Problem is *temporarily* solved.

As per advice I got from this forum: http://forums.whirlpool.net.au/forum-replies.cfm?t=1821427

I installed the Firefox Addon "User Agent Switcher 0.7.3".  

Then when I visit the problem website, before I start using the Journey Planner, I click on Tools>Default User Agent>Internet Explorer>Internet Explorer 8. Then the site works as it should.

When finished using it I change the user agent back to the default.

This is a temporary solution to what seems to be a bug in the website which sees the Firefox version I am using (desktop pc with a usb mobile broadband dongle) as a mobile device.

One other person using Linux Mint 10 + Firefox 8 also had the same trouble, but someone else using OpenSuSE 11.4 + Firefox 8 had no problem using the site.

So it could also be a problem with Linux Mint's version of Firefox 8. (?)

Have submitted a feedback form to the website hoping they'll look into it. Currently they state they support Firefox 4 and 5.

Hope this can help someone else with this problem or similar problem.

more options

Chosen Solution

"FF8 + dialog box popup "application/vnd.wap.xhtml+xml" when accessing a certain website."

THE PROBLEM ABOVE IS NOW COMPLETELY SOLVED.

The website in question was the problem - NOT Firefox 8 or Linux Mint.

The website has been fixed and now works as it should.

If anyone else gets a similar pop-up dialog box to the above - suggest they contact the problem website's administrator and inform them that their website's user-agent detection is incorrectly identifying your Firefox version as a mobile browser, and therefore redirecting it to a mobile version, returning mobile specific markup (and Content-Type).

Refer to the Whirlpool forum: http://forums.whirlpool.net.au/forum-replies.cfm?t=1821427

and here for a similar problem: http://support.mozilla.com/en-US/questions/796303#answer-158925

As mentioned above, to gain temporary functionality of the problem website while it is being fixed, install the User agent switcher extension -

https://addons.mozilla.org/en-US/firefox/addon/user-agent-switcher/

Modified by arinacca