X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Secure Connection Failed on all https sites?

Posted

On all HTTPS sites, I get this message...

Secure Connection Failed

An error occurred during a connection to www.adobe.com. (or whatever site... lynda.com, bill pay sites, banks, etc...)

The OCSP server experienced an internal error.

(Error code: sec_error_ocsp_server_error)

 The page you are trying to view can not be shown because the authenticity of the received data could not be verified.
 Please contact the web site owners to inform them of this problem. Alternatively, use the command found in the help menu to report this broken site.

This happens ever since I updated from FF6 on all sites that use https for logging on... I've contacted most of the sites and they say it's not them... they are all sites that I've accessed in the past and use regularly... now since I've updated FF, they don't work anymore and I've had to use another browser to access these sites... it's a royal pain!

Chosen solution

Thank you very much! That solved it, but is it secure to leave it unchecked?

Thanks again!

Happy Thanksgiving!!

Read this answer in context 0

Additional System Details

Sites Affected

https://www.adobe.com/

Installed Plug-ins

  • Shockwave Flash 11.1 r102
  • Java Plug-In 2 for NPAPI Browsers
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • DivX VOD Helper Plug-in
  • DivX Web Player version 2.1.2.265
  • 4.0.60531.0
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • Coupons Inc Mac Safari Plugin
  • iPhoto6
  • Plugin for viewing Sibelius(tm) music scores http://www.sibelius.com
  • RealPlayer Plugin

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:8.0.1) Gecko/20100101 Firefox/8.0.1

More Information

I tried changing the proxy server settings... didn't work or worse, no connection to anything. I tried to compare proxy settings to safari and other browsers... they all just say they are configured automatically... safari has passive FTP mode (PASV) checked off... FF offers not such choice. This is driving me crazy!

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96959 answers

Check the OCSP settings.

Firefox > Preferences > Advanced > Encryption: Certificates > Validation:

"Use the Online Certificate Status Protocol (OCSP) to confirm the current validity of certificates"
"When an OCSP server connection fails, treat the certificate as invalid"

Question owner

Thanks for your reply... I looked at those settings and both those items are checked off... Are they supposed to be checked off??? Or should I uncheck one of them? Also Validate all certificates using the following OCSP server: Response Signer: Builtin Object Token: Go Daddy Class 2 CA is checked off, I tried unchecking it and checked off Validate a certificate if it specifies an OCSP server... That didn't work, so I switched it back... Any other thoughts on this subject would be much appreciated.

Thanks again!

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96959 answers

You probably need to uncheck the setting at the bottom like that shows as set like I expected.

  • [] "When an OCSP server connection fails, treat the certificate as invalid"

Chosen Solution

Thank you very much! That solved it, but is it secure to leave it unchecked?

Thanks again!

Happy Thanksgiving!!

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96959 answers

The default is the unchecked state as you can see by the value of the security.OCSP.require pref on the about:config page, via the location bar.

TST.LP 0 solutions 1 answers

I fixed this problem with setting up the "Date & Time Properties" in Win XP SP3 !!! Just set them up to date, And everything is fine now.