X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How to stop Google search from going to address bar

Posted

I have a new annoying problem in Firefox 8.0 - when I try typing text in Google search box, the cursor keeps jumping to address bar. How do I prevent this from happening

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.1 r102
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_29 for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.1
  • 4.0.60831.0
  • RealJukebox Netscape Plugin
  • RealNetworks(tm) RealPlayer Chrome Background Extension Plug-In
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 12.0.1.647
  • LogMeIn, Inc. Remote Access Components
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • P3 Remote Control
  • Office Authorization plug-in for NPAPI browsers
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • np-mswmp

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; WOW64; rv:8.0) Gecko/20100101 Firefox/8.0

More Information

Whenever I click inside Google search box and start to type text, the cursor jumps to the Firefox address bar. Help!!! This is driving me nuts as I do many searches daily.

cor-el
  • Top 10 Contributor
  • Moderator
10777 solutions 97000 answers

That issue can be caused by an extension that isn't working properly.

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

Question owner

How do I "start Firefox in Safe Mode"? Sounds complicated.

Vivek 310 solutions 2084 answers

In the Run... (or press Windows key + R) dialog box type firefox -safe-mode and OK. If that doesn't work Search for firefox.exe and in the results right-click firefox.exe > Properties, copy the Location by highlighting it and then instead of just firefox prefix that location in double quotes eg. "C:\Program Files(x86)\Mozilla Firefox\firefox.exe" -safe-mode

If the problem persists in Safe Mode, you may want to check if the Alt keys of the keyboard are stuck. The combination of Alt + D is a shortcut to highlight the address bar.

Modified by Vivek

Question owner

When I look p properties, I get this: C:\Program Files (x86)\Mozilla Firefox

Then what?

Vivek 310 solutions 2084 answers

"C:\Program Files (x86)\Mozilla Firefox\firefox.exe" -safe-mode

First make sure that Firefox is not running and then type the above into the Run... (Windows key + R) dialog box and click OK. This will start Firefox in Safe Mode. You can read more about the Safe Mode, the different ways to start Firefox in Safe Mode and troubleshooting tips in the links given by cor-el.

Modified by Vivek

cor-el
  • Top 10 Contributor
  • Moderator
10777 solutions 97000 answers

In Firefox 4+ versions you can use one of these to start in Safe mode:

  • Help > Restart with Add-ons Disabled
  • Hold down the Shift key while double clicking the Firefox desktop shortcut (Windows)

Question owner

I am really lost. If I started Firefox in Safe mode, then what? more complicated instructions to follow? I don't quite get what it is that I need to do. I gather that I need to track down which extensions is the culprit, and uninstall/delete it? I'm not sure I have the experience level or skills to do this. All I want is to stop the cursor from jumping to the address bar whenever I try to type key word in Google search engine!

cor-el
  • Top 10 Contributor
  • Moderator
10777 solutions 97000 answers

If it does work in Safe-mode then disable all extensions and then try to find which is causing it by enabling one at a time until the problem reappears.

  • Use "Disable all add-ons" on the Troubleshoot Firefox issues using Safe Mode start window to disable all extensions.
  • Close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit")
MaccaUK 0 solutions 1 answers

This seems to be caused by the add-on "New Tab Homepage". Disabling this and using NewTabURL (2.2.3) seemed to solve the problem for me.

HTH